%%ItemTitle%%

Quality Center Database

Quality Center Database

Description

Quality Center data.

Remarks

The project database stores system information, some user information, and information produced while using the Quality Center modules.

The Requirements Module

Requirements data is stored primarily in the REQ Table. For more details, see the Requirements Module Overview.

The Test Plan Module

In the Test Plan module, the user defines the subjects to be tested and designs tests that relate to each test. The main table is the TEST Table. For more details, see the Test Plan Module Overview.

The Test Lab Module

In the Test Lab Module, the user organizes design tests in ordered groups called Test Sets that will usually run as a testing unit. The main table is the CYCLE Table. For more details, see the Test Lab Module Overview.

The Business Components Module

In the Business Components Module, subject matter experts create high-level components that represent steps in the business process. The main table is the COMPONENT Table. For more details, see the Business Process Overview.

The Defect Module

In the defect module, QA engineers and others report problems with the application, such as test run failures and incidentally observed problems. The main table is the BUG Table. For more details, see the Defect Module Overview.

The Releases Module

The Releases module handles information about releases and development cycles. Release information is stored in several tables, depending on the subject. See the Releases Overview.

The Customization Module

The Customization module handles meta-properties for a project. Customization is stored in several tables, depending on the subject. See the Customization Overview.

History

Changes to data are tracked in the AUDIT_LOG and AUDIT_PROPERTIES Tables.

Alerts and Reminders

Alerts are maintained in the ALERT and RULES Tables.

Disclaimer:
This database reference is provided for informational purposes. Mercury reserves the right to change the database structure and does not commit to preserving compatibility between Quality Center versions.

Tables

Table | Description
ACTIONS | Permissions on user actions performed from the user interface.
ALERT | Information for managing automatic alerts and user-defined follow ups.
ALL_LISTS | System and custom lists and folder trees.
AUDIT_LOG | Events on which history is recorded.
AUDIT_PROPERTIES | Details of the changes recorded in the AUDIT_LOG table.
BP_ITER_PARAM | The design-time value of a business component parameter for a specific iteration.
BP_ITERATION | The order of component iterations in a test.
BP_PARAM | Associates a parameter to a test and component.
BP_STEP_PARAM | Values of business component parameters with relation to run steps.
BPTEST_TO_COMPONENTS | Iteration settings and order of execution for Business Process Components in the context of the design tests that contain them.
BUG | Information about defects.
BUG_MULTIVALUE | Multiple values for defect records.
BUG_TOKENS | An associative table linking defects and tokens.
CACHE | The Cache table is for internal use. Do not change data.
COMMON_SETTINGS | User settings and third party data.
COMPONENT | Business Process Components.
COMPONENT_FOLDER | Business Process Component Folders.
COMPONENT_STEP | Steps of Business Process Components.
COMPONENT_STEP_PARAMS | An associative table linking the Business Process Component steps to their parameters.
CROS_REF | Attachments.
CYCL_FOLD | The test set folder tree.
CYCLE | Test sets.
CYCLE_MULTIVALUE | Multiple values for test set records.
DATACONST | Global project constants.
DESSTEPS | A single step of a Design Test in Test Plan module.
EXTENSIONS | The Quality Center extensions that are enabled for this project.
FRAMEWORK_PARAM | Parameters for Business Process Components.
GROUPS | Groups of users with a common set of privileges.
HOST_GROUP | Logical groups of computers.
HOST_IN_GROUP | An associative table that links HOSTS with HOST_GROUPs.
HOSTS | Computers on the network.
LINK | Associations between defects and other entities.
LOCKS | Locks to control access to the same item by different user sessions. For internal use. Do not change values in this table.
MAILCOND | Rules for sending defect notifications to individual users.
MODULES | Permissions by group for accessing modules in the user interface.
RBT_CUSTOMIZATION | Risk-based quality management settings.
RBT_CUSTOMIZATION_ANSWERS | Possible values for risk-based quality management criteria.
RBT_CUSTOMIZATION_QUESTIONS | Risk-based quality management criteria.
RELEASE_CYCLES | Details of cycles. A release can contain a number of cycles.
RELEASE_FOLDERS | Folders for release records.
RELEASE_MULTIVALUE | Multiple values for release records.
RELEASECYCLE_MULTIVALUE | Multiple values for release cycle records.
RELEASEFOLDER_MULTIVALUE | Multiple values for release folder records.
RELEASES | Information about a product release.
REPOSITORY | Storage for database simulation of file system.
REQ | Details of individual requirements and the structure of the requirements tree.
REQ_COVER | An associative table linking requirements to the design tests and test instances in test sets that cover the requirements.
REQ_CYCLES | An associative table linking requirements to release cycles.
REQ_MULTIVALUE | Multiple values for requirement records.
REQ_RELEASES | An associative table linking requirements to releases.
REQ_TRACE | Associations between requirements.
REQ_TYPE | Types of requirements.
REQ_TYPE_FIELD | Specifies which fields are required for each requirement type.
REQ_TYPE_HIER_RULES | The hierarchy rules for requirement types in the requirement tree. For internal use. Do not change values in this table.
RULES | Conditions for generating automatic alerts.
RUN | Execution records for test instances.
RUN_MULTIVALUE | Multiple values for run records.
RUNTIME_PARAM | Parameters defined at design time for Business Process Tests.
SEQUENCES | A system table to manage IDs and other system numerators. Do not change values in this table.
STEP | Test steps performed during a test instance runs.
STEP_PARAMS | Parameters for executing manual tests.
SYSTEM_FIELD | Meta-data about data fields in other tables. Stores settings from project entity customizations and system defaults.
SYSTRANSLATE | For backward compatablity. This table may be removed in future versions.
TABLES | Permissions by user group to change data.
TEST | Details of the design test from the test plan module.
TEST_MULTIVALUE | Multiple values of test records.
TEST_VC_INFO | Used internally by version control plug-in. Do not change values in this table.
TESTCYCL | Instances of design tests in test sets.
TESTCYCL_MULTIVALUE | Multiple values of test cycle - test instance records.
TO_ALERT | For internal use. Do not change data in this table.
TOKENS | Assists in searching for similar defects.
TRAN_RULES | Permitted status changes per group.
USERS | System users who can access this project.
VC_CROS_REF | Version control table for attachments.
VC_DESSTEPS | Version control table for design steps.
VC_STEP_PARAMS | Version Control table for step parameters.
VC_TEST | Version control table for tests. Details of the design test from the test plan module.
VC_TEST_MULTIVALUE | Multiple values for records of tests under version control.
VER_CTRL | Version control locking.

Copyright 2002-2007 Mercury Interactive Corporation.

Documentation comments or suggestions?
Please send feedback to SW-Doc@hp.com


Requirements Module

Quality Center Database

Requirements Module Overview

The Requirements Module

Requirements data is stored primarily in the REQ Table.

Main Table Relations

req_cover testcycl test req


Requirements Module

Quality Center Database

Test Plan Module Overview

The Test Plan Module

In the Test Plan module, the user defines the subjects to be tested and designs tests that relate to each subject. A design test can have design test steps and design parameters. Tests generally are designed to cover requirements.

The test subjects are in the ALL_LISTS Table.

Design tests are stored in the TEST Table. These tests are the basis for later test sets and test runs. The design steps that provide more detail for the tests are in the DESSTEPS Table. Design step parameters are stored with parameters for other levels in the STEP_PARAMS Table.

Design tests are linked to the requirements they cover in the REQ_COVER Table.

Main Table Relations

test all_lists dessteps req_cover step_params req


Test Lab Module

Quality Center Database

Test Lab Module Overview

The Test Lab Module

In the Test Lab Module, the user organizes design tests in ordered groups called test sets that will usually run as a testing unit. A design test may be used more than once in a test set. Each use is called a test instance. The module is also used to perform the actual testing.

Test sets are stored in the CYCLE Table, while their logical organization is in the CYCL_FOLD Table. The design tests that comprise the test sets are linked to the test sets in the TESTCYCL Table.

The result data from running tests or test sets is in the RUN Table. There is a record for each run of each test instance.

The Test Lab module also provides the data in the HOSTS and HOST_GROUP tables.

Main Table Relations

test step_params cycl_fold run testcycl cycle


Defects Module

Quality Center Database

Defects Module Overview

The Defects Module

In the Defects module, QA engineers and others report problems with the application, such as test run failures and incidentally observed problems. Depending on the user organization processes, the module can also be customized and be used to request new features, etc. The information entered in the Defects module is stored in the BUG Table.

Defects can be linked to each other and to other entities. The links are maintained in the LINK Table.

Main Table Relations

link all lists bug


Business Components Module

Quality Center Database

Business Components Module Overview

The Business Components Module

In the Business Components Module, subject matter experts create high-level components that represent steps in the business process. These are stored in the COMPONENT Table. Their logical organization is in the COMPONENT_FOLDER Table.

The breakdown of a component into business steps is captured in the COMPONENT_STEP Table. The parameters for running the steps are in the FRAMEWORK_PARAM Table.

Main Table Relations

component_step_params bptest_to_components component_folder component step bp_interation framework_param component bp_iter_param test bp_param testcycl runtime param


Customization Module

Quality Center Database

Customization Module Overview

The Customization Module

The Customization module handles meta-properties for a project. For example, it handles settings that affect individual users, groups of users, and user and group access rights.

Customization Tables

Table | Description
ACTIONS table | Permissions on user actions performed from the user interface.
ALL_LISTS table | System and custom lists and folder trees.
COMMON_SETTINGS table | User settings and third party data.
DATACONST table | Global project constants.
EXTENSIONS table | The Quality Center extensions that are enabled for this project.
GROUPS table | Groups of users with a common set of privileges.
HOSTS table | Computers on the network.
HOST_GROUP table | Logical groups of computers.
MAILCOND table | Rules for sending defect notifications to individual users.
RBT_CUSTOMIZATION table | Risk-based quality management settings.
RBT_CUSTOMIZATION_ANSWERS table | Possible values for risk-based quality management criteria.
RBT_CUSTOMIZATION_QUESTIONS table | Risk-based quality management criteria.
REQ_TYPE table | Types of requirements.
REQ_TYPE_FIELD table | Specifies which fields are required for each requirement type.
RULES table | Conditions for generating automatic alerts.
SYSTEM_FIELD table | Meta-data about data fields in other tables. Stores settings from project entity customizations and system defaults.
USERS table | System users who can access this project.


Releases

Quality Center Database

Releases Module Overview

The Releases Module

The Releases module contains release folders, releases, and cycles. Entities in other modules, such as requirements, defects, and test set folders, can be associated with releases and cycles.

Releases Tables

Table | Description
RELEASES table | Information about a product release.
RELEASE_CYCLES table | Information about release cycles. A release can contain several cycles.
RELEASE_FOLDERS table | Folders for release records.
REQ_CYCLES table | An associative table linking requirements to release cycles.
REQ_RELEASES table | An associative table linking requirements to releases.


%%LocalItemTitle%%

See Also

Quality Center Database

See Also Quality Center Database

ACTIONS Table

Description

Permissions on user actions performed from the user interface.

Columns

 | Column Name | Description | Datatype | Length | Allow Nulls
Primary Key | AC_ACTION_NAME | The name of the action. | VarChar | 40 |
 | AC_IS_SYSTEM_INTERNAL | For backward compatibility. Field may be removed in future version. | VarChar | 1 |
 | AC_GRANT_MASK | A bit mask that specifies the groups whose members may perform the action. If bit X is set, the action is enabled for the group identified with GROUPS.GR_GROUP_ID = X. | VarChar | 512 |
 | AC_OWNER_SENSIBLE | For backward compatibility. Field may be removed in future version. | VarChar | 512 |
 | AC_OWNERED_TABLE | For backward compatibility. Field may be removed in future version. | VarChar | 40 |
 | AC_IS_COLUMNS_MODIFY | For backward compatibility. Field may be removed in future version. | VarChar | 1 |
 | AC_IS_AUDIT | For future use. | VarChar | 1 |

Indexes

Index | Primary | Unique
AC_PRIMARYKEY |  |

See Also

Quality Center Database


%%LocalItemTitle%%

ACTIONS Table | Quality Center Database

AC_PRIMARYKEY Index

Index Properties

Primary Key | Yes
Unique Values | Yes

Columns

 | Column | Sort Order
Primary Key | AC_ACTION_NAME | Ascending

See Also

ACTIONS Table | Quality Center Database


%%LocalItemTitle%%

Quality Center Database

ALERT Table

Description

Information for managing automatic alerts and user-defined follow ups.

Remarks

Alerts are automatically generated using the data in the RULES table, while follow-ups are user-defined reminders that are set by the user.

Columns

 | Column Name | Description | Datatype | Length | Allow Nulls
Primary Key | AT_ID | The record ID. | Integer | 4 |
 | AT_USER | The owner of the alert or follow-up. | VarChar | 60 |
 | AT_ENTITY_TYPE | The name of the table containing the entity to which the alert applies. | VarChar | 50 |
 | AT_KEY1 | The ID of the entity in the table specified by AT_ENTITY_TYPE. | Integer | 4 |
 | AT_KEY2 | For backward compatibility. Field may be removed in future version. | Integer | 4 |
 | AT_KEY3 | For backward compatibility. Field may be removed in future version. | Integer | 4 |
 | AT_DESCRIPTION | The description of the alert. | LongVarChar | 16 |
 | AT_DATE | Either the date and time the alert was sent or the date the follow-up is configured to be sent. | DBTimeStamp | 4 |
 | AT_SENT_BY_EMAIL | Indicates whether the follow-up was emailed. Y or N. | VarChar | 1 |
 | AT_ALERT_TYPE | The type of alert created. 1 for Follow-up. 2 for automatic alert. | Integer | 4 |
 | AT_ALERT_STATUS | Indicates whether the alert has been read. 1 if read. 0 if still unread. | Integer | 4 |

Indexes

Index | Primary | Unique
AT_PRIMARYKEY |  |
ALERT_IX2 |  |
AT_ENTITY_KEY_IDX |  |

See Also

Quality Center Database


%%LocalItemTitle%%

ALERT Table | Quality Center Database

ALERT_IX2 Index

Index Properties

Primary Key | No
Unique Values | No

Columns

Column | Sort Order
AT_KEY1 | Ascending
AT_ENTITY_TYPE | Ascending
AT_ALERT_TYPE | Ascending

See Also

ALERT Table | Quality Center Database


%%LocalItemTitle%%

ALERT Table | Quality Center Database

AT_ENTITY_KEY_IDX Index

Index Properties

Primary Key | No
Unique Values | No

Columns

Column | Sort Order
AT_ENTITY_TYPE | Ascending
AT_KEY1 | Ascending

See Also

ALERT Table | Quality Center Database


%%LocalItemTitle%%

ALERT Table | Quality Center Database

AT_PRIMARYKEY Index

Index Properties

Primary Key | Yes
Unique Values | Yes

Columns

 | Column | Sort Order
Primary Key | AT_ID | Ascending

See Also

ALERT Table | Quality Center Database


%%LocalItemTitle%%

Quality Center Database

ALL_LISTS Table

Description

System and custom lists and folder trees.

Remarks

Folder structures are recreated with a self-join of ALL_LISTS parent and ALL_LISTS child where child.AL_FATHER_ID = parent.AL_ITEM_ID. For top level nodes, AL_FATHER_ID = 0.

In addition, each child node inherits the AL_ABSOLUTE_PATH of its parent node and appends three more characters. For example, the children of the node with path AAAAAA have paths AAAAAAA, AAAAAAB, AAAAAAC, and so on.

Columns

 | Column Name | Description | Datatype | Length | Allow Nulls
Primary Key | AL_ITEM_ID | The record ID. | Integer | 4 |
 | AL_FATHER_ID | The ID of the parent folder, list, or list item. Tree and list roots have AL_FATHER_ID = 0. | Integer | 4 |
 | AL_DESCRIPTION | The item description. | VarChar | 255 |
 | AL_NO_OF_SONS | The number of immediate child nodes (not including children of those children). | Integer | 4 |
 | AL_SYSTEM | The permissions for the item: R - read-only but can add sub-folders. S - system field (Quality Center does not permit changes to this field). A - all actions are available. C - can change but not delete. | VarChar | 1 |
 | AL_ABSOLUTE_PATH | An alphabetic code showing the folder tree structure. List and root nodes have a six-letter path from AAAAAA to ZZZZZZ | VarChar | 255 |
 | AL_VIEW_ORDER | The display order of this child item when the parent node is expanded in the user interface. | Integer | 4 |
 | AL_MEMO | A descriptive comment. | LongVarChar | 16 |
 | AL_ATTACHMENT | A Value of Y indicates that the item has at least one attachment. | VarChar | 1 |
 | AL_ITEM_VERSION | For backward compatibility. Field may be removed in future version. | Integer | 4 |
 | AL_VER_STAMP | The revision number of this item. Increments each time the record is updated. | Integer | 4 |
 | AL_VTS | The version time stamp. Indicates the database-server time the record was last changed. | VarChar | 20 |

Indexes

Index | Primary | Unique
AL_ABS_PATH_COV_IDX |  |
AL_ABSOLUTE_PATH_IDX |  |
AL_FATHER_DESC_LWR_IDX |  |
AL_PRIMARYKEY |  |

See Also

Quality Center Database


%%LocalItemTitle%%

ALL_LISTS Table | Quality Center Database

AL_ABS_PATH_COV_IDX Index

Description

Index Properties

Primary Key | Yes
Unique Values | Yes

Columns

 | Column | Sort Order
Primary Key | AL_ITEM_ID | Ascending
 | AL_ABSOLUTE_PATH | Ascending

Description

See Also

ALL_LISTS Table | Quality Center Database


%%LocalItemTitle%%

ALL_LISTS Table | Quality Center Database

AL_ABSOLUTE_PATH_IDX Index

Description

Index Properties

Primary Key | No
Unique Values | Yes

Columns

Column | Sort Order
AL_ABSOLUTE_PATH | Ascending

Description

See Also

ALL_LISTS Table | Quality Center Database


%%LocalItemTitle%%

ALL_LISTS Table | Quality Center Database

AL_FATHER_DESC_LWR_IDX Index

Description

Index Properties

Primary Key | No
Unique Values | Yes

Columns

Column | Sort Order
AL_FATHER_ID | Ascending
AL_DESCRIPTION | Ascending

Description

See Also

ALL_LISTS Table | Quality Center Database


%%LocalItemTitle%%

ALL_LISTS Table | Quality Center Database

AL_PRIMARYKEY Index

Description

Index Properties

Primary Key | Yes
Unique Values | Yes

Columns

 | Column | Sort Order
Primary Key | AL_ITEM_ID | Ascending

Description

See Also

ALL_LISTS Table | Quality Center Database


%%LocalItemTitle%%

Quality Center Database

AUDIT_LOG Table

Description

Events on which history is recorded.

Remarks

Details of the changes caused by the audited events are in the AUDIT_PROPERTIES Table.

Columns

 | Column Name | Description | Datatype | Length | Allow Nulls
Primary Key | AU_ACTION_ID | The record ID. | Integer | 4 |
 | AU_FATHER_ID | For backward compatibility. Field may be removed in future version. | Integer | 4 |
 | AU_USER | The user name of the user who performed the action. | VarChar | 2000 |
 | AU_SESSION_ID | The Quality Center session ID of the session in which the action was performed. | Integer | 4 |
 | AU_TIME | The timestamp of the audit record according to the database server clock. | DBTimeStamp | 4 |
 | AU_ACTION | The type of event. For example: INSERT, UPDATE, DELETE, and so on. | VarChar | 200 |
 | AU_ENTITY_TYPE | The name of the table in which the change occurred. | VarChar | 200 |
 | AU_ENTITY_ID | The record ID of the changed record in the table specified by AU_ENTITY_TYPE. | VarChar | 200 |
 | AU_DESCRIPTION | The audit record description. | LongVarChar | 16 |

Indexes

Index | Primary | Unique
AU_PRIMARYKEY |  |
AU_ENTITY_TYPE_ENTITY_ID_IDX |  |

See Also

Quality Center Database


%%LocalItemTitle%%

AUDIT_LOG Table | Quality Center Database

AU_ENTITY_TYPE_ENTITY_ID_IDX Index

Description

Index Properties

Primary Key | No
Unique Values | No

Columns

Column | Sort Order
AU_ENTITY_TYPE | Ascending
AU_ENTITY_ID | Ascending

Description

See Also

AUDIT_LOG Table | Quality Center Database


%%LocalItemTitle%%

AUDIT_LOG Table | Quality Center Database

AU_PRIMARYKEY Index

Description

Index Properties

Primary Key | Yes
Unique Values | Yes

Columns

 | Column | Sort Order
Primary Key | AU_ACTION_ID | Ascending

Description

See Also

AUDIT_LOG Table | Quality Center Database


%%LocalItemTitle%%

Quality Center Database

AUDIT_PROPERTIES Table

Description

Details of the changes recorded in the AUDIT_LOG table.

Remarks

For any given record, only the fields relevant to the type of the changed data have values. Fields for other data types are NULL.

Columns

 | Column Name | Description | Datatype | Length | Allow Nulls
Primary Key | AP_PROPERTY_ID | The record ID. | Integer | 4 |
 | AP_ACTION_ID | The audit log record: AUDIT_LOG.AU_ACTION_ID | Integer | 4 |
 | AP_TABLE_NAME | If the property change was saved in the database, the name of the table in which the change occurred. | VarChar | 40 |
 | AP_FIELD_NAME | If the property change was saved in the database, the field (column) that was changed. | VarChar | 40 |
 | AP_PROPERTY_NAME | If the property change was saved in the database, the user-defined label for the field that was changed (SYSTEM_FIELD.SF_USER_LABEL). If not a database field, the name of the property. | VarChar | 50 |
 | AP_OLD_VALUE | The value before the change for types other than timestamp or large object fields. If there is no previous value, or if timestamp or large object, NULL. | VarChar | 2000 |
 | AP_NEW_VALUE | The value resulting from the change for types other than timestamp or large object fields. NULL for timestamp and large object. | VarChar | 2000 |
 | AP_OLD_LONG_VALUE | The value before the change for large object fields. If there is no previous value or if not a large object, NULL. | LongVarChar | 16 |
 | AP_NEW_LONG_VALUE | The value resulting from the change for large object fields, such as memo fields. If not a large object, NULL. | LongVarChar | 16 |
 | AP_OLD_DATE_VALUE | The value before the change for timestamp fields. If there is no previous value or if not a timestamp , NULL. | DBTimeStamp | 4 |
 | AP_NEW_DATE_VALUE | The value resulting from the change for timestamp fields. If not a timestamp , NULL. | DBTimeStamp | 4 |

Indexes

Index | Primary | Unique
AP_PRIMARYKEY |  |
AP_ACTION_IDX |  |
AP_TABLE_NAME_FIELD_NAME_IDX |  |

See Also

Quality Center Database


%%LocalItemTitle%%

AUDIT_PROPERTIES Table | Quality Center Database

AP_ACTION_IDX Index

Description

Index Properties

Primary Key | No
Unique Values | No

Columns

Column | Sort Order
AP_ACTION_ID | Ascending

Description

See Also

AUDIT_PROPERTIES Table | Quality Center Database


%%LocalItemTitle%%

AUDIT_PROPERTIES Table | Quality Center Database

AP_PRIMARYKEY Index

Description

Index Properties

Primary Key | Yes
Unique Values | Yes

Columns

 | Column | Sort Order
Primary Key | AP_PROPERTY_ID | Ascending

Description

See Also

AUDIT_PROPERTIES Table | Quality Center Database


%%LocalItemTitle%%

AUDIT_PROPERTIES Table | Quality Center Database

AP_TABLE_NAME_FIELD_NAME_IDX Index

Description

Index Properties

Primary Key | No
Unique Values | No

Columns

Column | Sort Order
AP_TABLE_NAME | Ascending
AP_FIELD_NAME | Ascending

Description

See Also

AUDIT_PROPERTIES Table | Quality Center Database


%%LocalItemTitle%%

Quality Center Database

BP_ITER_PARAM Table

Description

The design-time value of a business component parameter for a specific iteration.

Columns

 | Column Name | Description | Datatype | Length | Allow Nulls
Primary Key | BPIP_ID | The record ID. | Integer | 4 |
 | BPIP_BPP_ID | The link to the test, component, and parameter through BP_PARAM.BPP_ID. | Integer | 4 |
 | BPIP_BPI_ID | The iteration: BP_ITERATION.BPI_ID | Integer | 4 |
 | BPIP_VALUE | The default value for the iteration. | LongVarChar | 16 |

Indexes

Index | Primary | Unique
BP_ITER_PARAM_PRIMARYKEY |  |
BPIP_BPI_ID_IDX |  |
BPIP_BPP_ID_IDX |  |

See Also

Quality Center Database


%%LocalItemTitle%%

BP_ITER_PARAM Table | Quality Center Database

BP_ITER_PARAM_PRIMARYKEY Index

Description

Index Properties

Primary Key | Yes
Unique Values | Yes

Columns

 | Column | Sort Order
Primary Key | BPIP_ID | Ascending

Description

See Also

BP_ITER_PARAM Table | Quality Center Database


%%LocalItemTitle%%

BP_ITER_PARAM Table | Quality Center Database

BPIP_BPI_ID_IDX Index

Index Properties

Primary Key | No
Unique Values | No

Columns

Column | Sort Order
BPIP_BPI_ID | Ascending

See Also

BP_ITER_PARAM Table | Quality Center Database


%%LocalItemTitle%%

BP_ITER_PARAM Table | Quality Center Database

BPIP_BPP_ID_IDX Index

Index Properties

Primary Key | No
Unique Values | No

Columns

Column | Sort Order
BPIP_BPP_ID | Ascending

See Also

BP_ITER_PARAM Table | Quality Center Database


%%LocalItemTitle%%

Quality Center Database

BP_ITERATION Table

Description

The order of component iterations in a test.

Columns

 | Column Name | Description | Datatype | Length | Allow Nulls
Primary Key | BPI_ID | The record ID. | Integer | 4 |
 | BPI_BPC_ID | The link to the test and component through BPTEST_TO_COMPONENTS.BC_ID. | Integer | 4 |
 | BPI_ORDER | The 0-based order of this iteration. If there is only one iteration, this field may be empty. | Integer | 4 |

Indexes

Index | Primary | Unique
BP_ITERATION_PRIMARYKEY |  |
BPI_BPC_ID_IDX |  |

See Also

Quality Center Database


%%LocalItemTitle%%

BP_ITERATION Table | Quality Center Database

BP_ITERATION_PRIMARYKEY Index

Description

Index Properties

Primary Key | Yes
Unique Values | Yes

Columns

 | Column | Sort Order
Primary Key | BPI_ID | Ascending

Description

See Also

BP_ITERATION Table | Quality Center Database


%%LocalItemTitle%%

BP_ITERATION Table | Quality Center Database

BPI_BPC_ID_IDX Index

Description

Index Properties

Primary Key | No
Unique Values | No

Columns

Column | Sort Order
BPI_BPC_ID | Ascending

Description

See Also

BP_ITERATION Table | Quality Center Database


%%LocalItemTitle%%

Quality Center Database

BP_PARAM Table

Description

Associates a parameter to a test and component.

Columns

 | Column Name | Description | Datatype | Length | Allow Nulls
Primary Key | BPP_ID | The record ID. | Integer | 4 |
 | BPP_BPC_ID | The link to the test and component through BPTEST_TO_COMPONENTS.BC_ID. | Integer | 4 |
 | BPP_PARAM_ID | The parameter: FRAMEWORK_PARAM.FP_ID | Integer | 4 |
 | BPP_TYPE | The type, such as CONSTANT for an entered value or REF_BPPARAM for a value read from another parameter. | VarChar | 70 |
 | BPP_REF_ID | When the value of this parameter is set at run-time to the value of another parameter, this is the BPP_ID of the parameter from which the value is taken. | Integer | 4 |

Indexes

Index | Primary | Unique
BP_PARAM_PRIMARYKEY |  |
BPP_BPC_ID_IDX |  |
BPP_PARAM_ID_IDX |  |

See Also

Quality Center Database


%%LocalItemTitle%%

BP_PARAM Table | Quality Center Database

BP_PARAM_PRIMARYKEY Index

Description

Index Properties

Primary Key | Yes
Unique Values | Yes

Columns

 | Column | Sort Order
Primary Key | BPP_ID | Ascending

Description

See Also

BP_PARAM Table | Quality Center Database


%%LocalItemTitle%%

BP_PARAM Table | Quality Center Database

BPP_BPC_ID_IDX Index

Description

Index Properties

Primary Key | No
Unique Values | No

Columns

Column | Sort Order
BPP_BPC_ID | Ascending

Description

See Also

BP_PARAM Table | Quality Center Database


%%LocalItemTitle%%

BP_PARAM Table | Quality Center Database

BPP_PARAM_ID_IDX Index

Description

Index Properties

Primary Key | No
Unique Values | No

Columns

Column | Sort Order
BPP_PARAM_ID | Ascending

Description

See Also

BP_PARAM Table | Quality Center Database


%%LocalItemTitle%%

Quality Center Database

BP_STEP_PARAM Table

Description

Values of business component parameters with relation to run steps.

Columns

 | Column Name | Description | Datatype | Length | Allow Nulls
Primary Key | BPSP_ID | The record ID. | Integer | 4 |
 | BPSP_RUN_ID | The RUN.RN_RUN_ID | Integer | 4 |
 | BPSP_STEP_ID | The step in which this value is used: STEP.ST_ID. | Integer | 4 |
 | BPSP_REF_ID | If the value of a parameter is not entered, but is taken from another parameter's value at run time, this is the BPSP_ID of the source parameter. | Integer | 4 |
 | BPSP_IS_OUT | The type of parameter: R - Run time parameter. N - Design-time input parameter. Y - Design-time output parameter. | VarChar | 1 |
 | BPSP_NAME | The parameter name. | VarChar | 255 |
 | BPSP_VALUE | The parameter value. | LongVarChar | 16 |

Indexes

Index | Primary | Unique
BPSP_PRIMARYKEY |  |
BP_STEP_PARAM_IDX2 |  |
BPSP_RUN_ID_IDX |  |

See Also

Quality Center Database


%%LocalItemTitle%%

BP_STEP_PARAM Table | Quality Center Database

BP_STEP_PARAM_IDX2 Index

Index Properties

Primary Key | No
Unique Values | No

Columns

Column | Sort Order
BPSP_REF_ID | Ascending
BPSP_STEP_ID | Ascending

See Also

BP_STEP_PARAM Table | Quality Center Database


%%LocalItemTitle%%

BP_STEP_PARAM Table | Quality Center Database

BPSP_PRIMARYKEY Index

Description

Index Properties

Primary Key | Yes
Unique Values | Yes

Columns

 | Column | Sort Order
Primary Key | BPSP_ID | Ascending

Description

See Also

BP_STEP_PARAM Table | Quality Center Database


%%LocalItemTitle%%

BP_STEP_PARAM Table | Quality Center Database

BPSP_RUN_ID_IDX Index

Index Properties

Primary Key | No
Unique Values | No

Columns

Column | Sort Order
BPSP_RUN_ID | Ascending

See Also

BP_STEP_PARAM Table | Quality Center Database


%%LocalItemTitle%%

Quality Center Database

BPTEST_TO_COMPONENTS Table

Description

Iteration settings and order of execution for Business Process Components in the context of the design tests that contain them.

Columns

 | Column Name | Description | Datatype | Length | Allow Nulls
Primary Key | BC_ID | The record ID | Integer | 4 |
 | BC_BPT_ID | The test: TEST.TS_TEST_ID | Integer | 4 |
 | BC_CO_ID | The component: COMPONENT.CO_ID | Integer | 4 |
 | BC_VER_STAMP | For backward compatibility. Field may be removed in future version. | Integer | 4 |
 | BC_ORDER | The 1-based order of the component in the test. | Integer | 4 |
 | BC_FAIL_COND | Action to take on failure: Continue or Exit. | VarChar | 70 |
 | BC_GROUP | Where components are grouped in a test for group iterations, the identifying number of the group to which the component belongs. Note that this number does not indicate order. | Integer | 4 |
 | BC_DESC | For backward compatibility. Field may be removed in future version. | LongVarChar | 16 |
 | BC_RUNFROM_ITERATION | If not all iterations defined are to be run, the number of the first defined iteration to be run (1-based). If all iterations are run, value is -1. | Integer | 4 |
 | BC_RUNTO_ITERATION | If not all iterations defined are to be run, the number of the last defined iteration to be run. If all iterations are run, value is -1. | Integer | 4 |

Indexes

Index | Primary | Unique
FW_BC_PRIMARYKEY |  |
BC_BPT_ID_IDX |  |
BC_CO_ID_IDX |  |

See Also

Quality Center Database


%%LocalItemTitle%%

BPTEST_TO_COMPONENTS Table | Quality Center Database

BC_BPT_ID_IDX Index

Description

Index Properties

Primary Key | No
Unique Values | No

Columns

Column | Sort Order
BC_BPT_ID | Ascending

Description

See Also

BPTEST_TO_COMPONENTS Table | Quality Center Database


%%LocalItemTitle%%

BPTEST_TO_COMPONENTS Table | Quality Center Database

BC_CO_ID_IDX Index

Description

Index Properties

Primary Key | No
Unique Values | No

Columns

Column | Sort Order
BC_CO_ID | Ascending

Description

See Also

BPTEST_TO_COMPONENTS Table | Quality Center Database


%%LocalItemTitle%%

BPTEST_TO_COMPONENTS Table | Quality Center Database

FW_BC_PRIMARYKEY Index

Description

Index Properties

Primary Key | Yes
Unique Values | Yes

Columns

 | Column | Sort Order
Primary Key | BC_ID | Ascending

Description

See Also

BPTEST_TO_COMPONENTS Table | Quality Center Database


%%LocalItemTitle%%

Quality Center Database

BUG Table

Description

Information about defects.

Remarks

For table relationships, see the Defect Module Overview.

Columns

 | Column Name | Description | Datatype | Length | Allow Nulls
Primary Key | BG_BUG_ID | The defect record ID. | Integer | 4 |
 | BG_STATUS | The current status of the defect. The values are from the Bug Status custom list. Typical values are: Open, Fixed, Closed, New, Rejected, and Reopen. | VarChar | 70 |
 | BG_RESPONSIBLE | The name of the developer responsible for fixing the defect. | VarChar | 60 |
 | BG_PROJECT | The name of the project in which the defect was found. The values are from the All Projects custom list. | VarChar | 70 |
 | BG_SUBJECT | The subject in the test plan tree to which the bug is related: ALL_LISTS.AL_ITEM_ID. | Integer | 4 |
 | BG_SUMMARY | A summary of the defect. | VarChar | 255 |
 | BG_DESCRIPTION | A description of the defect. | LongVarChar | 16 |
 | BG_DEV_COMMENTS | Comments about the defect, usually by the developer responsible for the defect. | LongVarChar | 16 |
 | BG_REPRODUCIBLE | Indicates whether the tester was able to reproduce the defect. | VarChar | 1 |
 | BG_SEVERITY | The severity level of the defect. The values are from the Severity custom list. Typical values are: 1-Low, 2-Medium, 3-High, 4-Very High, 5-Urgent. | VarChar | 70 |
 | BG_PRIORITY | The priority level of the defect. The values are from the Priority custom list. Typical values are: 1-Low, 2-Medium, 3-High, 4-Very High, 5-Urgent. | VarChar | 70 |
 | BG_DETECTED_BY | The user name of the tester who found the defect. | VarChar | 60 |
 | BG_DETECTION_DATE | The date the defect was found. | DBTimeStamp | 4 |
 | BG_DETECTION_VERSION | The version in which the defect was detected. | VarChar | 70 |
 | BG_PLANNED_CLOSING_VER | The version in which the developer estimates the defect will be closed. | VarChar | 70 |
 | BG_ESTIMATED_FIX_TIME | The number of days the developer estimates will be required to fix the defect. | Integer | 4 |
 | BG_ACTUAL_FIX_TIME | The number of days worked to fix the defect. | Integer | 4 |
 | BG_CLOSING_DATE | The date the defect record was closed. | DBTimeStamp | 4 |
 | BG_CLOSING_VERSION | The version in which the defect record was closed. | VarChar | 70 |
 | BG_TO_MAIL | Indicates whether a defect report should be mailed to users registered to receive such reports. | VarChar | 1 |
 | BG_ATTACHMENT | Indicates whether the defect record has any attachments. The value of this field can be either Y or N. | VarChar | 1 |
 | BG_USER_01 | User-defined field. | VarChar | 40 |
 | BG_USER_02 | User-defined field. | VarChar | 40 |
 | BG_USER_03 | User-defined field. | VarChar | 40 |
 | BG_USER_04 | User-defined field. | VarChar | 40 |
 | BG_USER_05 | User-defined field. | VarChar | 40 |
 | BG_USER_06 | User-defined field. | VarChar | 40 |
 | BG_USER_07 | User-defined field. | VarChar | 40 |
 | BG_USER_08 | User-defined field. | VarChar | 40 |
 | BG_USER_09 | User-defined field. | VarChar | 40 |
 | BG_USER_10 | User-defined field. | VarChar | 40 |
 | BG_USER_11 | User-defined field. | VarChar | 40 |
 | BG_USER_12 | User-defined field. | VarChar | 40 |
 | BG_USER_13 | User-defined field. | VarChar | 40 |
 | BG_USER_14 | User-defined field. | VarChar | 40 |
 | BG_USER_15 | User-defined field. | VarChar | 40 |
 | BG_USER_16 | User-defined field. | VarChar | 40 |
 | BG_USER_17 | User-defined field. | VarChar | 40 |
 | BG_USER_18 | User-defined field. | VarChar | 40 |
 | BG_USER_19 | User-defined field. | VarChar | 40 |
 | BG_USER_20 | User-defined field. | VarChar | 40 |
 | BG_USER_21 | User-defined field. | VarChar | 40 |
 | BG_USER_22 | User-defined field. | VarChar | 40 |
 | BG_USER_23 | User-defined field. | VarChar | 40 |
 | BG_USER_24 | User-defined field. | VarChar | 40 |
 | BG_USER_HR_01 | BG_USER_HR_01 to BG_USER_HR_06 are for backward compatibility. Fields may be removed in future version. | Integer | 4 |
 | BG_BUG_VER_STAMP | A number indicating the revision number of this record. Increments each time a change is made. | Integer | 4 |
 | BG_HAS_CHANGE | For backward compatibility. | VarChar | 50 |
 | BG_VTS | The version time stamp. Indicates the time this record was last changed according to the database server. | VarChar | 20 |
 | BG_EXTENDED_REFERENCE | For internal use. Do not change data. | VarChar | 50 |
 | BG_REQUEST_ID | The ITG Request ID. This field is used internally by ITG to link ITG requests to defects. | Integer | 4 |
 | BG_TEXT_SYNC | For internal use. Do not change data. | VarChar | 1 |
 | BG_REQUEST_SERVER | The URL of the ITG server. This field is used internally by ITG. | VarChar | 120 |
 | BG_REQUEST_TYPE | The ITG request type. This field is used internally by ITG. | VarChar | 120 |
 | BG_REQUEST_NOTE | The notes added to the linked request in ITG. | LongVarChar | 16 |
 | BG_CYCLE_ID | For backward compatibility. | Integer | 4 |
 | BG_TEST_REFERENCE | For backward compatibility. | Integer | 4 |
 | BG_CYCLE_REFERENCE | For backward compatibility. | VarChar | 255 |
 | BG_RUN_REFERENCE | For backward compatibility. | Integer | 4 |
 | BG_STEP_REFERENCE | For backward compatibility. | Integer | 4 |
 | BG_DETECTED_IN_REL | The RELEASES.REL_ID of the release in which the defect was detected. | Integer | 4 |
 | BG_DETECTED_IN_RCYC | The RELEASE_CYCLES.RCYC_ID of the release cycle in which the defect was detected. | Integer | 4 |
 | BG_TARGET_REL | The RELEASES.REL_ID of the release in which the defect is planned to be fixed. | Integer | 4 |
 | BG_TARGET_RCYC | The RELEASE_CYCLES.RCYC_ID of the release cycle in which the defect is planned to be fixed. | Integer | 4 |

Indexes

Index | Primary | Unique
BG_PRIMARYKEY |  |
BG_COMPOUND_IDX |  |
BG_TO_MAIL_IDX |  |

Triggers

Trigger | Description
AUTR66132_BUG |

See Also

Quality Center Database


%%LocalItemTitle%%

Quality Center Database

BUG_MULTIVALUE Table

Description

Multiple values for defect records.

Columns

Column Name | Description | Datatype | Length | Allow Nulls
BGMV_BUG_ID | The Defect ID: BUG.BG_BUG_ID. | Integer | 4 |
BGMV_COLUMN_NAME | The multi-value column. | VarChar | 40 |
BGMV_VALUE | A single value. Note: The values are denormalized for performance reasons. Any program that alters the values in this value field must also handle the semicolon-separated value in the main entity table. | VarChar | 255 |

Indexes

Index | Primary | Unique
INX_BGMV |  |
INX_BGMV_BUG_ID |  |

See Also

Quality Center Database


%%LocalItemTitle%%

BUG_MULTIVALUE Table | Quality Center Database

INX_BGMV Index

Description

Index Properties

Primary Key | Yes
Unique Values | Yes

Columns

Column | Sort Order
BGMV_COLUMN_NAME | Ascending
BGMV_VALUE | Ascending
BGMV_BUG_ID | Ascending

Description

See Also

BUG_MULTIVALUE Table | Quality Center Database


%%LocalItemTitle%%

BUG_MULTIVALUE Table | Quality Center Database

INX_BGMV_BUG_ID Index

Description

Index Properties

Primary Key | Yes
Unique Values | No

Columns

Column | Sort Order
BGMV_BUG_ID | Ascending

Description

See Also

BUG_MULTIVALUE Table | Quality Center Database


%%LocalItemTitle%%

Quality Center Database

BUG_TOKENS Table

Description

An associative table linking defects and tokens.

Remarks

The linkage assists in searches for defect similarity.

Columns

 | Column Name | Description | Datatype | Length | Allow Nulls
Primary Key | BT_BUG_ID | The defect: BUG.BG_BUG_ID | Integer | 4 |
Primary Key | BT_TOKEN_ID | The token: TOKENS.TK_ID | Integer | 4 |

Indexes

Index | Primary | Unique
BT_PRIMARYKEY |  |
BT_BUG_TOKEN_ID |  |

See Also

Quality Center Database


%%LocalItemTitle%%

BUG_TOKENS Table | Quality Center Database

BT_BUG_TOKEN_ID Index

Index Properties

Primary Key | No
Unique Values | No

Columns

 | Column | Sort Order
Primary Key | BT_TOKEN_ID | Ascending

See Also

BUG_TOKENS Table | Quality Center Database


%%LocalItemTitle%%

BUG_TOKENS Table | Quality Center Database

BT_PRIMARYKEY Index

Description

Index Properties

Primary Key | Yes
Unique Values | Yes

Columns

 | Column | Sort Order
Primary Key | BT_BUG_ID | Ascending
Primary Key | BT_TOKEN_ID | Ascending

Description

See Also

BUG_TOKENS Table | Quality Center Database


%%LocalItemTitle%%

Quality Center Database

CACHE Table

Description

The Cache table is for internal use. Do not change data.

See Also

Quality Center Database


%%LocalItemTitle%%

Quality Center Database

COMMON_SETTINGS Table

Description

User settings and third party data.

Remarks

This table is used by Quality Center to save user settings such as view filters from session to session.

It can also be used to implement data persistency by third party applications using the Open Test Architecture API or WorkFlow module scripts. This practice is recommended over use of external files unless the data to be saved is very large or too complex to be saved in a string.

The table is a two-level list of variables. The CSET_CATEGORY is the name of the list and can be any string. Each category can have any number of variables. The variable name is CSET_NAME.

The CSET_VALUE is the value of the variable. The format of the string is determined by the application using the variable.

Columns

 | Column Name | Description | Datatype | Length | Allow Nulls
Primary Key | CSET_CATEGORY | The category name. | VarChar | 240 |
Primary Key | CSET_NAME | The setting name. | VarChar | 70 |
Primary Key | CSET_OWNER | The user name of the user to whom the setting or definition applies. | VarChar | 240 |
 | CSET_VALUE | The value of the setting. | LongVarChar | 16 |
 | CSET_IS_SYSTEM | For future use. | VarChar | 1 |

Indexes

Index | Primary | Unique
CS_PRIMARYKEY |  |

See Also

Quality Center Database


%%LocalItemTitle%%

COMMON_SETTINGS Table | Quality Center Database

CS_PRIMARYKEY Index

Description

Index Properties

Primary Key | Yes
Unique Values | Yes

Columns

 | Column | Sort Order
Primary Key | CSET_OWNER | Ascending
Primary Key | CSET_CATEGORY | Ascending
Primary Key | CSET_NAME | Ascending

Description

See Also

COMMON_SETTINGS Table | Quality Center Database


%%LocalItemTitle%%

Quality Center Database

COMPONENT Table

Description

Business Process Components.

Remarks

Parameters for components are in the FRAMEWORK_PARAM Table.

Runtime data for parameters are in TESTCYCL.TC_DATA_OBJ.

When a component is contained in a test, the link between the test and component is in the BPTEST_TO_COMPONENTS Table.

The steps in the component are in the COMPONENT_STEP Table.

The logical organization of components in is the COMPONENT_FOLDER Table.

For table relationships, see the Business Process Overview.

Columns

 | Column Name | Description | Datatype | Length | Allow Nulls
Primary Key | CO_ID | The record ID. | Integer | 4 |
 | CO_FOLDER_ID | The COMPONENT_FOLDER.FC_ID of the folder containing this component. For QuickTest Professional Application Areas, CO_FOLDER_ID is 2. Application areas are not displayed in the Business Process Testing Module. | Integer | 4 |
 | CO_NAME | The component name. | VarChar | 255 |
 | CO_VERSION | For future use. | VarChar | 255 |
 | CO_PHYSICAL_PATH | For future use. | VarChar | 255 |
 | CO_RESPONSIBLE | The user to whom the component is assigned. | VarChar | 60 |
 | CO_CREATED_BY | The user who created the component. | VarChar | 60 |
 | CO_STATUS | The values are from the Component Status list. Typical values are: Error, Ready, Failed, Maintenance, Under Development, and Not Implemented. | VarChar | 70 |
 | CO_CREATION_DATE | The date the component was created. | DBTimeStamp | 4 |
 | CO_DESC | The HTML formatted string that appears in the Description box in the component details. | LongVarChar | 16 |
 | CO_DEV_COMMENTS | Comments. | LongVarChar | 16 |
 | CO_STEPS_DATA | For future use. | LongVarChar | 16 |
 | CO_VER_STAMP | Increments when the record is updated. | Integer | 4 |
 | CO_IS_ITERATABLE | For backward compatibility. | VarChar | 1 |
 | CO_DEFAULT_PICTURE_ID | For future use. | Integer | 4 |
 | CO_IS_OBSOLETE | If a user deletes the component but it is in use in a test, this field is set to Y and the component is not physically deleted. If the component is restored, the field is set to N. | VarChar | 1 |
 | CO_SRC_ID | For future use. | Integer | 4 |
 | CO_DELETION_DATE | Database timestamp when the record is marked obsolete. | DBTimeStamp | 4 |
 | CO_DELETED_FROM_PATH | The path of the component before it was marked obsolete. | VarChar | 255 |
 | CO_DATA | For future use. | LongVarChar | 16 |
 | CO_SCRIPT_TYPE | The test type. For example: QuickTest, WinRunner, manual, and so on. | VarChar | 60 |
 | CO_HAS_PICTURE | A value of Y indicates that the component has a snapshot. | VarChar | 1 |
 | CO_TEXT_SYNC | For internal use. | VarChar | 1 |
 | CO_APP_AREA_ID | The QuickTest Professional Application Area ID. Meaningful only when CO_FOLDER_ID points to a Application Area folder. | Integer | 4 |
 | CO_USER_01 | User-defined field. | VarChar | 40 |
 | CO_USER_02 | User-defined field. | VarChar | 40 |
 | CO_USER_03 | User-defined field. | VarChar | 40 |
 | CO_USER_04 | User-defined field. | VarChar | 40 |
 | CO_USER_05 | User-defined field. | VarChar | 40 |
 | CO_USER_06 | User-defined field. | VarChar | 40 |
 | CO_USER_07 | User-defined field. | VarChar | 40 |
 | CO_USER_08 | User-defined field. | VarChar | 40 |
 | CO_USER_09 | User-defined field. | VarChar | 40 |
 | CO_USER_10 | User-defined field. | VarChar | 40 |
 | CO_USER_11 | User-defined field. | VarChar | 40 |
 | CO_USER_12 | User-defined field. | VarChar | 40 |
 | CO_USER_13 | User-defined field. | VarChar | 40 |
 | CO_USER_14 | User-defined field. | VarChar | 40 |
 | CO_USER_15 | User-defined field. | VarChar | 40 |
 | CO_USER_16 | User-defined field. | VarChar | 40 |
 | CO_USER_17 | User-defined field. | VarChar | 40 |
 | CO_USER_18 | User-defined field. | VarChar | 40 |
 | CO_USER_19 | User-defined field. | VarChar | 40 |
 | CO_USER_20 | User-defined field. | VarChar | 40 |
 | CO_USER_21 | User-defined field. | VarChar | 40 |
 | CO_USER_22 | User-defined field. | VarChar | 40 |
 | CO_USER_23 | User-defined field. | VarChar | 40 |
 | CO_USER_24 | User-defined field. | VarChar | 40 |

Indexes

Index | Primary | Unique
FW_CO_PRIMARYKEY |  |
CO_FOLDER_ID_IDX |  |

See Also

Quality Center Database


%%LocalItemTitle%%

Quality Center Database

COMPONENT_FOLDER Table

Description

Business Process Component Folders.

Columns

 | Column Name | Description | Datatype | Length | Allow Nulls
Primary Key | FC_ID | The record ID. | Integer | 4 |
 | FC_FATHER_ID | The FC_ID of the folder containing this folder. The initial folders created automatically with a new project have an FC_FATHER_ID of 0. | Integer | 4 |
 | FC_PATH | The folders at the top level are ordered from AAA to ZZZ. Child folders' paths are the parent path with three more characters appended, so that children of the same node are ordered among themselves. The child paths are {parent path}AAA to {parent path}ZZZ. | VarChar | 255 |
 | FC_NAME | The folder name. | VarChar | 255 |
 | FC_DESC | The folder description. | LongVarChar | 16 |
 | FC_LOGICAL_PATH | For future use. | VarChar | 255 |
 | FC_VER_STAMP | Increments each time the record is changed. | Integer | 4 |

Indexes

Index | Primary | Unique
FC_FATHER_NAME_IDX |  |
FC_PATH_IDX |  |
FW_FC_PRIMARYKEY |  |

See Also

Quality Center Database


%%LocalItemTitle%%

COMPONENT_FOLDER Table | Quality Center Database

FC_FATHER_NAME_IDX Index

Description

Index Properties

Primary Key | No
Unique Values | Yes

Columns

Column | Sort Order
FC_FATHER_ID | Ascending
FC_NAME | Ascending

Description

See Also

COMPONENT_FOLDER Table | Quality Center Database


%%LocalItemTitle%%

COMPONENT_FOLDER Table | Quality Center Database

FC_PATH_IDX Index

Description

Index Properties

Primary Key | No
Unique Values | Yes

Columns

Column | Sort Order
FC_PATH | Ascending

Description

See Also

COMPONENT_FOLDER Table | Quality Center Database


%%LocalItemTitle%%

COMPONENT_FOLDER Table | Quality Center Database

FW_FC_PRIMARYKEY Index

Description

Index Properties

Primary Key | Yes
Unique Values | Yes

Columns

 | Column | Sort Order
Primary Key | FC_ID | Ascending

Description

See Also

COMPONENT_FOLDER Table | Quality Center Database


%%LocalItemTitle%%

Quality Center Database

COMPONENT_STEP Table

Description

Steps of Business Process Components.

Remarks

In the description and expected result strings, parameters are enclosed in triple angle brackets. The HTML representation is &lt;&lt;&lt;PARAMETER NAME&gt;&gt;&gt;

Parameters are linked to steps in the COMPONENT_STEP_PARAMS Table.

Columns

 | Column Name | Description | Datatype | Length | Allow Nulls
Primary Key | CS_STEP_ID | The step record ID. | Integer | 4 |
 | CS_COMPONENT_ID | The COMPONENT.CO_ID of the component to which the step belongs. | Integer | 4 |
 | CS_STEP_ORDER | The order of execution of the step in the component (1 based). | Integer | 4 |
 | CS_DESCRIPTION | The HTML format for the description. | LongVarChar | 16 |
 | CS_EXPECTED | The HTML format for the expected result. | LongVarChar | 16 |
 | CS_STEP_NAME | The step name. | VarChar | 255 |
 | CS_TEXT_SYNC | For internal use. | VarChar | 1 |

Indexes

Index | Primary | Unique
COMPSTEP_PK |  |
CS_COMPONENT_IDX |  |

See Also

Quality Center Database


%%LocalItemTitle%%

Quality Center Database

COMPONENT_STEP_PARAMS Table

Description

An associative table linking the Business Process Component steps to their parameters.

Columns

 | Column Name | Description | Datatype | Length | Allow Nulls
Primary Key | CSP_ID | The record ID. | Integer | 4 |
 | CSP_STEP_ID | The component step, identified with COMPONENT_STEP.CS_STEP_ID | Integer | 4 |
 | CSP_PARAM_ID | The parameter, identified with FRAMEWORK_PARAM.FP_ID | Integer | 4 |

Indexes

Index | Primary | Unique
COMP_STEP_PARAMS_PK |  |
COMPONENT_PARAM_IDX |  |
COMPONENT_STEP_IDX |  |

See Also

Quality Center Database


%%LocalItemTitle%%

COMPONENT_STEP_PARAMS Table | Quality Center Database

COMP_STEP_PARAMS_PK Index

Description

Index Properties

Primary Key | Yes
Unique Values | Yes

Columns

 | Column | Sort Order
Primary Key | CSP_ID | Ascending

Description

See Also

COMPONENT_STEP_PARAMS Table | Quality Center Database


%%LocalItemTitle%%

COMPONENT_STEP_PARAMS Table | Quality Center Database

COMPONENT_PARAM_IDX Index

Description

Index Properties

Primary Key | No
Unique Values | No

Columns

Column | Sort Order
CSP_PARAM_ID | Ascending

Description

See Also

COMPONENT_STEP_PARAMS Table | Quality Center Database


%%LocalItemTitle%%

COMPONENT_STEP_PARAMS Table | Quality Center Database

COMPONENT_STEP_IDX Index

Description

Index Properties

Primary Key | No
Unique Values | No

Columns

Column | Sort Order
CSP_STEP_ID | Ascending

Description

See Also

COMPONENT_STEP_PARAMS Table | Quality Center Database


%%LocalItemTitle%%

Quality Center Database

CROS_REF Table

Description

Attachments.

Columns

 | Column Name | Description | Datatype | Length | Allow Nulls
 | CR_ENTITY | The name of the table containing the item to which the file or URL is attached. | VarChar | 30 |
 | CR_KEY_1 | The string representation of the key in the table specified in CR_ENTITY. The key can be the ID field or a compound key. If a compound key, the values of the key fields are separated by a tilde (~). | VarChar | 40 |
Primary Key | CR_REF_ID | The record ID. | Integer | 4 |
 | CR_REFERENCE | The file name or URL. If a file, CR_REFERENCE is CR_ENTITY + CR_KEY_1 + the name of the original uploaded file. | VarChar | 255 |
 | CR_REF_TYPE | The type of attachment: either File or Internet Web Address. | VarChar | 20 |
 | CR_REF_SUBTYPE | This property is used only in Quality Center 9.2. It's use will be discontinued in later versions. A value of enum TDAPI_ATTACH_SUBTYPE. For example, 1 indicates rich content. For all possible values, see the API reference. | Integer | 4 |
 | CR_DESCRIPTION | A description of the attachment. | LongVarChar | 16 |
 | CR_VC_CUR_VER | For backward compatibility. Field may be removed in future version. | VarChar | 50 |

Indexes

Index | Primary | Unique
CR_PRIMARYKEY |  |
CR_ENTITY_KEY_IDX |  |

See Also

Quality Center Database


%%LocalItemTitle%%

CROS_REF Table | Quality Center Database

CR_ENTITY_KEY_IDX Index

Index Properties

Primary Key | No
Unique Values | No

Columns

Column | Sort Order
CR_ENTITY | Ascending
CR_KEY_1 | Ascending

See Also

CROS_REF Table | Quality Center Database


%%LocalItemTitle%%

CROS_REF Table | Quality Center Database

CR_PRIMARYKEY Index

Index Properties

Primary Key | Yes
Unique Values | Yes

Columns

 | Column | Sort Order
Primary Key | CR_REF_ID | Ascending

See Also

CROS_REF Table | Quality Center Database


%%LocalItemTitle%%

Quality Center Database

CYCL_FOLD Table

Description

The test set folder tree.

Columns

 | Column Name | Description | Datatype | Length | Allow Nulls
Primary Key | CF_ITEM_ID | The record ID. | Integer | 4 |
 | CF_ITEM_NAME | The folder name. | VarChar | 255 |
 | CF_ITEM_PATH | Root folders paths are AAAAA to ZZZZZ. Child folders are numbered AAA to ZZZ where the child numeration is concatenated at the end of the parent path. | VarChar | 255 |
 | CF_FATHER_ID | The CF_ITEM_ID of the folder containing this item. Root folders have CF_FATHER_ID = 0. | Integer | 4 |
 | CF_VIEW_ORDER | The order in which the folder appears among other children of the same parent folder. | Integer | 4 |
 | CF_WORKFLOW | For backward compatibility. Field may be removed in future version. | LongVarChar | 16 |
 | CF_ATTACHMENT | A value of Y indicates that the folder has at least one attachment. | VarChar | 1 |
 | CF_VER_STAMP | The revision number of this record. Increments each time the record is updated. | Integer | 4 |
 | CF_VTS | The version time stamp. The time the record was last changed according the the database server clock. | VarChar | 20 |
 | CF_DESCR | A description of the folder. | LongVarChar | 16 |
 | CF_NO_OF_SONS | The number of direct child nodes, not including children of those child nodes. | Integer | 4 |
 | CF_ASSIGN_RCYC | The RELEASE_CYCLES.RCYC_ID of the release cycle with which the folder is associated. | Integer | 4 |

Indexes

Index | Primary | Unique
CF_FATHER_NAME_ID |  |
CF_ITEM_PATH_IDX |  |
CF_PRIMARYKEY |  |

See Also

Quality Center Database


%%LocalItemTitle%%

CYCL_FOLD Table | Quality Center Database

CF_FATHER_NAME_ID Index

Description

Index Properties

Primary Key | No
Unique Values | Yes

Columns

Column | Sort Order
CF_FATHER_ID | Ascending
CF_ITEM_NAME | Ascending

Description

See Also

CYCL_FOLD Table | Quality Center Database


%%LocalItemTitle%%

CYCL_FOLD Table | Quality Center Database

CF_ITEM_PATH_IDX Index

Description

Index Properties

Primary Key | No
Unique Values | Yes

Columns

Column | Sort Order
CF_ITEM_PATH | Ascending

Description

See Also

CYCL_FOLD Table | Quality Center Database


%%LocalItemTitle%%

CYCL_FOLD Table | Quality Center Database

CF_PRIMARYKEY Index

Description

Index Properties

Primary Key | Yes
Unique Values | Yes

Columns

 | Column | Sort Order
Primary Key | CF_ITEM_ID | Ascending

Description

See Also

CYCL_FOLD Table | Quality Center Database


%%LocalItemTitle%%

Quality Center Database

CYCLE Table

Description

Test sets.

Remarks

The test set tree is maintained in the CYCL_FOLD Table.

Test sets are linked to tests in the TESTCYCL Table.

Test sets are linked to test runs with RUN.RN_CYCLE_ID.

Multiple values for fields are maintained in the CYCLE_MULTIVALUE Table.

For table relationships, see the Test Lab Module Overview.

Columns

 | Column Name | Description | Datatype | Length | Allow Nulls
Primary Key | CY_CYCLE_ID | The ID of the test set record. | Integer | 4 |
 | CY_CYCLE | The test set name assigned by the creator of the test set. | VarChar | 255 |
 | CY_OPEN_DATE | The date the test set was opened. | DBTimeStamp | 4 |
 | CY_CLOSE_DATE | The date the test set was closed. | DBTimeStamp | 4 |
 | CY_STATUS | The current status of the test set: Open or Closed. | VarChar | 70 |
 | CY_DESCRIPTION | The information entered in the Execution Flow tab in the user interface. Includes execution dependencies (conditions) and comments. | LongVarChar | 16 |
 | CY_CYCLE_VER_STAMP | The revision number of this record. Increments each time the record is updated. | Integer | 4 |
 | CY_COMMENT | A description of the test set. | LongVarChar | 16 |
 | CY_ATTACHMENT | Indicates whether the test set has any attachments: Y or N. | VarChar | 1 |
 | CY_EXEC_EVENT_HANDLE | The actions to be executed in response to various test set execution events. This field is in a proprietary format. | LongVarChar | 16 |
 | CY_MAIL_SETTINGS | The mailing actions in response to various test set execution events. This field is in a proprietary format. | LongVarChar | 16 |
 | CY_USER_01 | User-defined field. | VarChar | 40 |
 | CY_USER_02 | User-defined field. | VarChar | 40 |
 | CY_USER_03 | User-defined field. | VarChar | 40 |
 | CY_USER_04 | User-defined field. | VarChar | 40 |
 | CY_USER_05 | User-defined field. | VarChar | 40 |
 | CY_USER_06 | User-defined field. | VarChar | 40 |
 | CY_VTS | The version time stamp. Indicates the time this record was updated according to the database server clock. | VarChar | 20 |
 | CY_OS_CONFIG | For backward compatibility. Field may be removed in future version. | VarChar | 40 |
 | CY_FOLDER_ID | The CYCL_FOLD.CF_ITEM_ID of the folder containing the test set. | Integer | 4 |
 | CY_CYCLE_CONFIG | For backward compatibility. Field may be removed in future version. | LongVarChar | 16 |
 | CY_REQUEST_ID | For backward compatibility. Field may be removed in future version. | Integer | 4 |
 | CY_TEXT_SYNC | For internal use. Do not change data. | VarChar | 1 |
 | CY_ASSIGN_RCYC | The RELEASE_CYCLES.RCYC_ID of the release cycle with which the test set is associated. | Integer | 4 |

Indexes

Index | Primary | Unique
CY_FOLDER_IDX |  |
CY_FOLDER_NAME_IDX |  |
CY_PRIMARYKEY |  |

Triggers

Trigger | Description
AUTR64594118_CYCLE |

See Also

Quality Center Database


%%LocalItemTitle%%

Quality Center Database

CYCLE_MULTIVALUE Table

Description

Multiple values for test set records.

Columns

Column Name | Description | Datatype | Length | Allow Nulls
CYMV_CYCLE_ID | The test set ID: CYCLE.CY_CYCLE_ID | Integer | 4 |
CYMV_COLUMN_NAME | The multi-value column. | VarChar | 40 |
CYMV_VALUE | A single value. Note: The values are denormalized for performance reasons. Any program that alters the values in this value field must also handle the semicolon-separated value in the main entity table. | VarChar | 255 |

Indexes

Index | Primary | Unique
INX_CYMV |  |
INX_CYMV_CYCLE_ID |  |

See Also

Quality Center Database


%%LocalItemTitle%%

CYCLE_MULTIVALUE Table | Quality Center Database

INX_CYMV Index

Description

Index Properties

Primary Key | Yes
Unique Values | Yes

Columns

Column | Sort Order
CYMV_COLUMN_NAME | Ascending
CYMV_VALUE | Ascending
CYMV_CYCLE_ID | Ascending

Description

See Also

CYCLE_MULTIVALUE Table | Quality Center Database


%%LocalItemTitle%%

CYCLE_MULTIVALUE Table | Quality Center Database

INX_CYMV_CYCLE_ID Index

Description

Index Properties

Primary Key | Yes
Unique Values | No

Columns

Column | Sort Order
CYMV_CYCLE_ID | Ascending

Description

See Also

CYCLE_MULTIVALUE Table | Quality Center Database


%%LocalItemTitle%%

Quality Center Database

DATACONST Table

Description

Global project constants.

Remarks

This table contains the relative paths to file system directories used to store project-related files, version information, and similar data.

Columns

 | Column Name | Description | Datatype | Length | Allow Nulls
Primary Key | DC_CONST_NAME | The constant's name. | VarChar | 40 |
 | DC_VALUE | The constant's value. | VarChar | 255 |

Indexes

Index | Primary | Unique
DC_PRIMARYKEY |  |

See Also

Quality Center Database


%%LocalItemTitle%%

DATACONST Table | Quality Center Database

DC_PRIMARYKEY Index

Description

Index Properties

Primary Key | Yes
Unique Values | Yes

Columns

 | Column | Sort Order
Primary Key | DC_CONST_NAME | Ascending

Description

See Also

DATACONST Table | Quality Center Database


%%LocalItemTitle%%

Quality Center Database

DESSTEPS Table

Description

A single step of a Design Test in Test Plan module.

Columns

 | Column Name | Description | Datatype | Length | Allow Nulls
Primary Key | DS_ID | The record ID. | Integer | 4 |
 | DS_TEST_ID | The TEST.TS_TEST_ID of the test to which the step belongs. | Integer | 4 |
 | DS_STEP_ORDER | The order in which the step appears within the test in the user interface. | Integer | 4 |
 | DS_STEP_NAME | The name assigned to the step by the test developer. | VarChar | 255 |
 | DS_DESCRIPTION | The design step description. | LongVarChar | 16 |
 | DS_EXPECTED | The expected result string. | LongVarChar | 16 |
 | DS_USER_01 | User-defined field. | VarChar | 40 |
 | DS_USER_02 | User-defined field. | VarChar | 40 |
 | DS_USER_03 | User-defined field. | VarChar | 40 |
 | DS_USER_04 | User-defined field. | VarChar | 40 |
 | DS_USER_05 | User-defined field. | VarChar | 40 |
 | DS_USER_06 | User-defined field. | VarChar | 40 |
 | DS_ATTACHMENT | Indicates whether the design step has any attachments: Y or N. | VarChar | 1 |
 | DS_LINK_TEST | If the design step is an instruction to run another test, the ID of the test to be run. | Integer | 4 |
 | DS_HAS_PARAMS | Indicates whether this design step has STEP_PARAMSassociated with it: Y or N. | VarChar | 1 |
 | DS_TEXT_SYNC | For internal use. Do not change data. | VarChar | 1 |

Indexes

Index | Primary | Unique
DS_PRIMARYKEY |  |
DS_LINK_TEST_IDX |  |
DS_TEST |  |

See Also

Quality Center Database


%%LocalItemTitle%%

DESSTEPS Table | Quality Center Database

DS_LINK_TEST_IDX Index

Index Properties

Primary Key | No
Unique Values | No

Columns

Column | Sort Order
DS_LINK_TEST | Ascending

See Also

DESSTEPS Table | Quality Center Database


%%LocalItemTitle%%

DESSTEPS Table | Quality Center Database

DS_PRIMARYKEY Index

Description

Index Properties

Primary Key | Yes
Unique Values | Yes

Columns

 | Column | Sort Order
Primary Key | DS_ID | Ascending

Description

See Also

DESSTEPS Table | Quality Center Database


%%LocalItemTitle%%

DESSTEPS Table | Quality Center Database

DS_TEST Index

Index Properties

Primary Key | No
Unique Values | No

Columns

Column | Sort Order
DS_TEST_ID | Ascending

See Also

DESSTEPS Table | Quality Center Database


%%LocalItemTitle%%

Quality Center Database

EXTENSIONS Table

Description

The Quality Center extensions that are enabled for this project.

Remarks

Add-ins are generally called Quality Center extensions because they extend Quality Center functionality.

Columns

 | Column Name | Description | Datatype | Length | Allow Nulls
Primary Key | EX_NAME | The short extension name. It is generally used internally, and is not visible in the Quality Center user interface. | VarChar | 50 |
 | EX_VERSION | The extension version enabled for this project. | VarChar | 50 |

Indexes

Index | Primary | Unique
EX_PRIMARYKEY |  |

See Also

Quality Center Database


%%LocalItemTitle%%

EXTENSIONS Table | Quality Center Database

EX_PRIMARYKEY Index

Index Properties

Primary Key | Yes
Unique Values | Yes

Columns

 | Column | Sort Order
Primary Key | EX_NAME | Ascending

See Also

EXTENSIONS Table | Quality Center Database


%%LocalItemTitle%%

Quality Center Database

FRAMEWORK_PARAM Table

Description

Parameters for Business Process Components.

Columns

 | Column Name | Description | Datatype | Length | Allow Nulls
Primary Key | FP_ID | The record ID. | Integer | 4 |
 | FP_COMPONENT_ID | The COMPONENT.CO_ID of the component to which the parameter belongs. | Integer | 4 |
 | FP_NAME | The parameter name. | VarChar | 255 |
 | FP_DESC | The parameter description. | LongVarChar | 16 |
 | FP_VALUE | The default value. | VarChar | 255 |
 | FP_IS_OUT | N for input parameter. Y for output parameter. | VarChar | 1 |
 | FP_SCOPE | For future use. | Integer | 4 |
 | FP_DATACENTER_LIST_ID | For future use. | Integer | 4 |
 | FP_ORDER | The 0-based display order in the UI. | Integer | 4 |
 | FP_VALUE_TYPE | The data type. | VarChar | 255 |
 | FP_VER_STAMP | Increments each time the record is updated. | Integer | 4 |

Indexes

Index | Primary | Unique
FW_FP_PRIMARYKEY |  |
FP_COMPONENT_ID_IDX |  |

See Also

Quality Center Database


%%LocalItemTitle%%

FRAMEWORK_PARAM Table | Quality Center Database

FP_COMPONENT_ID_IDX Index

Description

Index Properties

Primary Key | No
Unique Values | No

Columns

Column | Sort Order
FP_COMPONENT_ID | Ascending

Description

See Also

FRAMEWORK_PARAM Table | Quality Center Database


%%LocalItemTitle%%

FRAMEWORK_PARAM Table | Quality Center Database

FW_FP_PRIMARYKEY Index

Description

Index Properties

Primary Key | Yes
Unique Values | Yes

Columns

 | Column | Sort Order
Primary Key | FP_ID | Ascending

Description

See Also

FRAMEWORK_PARAM Table | Quality Center Database


%%LocalItemTitle%%

Quality Center Database

GROUPS Table

Description

Groups of users with a common set of privileges.

Columns

 | Column Name | Description | Datatype | Length | Allow Nulls
Primary Key | GR_GROUP_ID | The ID of the group serves as its bit-offset in masks that define characteristics of groups. | Integer | 4 |
 | GR_GROUP_NAME | The name of the group. | VarChar | 60 |
 | GR_IS_SYSTEM | A value of Y indicates that this is a default user group created automatically in new projects. N indicates that the group was added. | VarChar | 1 |
 | GR_PREDEF_FILTER | The default view filter for members of the group. | LongVarChar | 16 |

Indexes

Index | Primary | Unique
GR_PRIMARYKEY |  |

See Also

Quality Center Database


%%LocalItemTitle%%

GROUPS Table | Quality Center Database

GR_PRIMARYKEY Index

Description

Index Properties

Primary Key | Yes
Unique Values | Yes

Columns

 | Column | Sort Order
Primary Key | GR_GROUP_ID | Ascending

Description

See Also

GROUPS Table | Quality Center Database


%%LocalItemTitle%%

Quality Center Database

HOST_GROUP Table

Description

Logical groups of computers.

Columns

 | Column Name | Description | Datatype | Length | Allow Nulls
Primary Key | GH_NAME | The group name. | VarChar | 50 |
 | GH_ATTACHMENT | A value of Y indicates that the group has at least one attachment. | VarChar | 1 |
 | GH_DESCRIPTION | A description of the group. | LongVarChar | 16 |

Indexes

Index | Primary | Unique
GH_PRIMARYKEY |  |

See Also

Quality Center Database


%%LocalItemTitle%%

HOST_GROUP Table | Quality Center Database

GH_PRIMARYKEY Index

Description

Index Properties

Primary Key | Yes
Unique Values | Yes

Columns

 | Column | Sort Order
Primary Key | GH_NAME | Ascending

Description

See Also

HOST_GROUP Table | Quality Center Database


%%LocalItemTitle%%

Quality Center Database

HOST_IN_GROUP Table

Description

An associative table that links HOSTS with HOST_GROUPs.

Columns

 | Column Name | Description | Datatype | Length | Allow Nulls
Primary Key | HG_HOST | The host: HOSTS.HO_NAME. | VarChar | 50 |
Primary Key | HG_GROUP | The host group: HOST_GROUP.GH_NAME | VarChar | 50 |

Indexes

Index | Primary | Unique
HG_PRIMARYKEY |  |
HG_GROUP_LWR_IDX |  |

See Also

Quality Center Database


%%LocalItemTitle%%

HOST_IN_GROUP Table | Quality Center Database

HG_GROUP_LWR_IDX Index

Description

Index Properties

Primary Key | No
Unique Values | No

Columns

 | Column | Sort Order
Primary Key | HG_GROUP | Ascending

Description

See Also

HOST_IN_GROUP Table | Quality Center Database


%%LocalItemTitle%%

HOST_IN_GROUP Table | Quality Center Database

HG_PRIMARYKEY Index

Description

Index Properties

Primary Key | Yes
Unique Values | Yes

Columns

 | Column | Sort Order
Primary Key | HG_HOST | Ascending
Primary Key | HG_GROUP | Ascending

Description

See Also

HOST_IN_GROUP Table | Quality Center Database


%%LocalItemTitle%%

Quality Center Database

HOSTS Table

Description

Computers on the network.

Columns

 | Column Name | Description | Datatype | Length | Allow Nulls
Primary Key | HO_NAME | The network name of the computer. | VarChar | 50 |
 | HO_DESCRIPTION | A description of the host. | VarChar | 200 |
 | HO_REX_SERVER | This field is available for use by third-party integrations. | VarChar | 50 |
 | HO_ATTACHMENT | A value of Y indicates that there is at least one attachment associated with this record. | VarChar | 1 |

Indexes

Index | Primary | Unique
HOSTS_PRIMARYKEY |  |

See Also

Quality Center Database


%%LocalItemTitle%%

HOSTS Table | Quality Center Database

HOSTS_PRIMARYKEY Index

Description

Index Properties

Primary Key | Yes
Unique Values | Yes

Columns

 | Column | Sort Order
Primary Key | HO_NAME | Ascending

Description

See Also

HOSTS Table | Quality Center Database


%%LocalItemTitle%%

Quality Center Database

LINK Table

Description

Associations between defects and other entities.

Columns

 | Column Name | Description | Datatype | Length | Allow Nulls
Primary Key | LN_LINK_ID | The record ID. | Integer | 4 |
 | LN_BUG_ID | The defect to which the entity is linked: BUG.BG_BUG_ID. | Integer | 4 |
 | LN_ENTITY_TYPE | The table name of the entity linked to the defect. If LN_ENTITY_TYPE is BUG, then the link is between two defects. | VarChar | 30 |
 | LN_ENTITY_ID | The record ID of the entity in the table specified by LN_ENTITY_TYPE. | Integer | 4 |
 | LN_CREATED_BY | The link author. | VarChar | 60 |
 | LN_CREATION_DATE | The date the link was created, based on the database-server clock. | DBTimeStamp | 4 |
 | LN_LINK_TYPE | A value of the Link Type custom list. | VarChar | 60 |
 | LN_LINK_COMMENT | The link description. | VarChar | 255 |

Indexes

Index | Primary | Unique
INX_LINK_ENTITY_TYPE_ID |  |
LN_PRIMARYKEY |  |

See Also

Quality Center Database


%%LocalItemTitle%%

LINK Table | Quality Center Database

INX_LINK_ENTITY_TYPE_ID Index

Description

Index Properties

Primary Key | No
Unique Values | Yes

Columns

Column | Sort Order
LN_BUG_ID | Ascending
LN_ENTITY_TYPE | Ascending
LN_ENTITY_ID | Ascending

Description

See Also

LINK Table | Quality Center Database


%%LocalItemTitle%%

LINK Table | Quality Center Database

LN_PRIMARYKEY Index

Description

Index Properties

Primary Key | Yes
Unique Values | Yes

Columns

 | Column | Sort Order
Primary Key | LN_LINK_ID | Ascending

Description

See Also

LINK Table | Quality Center Database


%%LocalItemTitle%%

Quality Center Database

LOCKS Table

Description

Locks to control access to the same item by different user sessions. For internal use. Do not change values in this table.

Indexes

Index | Primary | Unique
LOCKS_PRIMARYKEY |  |
LK_LOCK_TIME_IDX |  |
LK_SESSION_ID_IDX |  |

See Also

Quality Center Database


%%LocalItemTitle%%

LOCKS Table | Quality Center Database

LK_LOCK_TIME_IDX Index

Description

Index Properties

Primary Key | No
Unique Values | No

Columns

Column | Sort Order
LK_LOCK_TIME | Ascending

Description

See Also

LOCKS Table | Quality Center Database


%%LocalItemTitle%%

LOCKS Table | Quality Center Database

LK_SESSION_ID_IDX Index

Description

Index Properties

Primary Key | No
Unique Values | No

Columns

Column | Sort Order
LK_SESSION_ID | Ascending

Description

See Also

LOCKS Table | Quality Center Database


%%LocalItemTitle%%

LOCKS Table | Quality Center Database

LOCKS_PRIMARYKEY Index

Description

Index Properties

Primary Key | Yes
Unique Values | Yes

Columns

 | Column | Sort Order
Primary Key | LK_OBJECT_TYPE | Ascending
Primary Key | LK_OBJECT_KEY | Ascending

Description

See Also

LOCKS Table | Quality Center Database


%%LocalItemTitle%%

Quality Center Database

MAILCOND Table

Description

Rules for sending defect notifications to individual users.

Columns

 | Column Name | Description | Datatype | Length | Allow Nulls
Primary Key | MC_USER | The user: USERS.US_USERNAME | VarChar | 60 |
 | MC_CONDITION | The condition under which the user receives defect reports by mail. | LongVarChar | 16 |

Indexes

Index | Primary | Unique
MC_PRIMARYKEY |  |

See Also

Quality Center Database


%%LocalItemTitle%%

MAILCOND Table | Quality Center Database

MC_PRIMARYKEY Index

Description

Index Properties

Primary Key | Yes
Unique Values | Yes

Columns

 | Column | Sort Order
Primary Key | MC_USER | Ascending

Description

See Also

MAILCOND Table | Quality Center Database


%%LocalItemTitle%%

Quality Center Database

MODULES Table

Description

Permissions by group for accessing modules in the user interface.

Columns

 | Column Name | Description | Datatype | Length | Allow Nulls
Primary Key | MD_ID | The module ID. | Integer | 4 |
 | MD_NAME | The module name. | VarChar | 255 |
 | MD_GUID | The Globally Unique Identifier of the module component. | VarChar | 255 |
 | MD_DESC | The module description. | VarChar | 255 |
 | MD_VISIBLE | A bit mask that specifies the groups whose members may view the module. If bit X is set, module access is enabled for the group identified with GROUPS.GR_GROUP_ID = X. | VarChar | 512 |
 | MD_ORDER | The position of an extension module in the collection of extensions. This field does not apply to built-in modules. | Integer | 4 |

Indexes

Index | Primary | Unique
MD_PRIMARYKEY |  |

See Also

Quality Center Database


%%LocalItemTitle%%

MODULES Table | Quality Center Database

MD_PRIMARYKEY Index

Index Properties

Primary Key | Yes
Unique Values | Yes

Columns

 | Column | Sort Order
Primary Key | MD_ID | Ascending

See Also

MODULES Table | Quality Center Database


%%LocalItemTitle%%

Quality Center Database

RBT_CUSTOMIZATION Table

Description

Risk-based quality management settings.

Remarks

These are examples of custom values:

RBT_POLICY_DATA
{
RBT_FP_EFFORT_HOURS:\00000033\{
RBT_FP_HIGH:18,
RBT_FP_MEDIUM:15,
RBT_FP_LOW:12
},
RBT_TESTING_LEVEL_PERCENTS:\00000047\{
RBT_TL_FULL:100,
RBT_TL_PARTIAL:67,
RBT_TL_SANITY:34,
RBT_TL_NONE:0
},
RBT_TESTING_POLICY_MATRIX:\0000013A\{
RBT_BI_A:\0000004e\{
RBT_FP_HIGH:RBT_TL_FULL,
RBT_FP_MEDIUM:RBT_TL_FULL,
RBT_FP_LOW:RBT_TL_FULL
},
RBT_BI_B:\00000057\{
RBT_FP_HIGH:RBT_TL_PARTIAL,
RBT_FP_MEDIUM:RBT_TL_PARTIAL,
RBT_FP_LOW:RBT_TL_PARTIAL
},
RBT_BI_C:\00000054\{
RBT_FP_HIGH:RBT_TL_SANITY,
RBT_FP_MEDIUM:RBT_TL_SANITY,
RBT_FP_LOW:RBT_TL_SANITY
}
}
}

RBT_THRESH_DATA
{
RBT_FP_LOW_THRESHOLD:\00000033\{
RBT_FP_HIGH:76,
RBT_FP_MEDIUM:52,
RBT_FP_LOW:32
},
RBT_BI_LOW_THRESHOLD:\00000029\{
RBT_BI_A:76,
RBT_BI_B:52,
RBT_BI_C:32
}
}

RBT_DISPLAY_TIMEUNITS_DATA
{
RBT_DISPLAY_TIMEUNITS_KIND:Hours
}

Columns

 | Column Name | Description | Datatype | Length | Allow Nulls
Primary Key | RBT_CUSTOM_ID | The record ID. | Integer | 4 |
 | RBT_CUSTOM_KEY | The key, for example: RBT_CUSTOM_POLICY_DATA, RBT_CUSTOM_THRESH_DATA (thresholds), or RBT_CUSTOM_DISPLAY_TIMEUNITS. | VarChar | 30 |
 | RBT_CUSTOM_VALUE | The value. It is recommended to change this value in the Quality Center user interface and not to write directly to the database. | LongVarChar | 16 |

Indexes

Index | Primary | Unique
INX_RBT_CUSTOM_KEY |  |
RBT_CUSTOM_PRIMARYKEY |  |

See Also

Quality Center Database


%%LocalItemTitle%%

Quality Center Database

RBT_CUSTOMIZATION_ANSWERS Table

Description

Possible values for risk-based quality management criteria.

Columns

 | Column Name | Description | Datatype | Length | Allow Nulls
Primary Key | RBT_ANS_ID | The record ID. | Integer | 4 |
 | RBT_ANS_QUESTION_ID | The RBT_CUSTOMIZATION_QUESTIONS.RBT_QST_ID of the criterion to which this is a possible value. | Integer | 4 |
 | RBT_ANS_ANSWER | The criterion value. | VarChar | 255 |
 | RBT_ANS_WEIGHT | The weight associated with the criterion value. The weight is used to calculate the overall Risk Category of the requirement. | Integer | 4 |

Indexes

Index | Primary | Unique
INX_RBT_ANS_QUESTION |  |
RBT_ANS_PRIMARYKEY |  |

See Also

Quality Center Database


%%LocalItemTitle%%

RBT_CUSTOMIZATION_ANSWERS Table | Quality Center Database

INX_RBT_ANS_QUESTION Index

Index Properties

Primary Key | No
Unique Values | Yes

Columns

Column | Sort Order
RBT_ANS_QUESTION_ID | Ascending
RBT_ANS_ANSWER | Ascending

See Also

RBT_CUSTOMIZATION_ANSWERS Table | Quality Center Database


%%LocalItemTitle%%

RBT_CUSTOMIZATION_ANSWERS Table | Quality Center Database

RBT_ANS_PRIMARYKEY Index

Index Properties

Primary Key | Yes
Unique Values | Yes

Columns

 | Column | Sort Order
Primary Key | RBT_ANS_ID | Ascending

See Also

RBT_CUSTOMIZATION_ANSWERS Table | Quality Center Database


%%LocalItemTitle%%

Quality Center Database

RBT_CUSTOMIZATION_QUESTIONS Table

Description

Risk-based quality management criteria.

Columns

 | Column Name | Description | Datatype | Length | Allow Nulls
Primary Key | RBT_QST_ID | The record ID. | Integer | 4 |
 | RBT_QST_QUESTION | The criterion. | VarChar | 255 |
 | RBT_QST_DESCRIPTION | The description of the criterion and its values in HTML format. It is recommended to change this value in the Quality Center user interface and not to write directly to the database. | LongVarChar | 16 |
 | RBT_QST_RISK_KIND | A value of: 1 indicates a criterion used to determine Business Criticality. 2 indicates a criterion used to determine Failure Probability. | Integer | 4 |
 | RBT_QST_ORDER | The order in which the criterion is displayed in the user interface. | Integer | 4 |

Indexes

Index | Primary | Unique
RBT_QST_PRIMARYKEY |  |

See Also

Quality Center Database


%%LocalItemTitle%%

RBT_CUSTOMIZATION_QUESTIONS Table | Quality Center Database

RBT_QST_PRIMARYKEY Index

Index Properties

Primary Key | Yes
Unique Values | Yes

Columns

 | Column | Sort Order
Primary Key | RBT_QST_ID | Ascending

See Also

RBT_CUSTOMIZATION_QUESTIONS Table | Quality Center Database


%%LocalItemTitle%%

Quality Center Database

RELEASE_CYCLES Table

Description

Details of cycles. A release can contain a number of cycles.

Columns

 | Column Name | Description | Datatype | Length | Allow Nulls
Primary Key | RCYC_ID | The record ID. | Integer | 4 |
 | RCYC_PARENT_ID | The RELEASES.REL_ID of the release to which the cycle belongs. | Integer | 4 |
 | RCYC_NAME | The cycle name. | VarChar | 255 |
 | RCYC_VER_STAMP | The record version. | Integer | 4 |
 | RCYC_START_DATE | The cycle start date. | DBTimeStamp | 4 |
 | RCYC_END_DATE | The cycle end date. | DBTimeStamp | 4 |
 | RCYC_DESCRIPTION | The cycle description. | LongVarChar | 16 |
 | RCYC_HAS_ATTACHMENTS | A value of Y indicates that the cycle has an attachment. | VarChar | 1 |
 | RCYC_USER_01 | User defined field. | VarChar | 40 |

Indexes

Index | Primary | Unique
RCYC_PRIMARYKEY |  |
RCYC_UNIQUE_NAME_IDX |  |

See Also

Quality Center Database


%%LocalItemTitle%%

RELEASE_CYCLES Table | Quality Center Database

RCYC_PRIMARYKEY Index

Index Properties

Primary Key | Yes
Unique Values | Yes

Columns

 | Column | Sort Order
Primary Key | RCYC_ID | Ascending

See Also

RELEASE_CYCLES Table | Quality Center Database


%%LocalItemTitle%%

RELEASE_CYCLES Table | Quality Center Database

RCYC_UNIQUE_NAME_IDX Index

Index Properties

Primary Key | No
Unique Values | Yes

Columns

Column | Sort Order
RCYC_PARENT_ID | Ascending
RCYC_NAME | Ascending

See Also

RELEASE_CYCLES Table | Quality Center Database


%%LocalItemTitle%%

Quality Center Database

RELEASE_FOLDERS Table

Description

Folders for release records.

Columns

 | Column Name | Description | Datatype | Length | Allow Nulls
Primary Key | RF_ID | The record ID. | Integer | 4 |
 | RF_PARENT_ID | The RF_ID of the containing folder. The root folder's parent ID is -1. | Integer | 4 |
 | RF_NAME | The folder name. | VarChar | 255 |
 | RF_VER_STAMP | The record version. | Integer | 4 |
 | RF_DESCRIPTION | The description of the folder. | LongVarChar | 16 |
 | RF_HAS_ATTACHMENTS | A value of Y indicates that the folder has attachments. | VarChar | 1 |
 | RF_PATH | A value from AAA to ZZZ appended to the path of the parent folder. For example, the path of the third child of the root folder is AAAAAC. | VarChar | 255 |
 | RF_USER_01 | User defined field. | VarChar | 40 |

Indexes

Index | Primary | Unique
RF_PATH_IDX |  |
RF_PRIMARYKEY |  |
RF_UNIQUE_NAME_IDX |  |

See Also

Quality Center Database


%%LocalItemTitle%%

RELEASE_FOLDERS Table | Quality Center Database

RF_PATH_IDX Index

Description

Index Properties

Primary Key | No
Unique Values | Yes

Columns

Column | Sort Order
RF_PATH | Ascending

Description

See Also

RELEASE_FOLDERS Table | Quality Center Database


%%LocalItemTitle%%

RELEASE_FOLDERS Table | Quality Center Database

RF_PRIMARYKEY Index

Description

Index Properties

Primary Key | Yes
Unique Values | Yes

Columns

 | Column | Sort Order
Primary Key | RF_ID | Ascending

Description

See Also

RELEASE_FOLDERS Table | Quality Center Database


%%LocalItemTitle%%

RELEASE_FOLDERS Table | Quality Center Database

RF_UNIQUE_NAME_IDX Index

Description

Index Properties

Primary Key | No
Unique Values | Yes

Columns

Column | Sort Order
RF_PARENT_ID | Ascending
RF_NAME | Ascending

Description

See Also

RELEASE_FOLDERS Table | Quality Center Database


%%LocalItemTitle%%

Quality Center Database

RELEASE_MULTIVALUE Table

Description

Multiple values for release records.

Columns

Column Name | Description | Datatype | Length | Allow Nulls
RELMV_RELEASE_ID | The release ID: RELEASES.REL_ID. | Integer | 4 |
RELMV_COLUMN_NAME | The multi-value column. | VarChar | 40 |
RELMV_VALUE | A single value. Note: The values are denormalized for performance reasons. Any program that alters the values in this value field must also handle the semicolon-separated value in the main entity table. | VarChar | 255 |

Indexes

Index | Primary | Unique
INX_RELMV |  |
INX_RELMV_RELEASE_ID |  |

See Also

Quality Center Database


%%LocalItemTitle%%

RELEASE_MULTIVALUE Table | Quality Center Database

INX_RELMV Index

Index Properties

Primary Key | Yes
Unique Values | Yes

Columns

Column | Sort Order
RELMV_COLUMN_NAME | Ascending
RELMV_VALUE | Ascending
RELMV_RELEASE_ID | Ascending

See Also

RELEASE_MULTIVALUE Table | Quality Center Database


%%LocalItemTitle%%

RELEASE_MULTIVALUE Table | Quality Center Database

INX_RELMV_RELEASE_ID Index

Index Properties

Primary Key | Yes
Unique Values | No

Columns

Column | Sort Order
RELMV_RELEASE_ID | Ascending

See Also

RELEASE_MULTIVALUE Table | Quality Center Database


%%LocalItemTitle%%

Quality Center Database

RELEASECYCLE_MULTIVALUE Table

Description

Multiple values for release cycle records.

Columns

Column Name | Description | Datatype | Length | Allow Nulls
RCYCMV_CYCLE_ID | The release cylcle ID: RELEASE_CYCLES.RCYC_ID. | Integer | 4 |
RCYCMV_COLUMN_NAME | The multi-value column. | VarChar | 40 |
RCYCMV_VALUE | A single value. Note: The values are denormalized for performance reasons. Any program that alters the values in this value field must also handle the semicolon-separated value in the main entity table. | VarChar | 255 |

Indexes

Index | Primary | Unique
INX_RCYCMV |  |
INX_RCYCMV_CYCLE_ID |  |

See Also

Quality Center Database


%%LocalItemTitle%%

RELEASECYCLE_MULTIVALUE Table | Quality Center Database

INX_RCYCMV Index

Index Properties

Primary Key | Yes
Unique Values | Yes

Columns

Column | Sort Order
RCYCMV_COLUMN_NAME | Ascending
RCYCMV_VALUE | Ascending
RCYCMV_CYCLE_ID | Ascending

See Also

RELEASECYCLE_MULTIVALUE Table | Quality Center Database


%%LocalItemTitle%%

RELEASECYCLE_MULTIVALUE Table | Quality Center Database

INX_RCYCMV_CYCLE_ID Index

Index Properties

Primary Key | Yes
Unique Values | No

Columns

Column | Sort Order
RCYCMV_CYCLE_ID | Ascending

See Also

RELEASECYCLE_MULTIVALUE Table | Quality Center Database


%%LocalItemTitle%%

Quality Center Database

RELEASEFOLDER_MULTIVALUE Table

Description

Multiple values for release folder records.

Columns

Column Name | Description | Datatype | Length | Allow Nulls
RFMV_RELFOLD_ID | The release folder ID: RELEASE_FOLDERS.RF_ID. | Integer | 4 |
RFMV_COLUMN_NAME | The multi-value column. | VarChar | 40 |
RFMV_VALUE | A single value. Note: The values are denormalized for performance reasons. Any program that alters the values in this value field must also handle the semicolon-separated value in the main entity table. | VarChar | 255 |

Indexes

Index | Primary | Unique
INX_RFMV |  |
INX_RFMV_RELFOLD_ID |  |

See Also

Quality Center Database


%%LocalItemTitle%%

RELEASEFOLDER_MULTIVALUE Table | Quality Center Database

INX_RFMV Index

Index Properties

Primary Key | Yes
Unique Values | Yes

Columns

Column | Sort Order
RFMV_COLUMN_NAME | Ascending
RFMV_VALUE | Ascending
RFMV_RELFOLD_ID | Ascending

See Also

RELEASEFOLDER_MULTIVALUE Table | Quality Center Database


%%LocalItemTitle%%

RELEASEFOLDER_MULTIVALUE Table | Quality Center Database

INX_RFMV_RELFOLD_ID Index

Index Properties

Primary Key | Yes
Unique Values | No

Columns

Column | Sort Order
RFMV_RELFOLD_ID | Ascending

See Also

RELEASEFOLDER_MULTIVALUE Table | Quality Center Database


%%LocalItemTitle%%

Quality Center Database

RELEASES Table

Description

Information about a product release.

Columns

 | Column Name | Description | Datatype | Length | Allow Nulls
Primary Key | REL_ID | The record ID. | Integer | 4 |
 | REL_PARENT_ID | The RELEASE_FOLDERS.RF_ID of the folder that contains the release. | Integer | 4 |
 | REL_NAME | The release name. | VarChar | 255 |
 | REL_VER_STAMP | The record version. | Integer | 4 |
 | REL_START_DATE | The start date of the release. | DBTimeStamp | 4 |
 | REL_END_DATE | The end date of the release. | DBTimeStamp | 4 |
 | REL_DESCRIPTION | The description of the release. | LongVarChar | 16 |
 | REL_HAS_ATTACHMENTS | If value is Y, the release has attachments. | VarChar | 1 |
 | REL_USER_01 | User defined field. | VarChar | 40 |

Indexes

Index | Primary | Unique
REL_PRIMARYKEY |  |
REL_UNIQUE_NAME_IDX |  |

See Also

Quality Center Database


%%LocalItemTitle%%

RELEASES Table | Quality Center Database

REL_PRIMARYKEY Index

Description

Index Properties

Primary Key | Yes
Unique Values | Yes

Columns

 | Column | Sort Order
Primary Key | REL_ID | Ascending

Description

See Also

RELEASES Table | Quality Center Database


%%LocalItemTitle%%

RELEASES Table | Quality Center Database

REL_UNIQUE_NAME_IDX Index

Index Properties

Primary Key | No
Unique Values | Yes

Columns

Column | Sort Order
REL_PARENT_ID | Ascending
REL_NAME | Ascending

See Also

RELEASES Table | Quality Center Database


%%LocalItemTitle%%

Quality Center Database

REPOSITORY Table

Description

Storage for database simulation of file system.

Remarks

This table stores attachments, test scripts, and other files. Storage in this table is an alternative to storage on the application server's file system.

Columns

 | Column Name | Description | Datatype | Length | Allow Nulls
Primary Key | RP_ID | The record ID. | Integer | 4 |
 | RP_PARENT_PATH | The path of the parent directory in the simulated file system hierarchy. | VarChar | 255 |
 | RP_NAME | The name of the file or directory. | VarChar | 255 |
 | RP_PATH_ID | For a directory, the path identifier. For a file, always 0. | Integer | 4 |
 | RP_NEXT_CHILD_PATH_ID | The path identifier (RP_PATH_ID) to allocate the next time a directory is created. | Integer | 4 |
 | RP_CREATED_TIME | Database server time stamp for item creation. | DBTimeStamp | 4 |
 | RP_MODIFIED_TIME | Database server time stamp for most recent modification. | DBTimeStamp | 4 |
 | RP_IS_READONLY | If Y, the item cannot be modified. | VarChar | 1 |
 | RP_DATA | For files, the file data. For directories, NULL. | LongVarBinary | 2147483647 |

Indexes

Index | Primary | Unique
RP_IX_PATH |  |
RP_PATH_CONSTR |  |
RP_PRIMARYKEY |  |

See Also

Quality Center Database


%%LocalItemTitle%%

REPOSITORY Table | Quality Center Database

RP_IX_PATH Index

Description

Index Properties

Primary Key | No
Unique Values | Yes

Columns

Column | Sort Order
RP_PARENT_PATH | Ascending
RP_NAME | Ascending
RP_PATH_ID | Ascending

Description

See Also

REPOSITORY Table | Quality Center Database


%%LocalItemTitle%%

REPOSITORY Table | Quality Center Database

RP_PATH_CONSTR Index

Description

Index Properties

Primary Key | No
Unique Values | Yes

Columns

Column | Sort Order
RP_PARENT_PATH | Ascending
RP_NAME | Ascending

Description

See Also

REPOSITORY Table | Quality Center Database


%%LocalItemTitle%%

REPOSITORY Table | Quality Center Database

RP_PRIMARYKEY Index

Description

Index Properties

Primary Key | Yes
Unique Values | Yes

Columns

 | Column | Sort Order
Primary Key | RP_ID | Ascending

Description

See Also

REPOSITORY Table | Quality Center Database


%%LocalItemTitle%%

Quality Center Database

REQ Table

Description

Details of individual requirements and the structure of the requirements tree.

Remarks

The tree structure is stored in two ways. First, each record holds a pointer to the parent in RQ_FATHER_ID. Within the children of each parent, the order is set with RQ_ORDER_ID. Thus, a self-join between REQ parent and REQ child ordered by child.RQ_FATHER_ID, child.RQ_ORDER_ID can be used to recreate the tree.

The second way the tree is stored is in RQ_REQ_PATH. The highest level nodes (RQ_FATHER_ID = -1) are ordered from AAA to ZZZ. Each child node down the tree inherits the parent path, and within the parent node, the requirements are ordered AAA to ZZZ where the current level numeration is concatenated to the inherited path. For example, the child requirements of the first node (AAA) have paths of AAAAAA, AAAAAB, AAAAAC, and so on.

Use of a self-join is easy to program when recreating the entire tree or a sub-tree. The path can be used when looking for the children of a given node since the child paths are the parent path plus three more characters.

To identify the tests and test steps that cover the requirements, see the REQ_COVER Table.

Multiple values for fields are maintained in the REQ_MULTIVALUE Table.

For table relationships, see the Requirements Module Overview.

Many of the integer values are ENUMs. For possible values, see the API reference.

Columns

 | Column Name | Description | Datatype | Length | Allow Nulls
Primary Key | RQ_REQ_ID | The record ID. | Integer | 4 |
 | RQ_FATHER_ID | The ID of the requirement for which this requirement is a sub-requirement. Top level requirements have a father ID of -1. | Integer | 4 |
 | RQ_ORDER_ID | The order in which the requirement appears in the user interface among other requirements at the same level of the requirements hierarchy. | Integer | 4 |
 | RQ_ISTEMPLATE | For backward compatibility. Field may be removed in future version. | Integer | 4 |
 | RQ_REQ_COMMENT | The requirement comment. | LongVarChar | 16 |
 | RQ_REQ_REVIEWED | Indicates whether or not the user responsible for the project has reviewed the requirement. The values are from the Review Status custom list. Typical values are: Changed, Not Reviewed, Reviewed. | VarChar | 70 |
 | RQ_REQ_PATH | The requirement path in the requirements hierarchy. See explanation in the Remarks. | VarChar | 255 |
 | RQ_REQ_STATUS | The aggregated status of previous runs of tests in the requirement coverage. Indicates whether any test that covers the requirement fails. The values are from the Status custom list. Typical values are: No Run, Failed, Passed, Not Completed, N/A. In addition to the values from the list, the Not Covered value can be assigned. | VarChar | 70 |
 | RQ_REQ_PRIORITY | The requirement priority level. The values are from the Priority custom list. Typical values are: 1-Low, 2-Medium, 3-High, 4-Very High, 5-Urgent. | VarChar | 70 |
 | RQ_REQ_TYPE | Obsolete. In previous versions, the requirement type. The values are from the Requirement Type custom list. Typical values are: Change, Functional, Guideline, Quality, Standard, System. | VarChar | 70 |
 | RQ_REQ_PRODUCT | The product for which the requirement is designed. | VarChar | 70 |
 | RQ_REQ_NAME | The name assigned to the requirement by the tester who designed the requirement. | VarChar | 255 |
 | RQ_REQ_AUTHOR | The user name of the person who designed the requirement. | VarChar | 70 |
 | RQ_RBT_IGNORE_IN_ANALYSIS | A value of Y indicates that this requirement is not included in risk-based quality management analysis regardless of filter and other settings. | VarChar | 1 |
 | RQ_RBT_BSNS_IMPACT | Business Criticality value calculated by Quality Center. A value of enum TD_RBT_BI_LEVELS. | VarChar | 1 |
 | RQ_RBT_CUSTOM_BSNS_IMPACT | Business Criticality value set by a user. A value of enum TD_RBT_BI_LEVELS. | VarChar | 1 |
 | RQ_RBT_USE_CUSTOM_BSNS_IMPACT | If true, RQ_RBT_CUSTOM_BSNS_IMPACT is used. If false, RQ_RBT_BSNS_IMPACT is used. | VarChar | 1 |
 | RQ_RBT_EFFECTIVE_BSNS_IMPACT | The Business Impact value used by the risk-based quality management analysis algorithm to analyze the Testing Level and testing time of this requirement. The value depends on the RQ_RBT_USE_CUSTOM_BSNS_IMPACT setting. | VarChar | 1 |
 | RQ_RBT_FAIL_PROB | The Failure Probability value calculated by Quality Center. A value of enum TD_RBT_FP_LEVELS. | VarChar | 1 |
 | RQ_RBT_CUSTOM_FAIL_PROB | The Failure Probability value set by a user. A value of enum TD_RBT_FP_LEVELS. | VarChar | 1 |
 | RQ_RBT_USE_CUSTOM_FAIL_PROB | If true, RQ_CUSTOM_FAIL_PROB is used. If false, RQ_FAIL_PROB is used. | VarChar | 1 |
 | RQ_RBT_EFFECTIVE_FAIL_PROB | The Failure Probability value used by the risk-based quality management analysis algorithm. The value depends on the RQ_RBT_USE_CUSTOM_FAIL_PROB setting. | VarChar | 1 |
 | RQ_RBT_TESTING_LEVEL | Testing Level set by the risk-based quality management analysis. A value of enum TD_RBT_TESTING_LEVELS. | VarChar | 70 |
 | RQ_RBT_CUSTOM_TESTING_LEVEL | Testing Level value set by a user. A value of enum TD_RBT_TESTING_LEVELS. | VarChar | 70 |
 | RQ_RBT_TESTING_HOURS | The testing time that was estimated for this requirement by the risk-based quality management analysis. | Integer | 4 |
 | RQ_RBT_CUSTOM_TESTING_HOURS | Testing time value set by a user. | Integer | 4 |
 | RQ_RBT_USE_CUSTOM_TL_AND_TE | Indicates whether to use custom or calculated Testing Level and testing time for risk-based quality management calculations. | VarChar | 1 |
 | RQ_RBT_RND_ESTIM_EFFORT_HOURS | Estimated development time. | Integer | 4 |
 | RQ_RBT_ASSESSMENT_DATA | The values assigned to the risk-based quality management assessment criteria. It is recommended to edit this value in the Quality Center user interface, and not to write directly to the database. | LongVarChar | 16 |
 | RQ_RBT_ANALYSIS_PARENT_REQ_ID | The RQ_REQ_ID of the requirement on which was performed the last analysis that was used to calculate the RQ_TESTING_LEVEL and RQ_TESTING_HOURS fields of this requirement. | Integer | 4 |
 | RQ_RBT_ANALYSIS_SETUP_DATA | The settings used to perform the last risk-based quality management analysis of the sub-tree of this requirement, including the filter, the policy, and the allocated time. It is recommended to edit this value in the Quality Center user interface, and not to write directly to the database. | LongVarChar | 16 |
 | RQ_RBT_ANALYSIS_RESULT_DATA | The aggregated results of the latest risk-based quality management analysis. It is recommended to edit this value in the Quality Center user interface, and not to write directly to the database. | LongVarChar | 16 |
 | RQ_RBT_LAST_ANALYSIS_DATE | The date and time of the last analysis. | DBTimeStamp | 4 |
 | RQ_USER_01 | User-defined field. | VarChar | 40 |
 | RQ_USER_02 | User-defined field. | VarChar | 40 |
 | RQ_USER_03 | User-defined field. | VarChar | 40 |
 | RQ_USER_04 | User-defined field. | VarChar | 40 |
 | RQ_USER_05 | User-defined field. | VarChar | 40 |
 | RQ_USER_06 | User-defined field. | VarChar | 40 |
 | RQ_USER_07 | User-defined field. | VarChar | 40 |
 | RQ_USER_08 | User-defined field. | VarChar | 40 |
 | RQ_USER_09 | User-defined field. | VarChar | 40 |
 | RQ_USER_10 | User-defined field. | VarChar | 40 |
 | RQ_USER_11 | User-defined field. | VarChar | 40 |
 | RQ_USER_12 | User-defined field. | VarChar | 40 |
 | RQ_REQ_VER_STAMP | The revision number of this requirement. Increments each time the record is updated. | Integer | 4 |
 | RQ_ATTACHMENT | A value of Y indicates that the requirement has at least one attachment. | VarChar | 1 |
 | RQ_REQ_DATE | The date the requirement was created according to the database server clock. | DBTimeStamp | 4 |
 | RQ_REQ_TIME | The time the requirement was created according to the database server clock. | VarChar | 10 |
 | RQ_NO_OF_SONS | The number of requirements that have this requirement as a parent requirement, that is, have their RQ_FATHER_ID field set to this requirement’s ID. | Integer | 4 |
 | RQ_IS_FOLDER | Used by the ReqPro synchronizer. | VarChar | 1 |
 | RQ_VTS | The time stamp of the last time the record was updated according to the database server clock. | VarChar | 20 |
 | RQ_USER_13 | User-defined field. | VarChar | 40 |
 | RQ_USER_14 | User-defined field. | VarChar | 40 |
 | RQ_USER_15 | User-defined field. | VarChar | 40 |
 | RQ_USER_16 | User-defined field. | VarChar | 40 |
 | RQ_USER_17 | User-defined field. | VarChar | 40 |
 | RQ_USER_18 | User-defined field. | VarChar | 40 |
 | RQ_USER_19 | User-defined field. | VarChar | 40 |
 | RQ_USER_20 | User-defined field. | VarChar | 40 |
 | RQ_USER_21 | User-defined field. | VarChar | 40 |
 | RQ_USER_22 | User-defined field. | VarChar | 40 |
 | RQ_USER_23 | User-defined field. | VarChar | 40 |
 | RQ_USER_24 | User-defined field. | VarChar | 40 |
 | RQ_REQUEST_ID | The ITG request ID. Used internally for ITG-QC integration. | Integer | 4 |
 | RQ_TEXT_SYNC | For internal use. Do not change data. | VarChar | 1 |
 | RQ_REQUEST_SERVER | The URL of the ITG server. Used internally for ITG-QC integration. | VarChar | 120 |
 | RQ_REQUEST_TYPE | ITG request type. Used internally for ITG-QC integration. | VarChar | 120 |
 | RQ_REQUEST_STATUS | ITG request status. Used internally for ITG-QC integration. | VarChar | 40 |
 | RQ_REQUEST_UPDATES | ITG request updates information. Used internally for ITG-QC integration. | VarChar | 120 |
 | RQ_REQUEST_ASSIGN_TO | The user to whom the requirement is assigned. | VarChar | 120 |
 | RQ_REQUEST_NOTE | The notes added to the request in ITG. | LongVarChar | 16 |
 | RQ_TYPE_ID | The REQ_TYPE.TPR_TYPE_ID. A value of 0 indicates that the requirement type is not defined. | Integer | 4 |
 | RQ_TARGET_RCYC | For internal use. Do not write to this field. | Integer | 4 |
 | RQ_TARGET_REL | For internal use. Do not write to this field. | Integer | 4 |
 | RQ_DEV_COMMENTS | Comments about the requirement. | LongVarChar | 16 |
 | RQ_HAS_RICH_CONTENT | Requirement has rich-text content. This property is used only in Quality Center 9.2. Its use will be discontinued in later versions. | VarChar | 1 |

Indexes

Index | Primary | Unique
RQ_FATHER_NAME_LWR_IDX |  |
RQ_PRIMARYKEY |  |
RQ_REQ_PATH_IDX |  |
RQ_REQ_STATUS_IDX |  |
RQ_TYPE_ID_IDX |  |

Triggers

Trigger | Description
AUTR81022_REQ |

See Also

Quality Center Database


%%LocalItemTitle%%

Quality Center Database

REQ_COVER Table

Description

An associative table linking requirements to the design tests and test instances in test sets that cover the requirements.

Remarks

For covering tests, the link is to the TEST Table. For test instances, the link is to the TESTCYCL Table.

Columns

 | Column Name | Description | Datatype | Length | Allow Nulls
Primary Key | RC_ITEM_ID | The record ID. | Integer | 4 |
 | RC_REQ_ID | The REQ.RQ_REQ_ID of the covered requirement. | Integer | 4 |
 | RC_ENTITY_ID | The ID of the entity that covers the requirement, either a TEST.TS_TEST_ID or a TESTCYCL.TC_TESTCYCL_ID. | Integer | 4 |
 | RC_ENTITY_TYPE | The table name of the covering entity type: TEST or TESTCYCL. | VarChar | 30 |

Indexes

Index | Primary | Unique
RC_ENTITY_ID_IDX |  |
RC_PRIMARYKEY |  |
RC_REQ_ID_IDX |  |

See Also

Quality Center Database


%%LocalItemTitle%%

REQ_COVER Table | Quality Center Database

RC_ENTITY_ID_IDX Index

Description

Index Properties

Primary Key | No
Unique Values | Yes

Columns

Column | Sort Order
RC_ENTITY_ID | Ascending
RC_ENTITY_TYPE | Ascending
RC_REQ_ID | Ascending

Description

See Also

REQ_COVER Table | Quality Center Database


%%LocalItemTitle%%

REQ_COVER Table | Quality Center Database

RC_PRIMARYKEY Index

Description

Index Properties

Primary Key | Yes
Unique Values | Yes

Columns

 | Column | Sort Order
Primary Key | RC_ITEM_ID | Ascending

Description

See Also

REQ_COVER Table | Quality Center Database


%%LocalItemTitle%%

REQ_COVER Table | Quality Center Database

RC_REQ_ID_IDX Index

Description

Index Properties

Primary Key | No
Unique Values | No

Columns

Column | Sort Order
RC_REQ_ID | Ascending

Description

See Also

REQ_COVER Table | Quality Center Database


%%LocalItemTitle%%

Quality Center Database

REQ_CYCLES Table

Description

An associative table linking requirements to release cycles.

Columns

 | Column Name | Description | Datatype | Length | Allow Nulls
Primary Key | RQC_ID | The record ID. | Integer | 4 |
 | RQC_REQ_ID | The REQ.RQ_REQ_ID. | Integer | 4 |
 | RQC_CYCLE_ID | The RELEASE_CYCLES.RCYC_ID. | Integer | 4 |

Indexes

Index | Primary | Unique
REQ_CYCLES_PK |  |
REQ_CYCLES_UK_1 |  |
REQ_CYCLES_IDX1 |  |

See Also

Quality Center Database


%%LocalItemTitle%%

REQ_CYCLES Table | Quality Center Database

REQ_CYCLES_IDX1 Index

Description

Index Properties

Primary Key | No
Unique Values | No

Columns

Column | Sort Order
RQC_CYCLE_ID | Ascending

Description

See Also

REQ_CYCLES Table | Quality Center Database


%%LocalItemTitle%%

REQ_CYCLES Table | Quality Center Database

REQ_CYCLES_PK Index

Description

Index Properties

Primary Key | Yes
Unique Values | Yes

Columns

 | Column | Sort Order
Primary Key | RQC_ID | Ascending

Description

See Also

REQ_CYCLES Table | Quality Center Database


%%LocalItemTitle%%

REQ_CYCLES Table | Quality Center Database

REQ_CYCLES_UK_1 Index

Description

Index Properties

Primary Key | No
Unique Values | Yes

Columns

Column | Sort Order
RQC_REQ_ID | Ascending
RQC_CYCLE_ID | Ascending

Description

See Also

REQ_CYCLES Table | Quality Center Database


%%LocalItemTitle%%

Quality Center Database

REQ_MULTIVALUE Table

Description

Multiple values for requirement records.

Columns

Column Name | Description | Datatype | Length | Allow Nulls
RQMV_REQ_ID | The requirement ID: REQ.RQ_REQ_ID. | Integer | 4 |
RQMV_COLUMN_NAME | The multi-value column. | VarChar | 40 |
RQMV_VALUE | A single value. Note: The values are denormalized for performance reasons. Any program that alters the values in this value field must also handle the semicolon-separated value in the main entity table. | VarChar | 255 |

Indexes

Index | Primary | Unique
INX_RQMV |  |
INX_RQMV_REQ_ID |  |

See Also

Quality Center Database


%%LocalItemTitle%%

REQ_MULTIVALUE Table | Quality Center Database

INX_RQMV Index

Description

Index Properties

Primary Key | Yes
Unique Values | Yes

Columns

Column | Sort Order
RQMV_COLUMN_NAME | Ascending
RQMV_VALUE | Ascending
RQMV_REQ_ID | Ascending

Description

See Also

REQ_MULTIVALUE Table | Quality Center Database


%%LocalItemTitle%%

REQ_MULTIVALUE Table | Quality Center Database

INX_RQMV_REQ_ID Index

Index Properties

Primary Key | Yes
Unique Values | No

Columns

Column | Sort Order
RQMV_REQ_ID | Ascending

See Also

REQ_MULTIVALUE Table | Quality Center Database


%%LocalItemTitle%%

Quality Center Database

REQ_RELEASES Table

Description

An associative table linking requirements to releases.

Columns

 | Column Name | Description | Datatype | Length | Allow Nulls
Primary Key | RQRL_ID | The record ID. | Integer | 4 |
 | RQRL_REQ_ID | The REQ.RQ_REQ_ID. | Integer | 4 |
 | RQRL_RELEASE_ID | The RELEASES.REL_ID. | Integer | 4 |

Indexes

Index | Primary | Unique
REQ_RELEASES_PK |  |
REQ_RELEASES_UK_1 |  |
REQ_RELEASES_IDX1 |  |

See Also

Quality Center Database


%%LocalItemTitle%%

REQ_RELEASES Table | Quality Center Database

REQ_RELEASES_IDX1 Index

Description

Index Properties

Primary Key | No
Unique Values | No

Columns

Column | Sort Order
RQRL_RELEASE_ID | Ascending

Description

See Also

REQ_RELEASES Table | Quality Center Database


%%LocalItemTitle%%

REQ_RELEASES Table | Quality Center Database

REQ_RELEASES_PK Index

Description

Index Properties

Primary Key | Yes
Unique Values | Yes

Columns

 | Column | Sort Order
Primary Key | RQRL_ID | Ascending

Description

See Also

REQ_RELEASES Table | Quality Center Database


%%LocalItemTitle%%

REQ_RELEASES Table | Quality Center Database

REQ_RELEASES_UK_1 Index

Description

Index Properties

Primary Key | No
Unique Values | Yes

Columns

Column | Sort Order
RQRL_REQ_ID | Ascending
RQRL_RELEASE_ID | Ascending

Description

See Also

REQ_RELEASES Table | Quality Center Database


%%LocalItemTitle%%

Quality Center Database

REQ_TRACE Table

Description

Associations between requirements.

Columns

 | Column Name | Description | Datatype | Length | Allow Nulls
Primary Key | RT_TRACE_ID | The record ID. | Integer | 4 |
 | RT_FROM_REQ_ID | The ID of the requirement from which the trace is made to the item specified by RT_TO_REQ_ID. | Integer | 4 |
 | RT_TO_REQ_ID | The dependent target of the trace from the requirement specified with RT_FROM_REQ_ID. | Integer | 4 |
 | RT_CREATED_BY | The username of the user who created the record. | VarChar | 60 |
 | RT_CREATION_DATE | Record creation date according to database server. | DBTimeStamp | 4 |
 | RT_COMMENT | Description of trace. | VarChar | 255 |
 | RT_VTS | The version time stamp. Indicates the time this record was last changed according to the database server. | VarChar | 20 |

Indexes

Index | Primary | Unique
RT_FROM_TO_IDX |  |
RT_PRIMARYKEY |  |
RT_FROM_IDX |  |
RT_TO_IDX |  |

See Also

Quality Center Database


%%LocalItemTitle%%

REQ_TRACE Table | Quality Center Database

RT_FROM_IDX Index

Description

Index Properties

Primary Key | No
Unique Values | No

Columns

Column | Sort Order
RT_FROM_REQ_ID | Ascending

Description

See Also

REQ_TRACE Table | Quality Center Database


%%LocalItemTitle%%

REQ_TRACE Table | Quality Center Database

RT_FROM_TO_IDX Index

Description

Index Properties

Primary Key | No
Unique Values | Yes

Columns

Column | Sort Order
RT_FROM_REQ_ID | Ascending
RT_TO_REQ_ID | Ascending

Description

See Also

REQ_TRACE Table | Quality Center Database


%%LocalItemTitle%%

REQ_TRACE Table | Quality Center Database

RT_PRIMARYKEY Index

Description

Index Properties

Primary Key | Yes
Unique Values | Yes

Columns

 | Column | Sort Order
Primary Key | RT_TRACE_ID | Ascending

Description

See Also

REQ_TRACE Table | Quality Center Database


%%LocalItemTitle%%

REQ_TRACE Table | Quality Center Database

RT_TO_IDX Index

Index Properties

Primary Key | No
Unique Values | No

Columns

Column | Sort Order
RT_TO_REQ_ID | Ascending

See Also

REQ_TRACE Table | Quality Center Database


%%LocalItemTitle%%

Quality Center Database

REQ_TYPE Table

Description

Types of requirements.

Remarks

The table is installed already populated with predefined types: Folder, Group, Undefined, Functional, Business, Testing. Additional types are added by the project administrator.

Columns

 | Column Name | Description | Datatype | Length | Allow Nulls
Primary Key | TPR_TYPE_ID | The record ID. | Integer | 4 |
 | TPR_NAME | The type name. | VarChar | 80 |
 | TPR_ICON_STREAM | The encoded graphic icon. | VarChar | 2000 |
 | TPR_PREFIX | The recommended prefix for requirements of this type. For example, if TPR_PREFIX for the type is BIZ, requirements of the type should have names like BIZ_REQ1. Quality Center does not change the names of existing requirements if TPR_PREFIX is changed. | VarChar | 10 |
 | TPR_EDITING_CONTROL | For future use. | VarChar | 255 |
 | TPR_HAS_DIRECT_COVERAGE | A value of 1 indicates that this type of requirement can have direct test coverage. | VarChar | 1 |
 | TPR_RISK_ANALYSIS_TYPE | A value of enum TDAPI_RBT_REQUIREMENT_TYPE_RISK_ANALYSIS_TYPE. See the API reference for possible values. | Integer | 4 |

Indexes

Index | Primary | Unique
TPR_NAME_LWR_IDX |  |
TPR_PRIMARYKEY |  |

See Also

Quality Center Database


%%LocalItemTitle%%

Quality Center Database

REQ_TYPE_FIELD Table

Description

Specifies which fields are required for each requirement type.

Columns

 | Column Name | Description | Datatype | Length | Allow Nulls
Primary Key | RTF_ID | The record ID. | Integer | 4 |
 | RTF_TYPE_ID | The REQ_TYPE.TPR_TYPE_ID. | Integer | 4 |
 | RTF_SF_TABLE_NAME | The SYSTEM_FIELD.SF_TABLE_NAME. | VarChar | 40 |
 | RTF_SF_COLUMN_NAME | The SYSTEM_FIELD.SF_COLUMN_NAME . | VarChar | 40 |
 | RTF_IS_REQUIRED | A Value of Y indicates that the field RTF_SF_TABLE_NAME.RTF_SF_COLUMN_NAME is required for this type. | VarChar | 1 |

Indexes

Index | Primary | Unique
RTF_PRIMARYKEY |  |
RTF_TYPE_TABLE_COL_IDX |  |

See Also

Quality Center Database


%%LocalItemTitle%%

REQ_TYPE_FIELD Table | Quality Center Database

RTF_PRIMARYKEY Index

Description

Index Properties

Primary Key | Yes
Unique Values | Yes

Columns

 | Column | Sort Order
Primary Key | RTF_ID | Ascending

Description

See Also

REQ_TYPE_FIELD Table | Quality Center Database


%%LocalItemTitle%%

REQ_TYPE_FIELD Table | Quality Center Database

RTF_TYPE_TABLE_COL_IDX Index

Index Properties

Primary Key | No
Unique Values | Yes

Columns

Column | Sort Order
RTF_TYPE_ID | Ascending
RTF_SF_TABLE_NAME | Ascending
RTF_SF_COLUMN_NAME | Ascending

See Also

REQ_TYPE_FIELD Table | Quality Center Database


%%LocalItemTitle%%

Quality Center Database

REQ_TYPE_HIER_RULES Table

Description

The hierarchy rules for requirement types in the requirement tree. For internal use. Do not change values in this table.

Columns

 | Column Name | Description | Datatype | Length | Allow Nulls
Primary Key | RTHR_ID | The record ID. | Integer | 4 |
 | RTHR_TYPE_ID | The requirement type, REQ_TYPE.TPR_TYPE_ID | Integer | 4 |
 | RTHR_PARENT_TYPE_ID | A requirement type (REQ_TYPE.TPR_TYPE_ID) that is a valid parent folder for this type. A value of -1 indicates that the type can have any requirement type as a parent folder. The parent of a folder is always another folder. | Integer | 4 |

Indexes

Index | Primary | Unique
RTHR_PARENT_TYPE_IDX |  |
RTHR_PRIMARYKEY |  |
RTHR_TYPE_PARENT_IDX |  |

See Also

Quality Center Database


%%LocalItemTitle%%

REQ_TYPE_HIER_RULES Table | Quality Center Database

RTHR_PARENT_TYPE_IDX Index

Description

Index Properties

Primary Key | No
Unique Values | Yes

Columns

Column | Sort Order
RTHR_PARENT_TYPE_ID | Ascending
RTHR_TYPE_ID | Ascending

Description

See Also

REQ_TYPE_HIER_RULES Table | Quality Center Database


%%LocalItemTitle%%

REQ_TYPE_HIER_RULES Table | Quality Center Database

RTHR_PRIMARYKEY Index

Description

Index Properties

Primary Key | Yes
Unique Values | Yes

Columns

 | Column | Sort Order
Primary Key | RTHR_ID | Ascending

Description

See Also

REQ_TYPE_HIER_RULES Table | Quality Center Database


%%LocalItemTitle%%

REQ_TYPE_HIER_RULES Table | Quality Center Database

RTHR_TYPE_PARENT_IDX Index

Index Properties

Primary Key | No
Unique Values | Yes

Columns

Column | Sort Order
RTHR_TYPE_ID | Ascending
RTHR_PARENT_TYPE_ID | Ascending

See Also

REQ_TYPE_HIER_RULES Table | Quality Center Database


%%LocalItemTitle%%

Quality Center Database

RULES Table

Description

Conditions for generating automatic alerts.

Remarks

Information on alerts generated according to these rules is stored in the ALERT Table.

Columns

 | Column Name | Description | Datatype | Length | Allow Nulls
Primary Key | RL_ID | The record ID. | Integer | 4 |
 | RL_CONDITION | An XML description either of an entity or an entity’s value. When the entity changes or when the value of the entity changes to the specified value, the alert is triggered. | LongVarChar | 16 |
 | RL_ACTION | The XML specification of the action to perform when the alert is triggered. | LongVarChar | 16 |
 | RL_RECIPIENT | Specifies the role of the users who receive the notice. | LongVarChar | 16 |
 | RL_DESCRIPTION | A description of the alert. | LongVarChar | 16 |
 | RL_TO_MAIL | If Y, an alert is emailed to the recipients defined in the administration console. | VarChar | 1 |
 | RL_IS_ACTIVE | If Y, the rule is active. | VarChar | 1 |
 | RL_IS_PREDEFINED | For future use. | VarChar | 1 |

Indexes

Index | Primary | Unique
RL_PRIMARYKEY |  |

See Also

Quality Center Database


%%LocalItemTitle%%

RULES Table | Quality Center Database

RL_PRIMARYKEY Index

Description

Index Properties

Primary Key | Yes
Unique Values | Yes

Columns

 | Column | Sort Order
Primary Key | RL_ID | Ascending

Description

See Also

RULES Table | Quality Center Database


%%LocalItemTitle%%

Quality Center Database

RUN Table

Description

Execution records for test instances.

Remarks

Multiple values for fields are maintained in the RUN_MULTIVALUE Table.

Columns

 | Column Name | Description | Datatype | Length | Allow Nulls
 | RN_TESTCYCL_ID | The TESTCYCL.TC_TESTCYCL_ID of the test instance. | Integer | 4 |
 | RN_CYCLE_ID | The CYCLE.CY_CYCLE_ID of the test set containing the test instance. | Integer | 4 |
 | RN_TEST_ID | The TEST.TS_TEST_ID of the design test from which the instance is derived. | Integer | 4 |
Primary Key | RN_RUN_ID | The record ID. | Integer | 4 |
 | RN_RUN_NAME | The name assigned to the test run by the tester. | VarChar | 255 |
 | RN_EXECUTION_DATE | The date on which the test instance run was performed. | DBTimeStamp | 4 |
 | RN_EXECUTION_TIME | The time at which the run was performed according to the database server clock. | VarChar | 10 |
 | RN_HOST | The name or IP address of the host server on which the test was executed. | VarChar | 50 |
 | RN_STATUS | The current status of the test run. The values are from the Status custom list. Typical values are: Not Completed, No Run, Passed, N/A, Failed. | VarChar | 70 |
 | RN_DURATION | The duration of the test run in seconds. | Integer | 4 |
 | RN_TESTER_NAME | The user name of the person who last executed the test. | VarChar | 60 |
 | RN_PATH | The path of this run relative to the test directory (TEST.TS_PATH) in the server repository. | VarChar | 255 |
 | RN_USER_01 | User-defined field. | VarChar | 40 |
 | RN_USER_02 | User-defined field. | VarChar | 40 |
 | RN_USER_03 | User-defined field. | VarChar | 40 |
 | RN_USER_04 | User-defined field. | VarChar | 40 |
 | RN_USER_05 | User-defined field. | VarChar | 40 |
 | RN_USER_06 | User-defined field. | VarChar | 40 |
 | RN_USER_07 | User-defined field. | VarChar | 40 |
 | RN_USER_08 | User-defined field. | VarChar | 40 |
 | RN_USER_09 | User-defined field. | VarChar | 40 |
 | RN_USER_10 | User-defined field. | VarChar | 40 |
 | RN_USER_11 | User-defined field. | VarChar | 40 |
 | RN_USER_12 | User-defined field. | VarChar | 40 |
 | RN_TEST_VERSION | The version of the application being tested. | Integer | 4 |
 | RN_ATTACHMENT | A value of Y indicates that the run has at least one attachment. | VarChar | 1 |
 | RN_RUN_VER_STAMP | The revision number of this record. Increments each time a the record is updated. | Integer | 4 |
 | RN_VTS | The version time stamp. Indicates the time according to the database server clock at which this record was last updated. | VarChar | 20 |
 | RN_CYCLE | For backward compatibility. Field may be removed in future version. | VarChar | 255 |
 | RN_TEST_INSTANCE | The number of this instance of the design test inside the cycle. If the test is run individually, this field will still show which instance was selected to run. | Integer | 4 |
 | RN_OS_NAME | The name of the operating system on which the test run is running. The value is from the Operating System custom list. | VarChar | 70 |
 | RN_OS_SP | Information about the operating system of the computer on which current run was executed. | VarChar | 70 |
 | RN_OS_BUILD | Information about the operating system of the computer on which current run was executed. | VarChar | 70 |
 | RN_VC_LOKEDBY | The name of the user who locked the test in Version Control engine. | VarChar | 255 |
 | RN_VC_STATUS | The version control status of the test instance at the time of execution. The value is from the VC Status custom list. Typical values are checked_out, checked_in, or Read_only. | VarChar | 50 |
 | RN_VC_VERSION | The version control test instance version at the time of execution. | VarChar | 50 |
 | RN_OS_CONFIG | For future use. | VarChar | 40 |
 | RN_ASSIGN_RCYC | The RELEASE_CYCLES.RCYC_ID of the release cycle with which the run is associated. | Integer | 4 |

Indexes

Index | Primary | Unique
RN_CYCLE_IDX |  |
RN_PRIMARYKEY |  |
RN_TEST_ID_IDX |  |
RN_TESTCYCLE_IDX |  |
RN_ASSIGN_RCYC_IDX |  |
RN_TESTCYCLE_OLD_IDX |  |

Triggers

Trigger | Description
AUTR81515_RUN |

See Also

Quality Center Database


%%LocalItemTitle%%

Quality Center Database

RUN_MULTIVALUE Table

Description

Multiple values for run records.

Columns

Column Name | Description | Datatype | Length | Allow Nulls
RNMV_RUN_ID | The RUN.RN_RUN_ID of the run. | Integer | 4 |
RNMV_COLUMN_NAME | The multi-value column. | VarChar | 40 |
RNMV_VALUE | A single value. Note: The values are denormalized for performance reasons. Any program that alters the values in this value field must also handle the semicolon-separated value in the main entity table. | VarChar | 255 |

Indexes

Index | Primary | Unique
INX_RNMV |  |
INX_RNMV_RUN_ID |  |

See Also

Quality Center Database


%%LocalItemTitle%%

RUN_MULTIVALUE Table | Quality Center Database

INX_RNMV Index

Description

Index Properties

Primary Key | Yes
Unique Values | Yes

Columns

Column | Sort Order
RNMV_COLUMN_NAME | Ascending
RNMV_VALUE | Ascending
RNMV_RUN_ID | Ascending

Description

See Also

RUN_MULTIVALUE Table | Quality Center Database


%%LocalItemTitle%%

RUN_MULTIVALUE Table | Quality Center Database

INX_RNMV_RUN_ID Index

Description

Index Properties

Primary Key | Yes
Unique Values | No

Columns

Column | Sort Order
RNMV_RUN_ID | Ascending

Description

See Also

RUN_MULTIVALUE Table | Quality Center Database


%%LocalItemTitle%%

Quality Center Database

RUNTIME_PARAM Table

Description

Parameters defined at design time for Business Process Tests.

Columns

 | Column Name | Description | Datatype | Length | Allow Nulls
Primary Key | RTP_ID | The record ID. | Integer | 4 |
 | RTP_TEST_ID | The TEST.TS_TEST_ID of the test for which the parameter is defined. | Integer | 4 |
 | RTP_NAME | The name of the parameter as entered in the test, without the brackets that are entered in the UI. | VarChar | 255 |
 | RTP_DESC | The parameter description. | LongVarChar | 16 |
 | RTP_VALUE_TYPE | The data type, such as String, Boolean, and so on. | VarChar | 40 |
 | RTP_DEFAULT_VALUE | The parameter's default value. | VarChar | 70 |
 | RTP_ORDER | The order of the runtime parameter in the test. | Integer | 4 |

Indexes

Index | Primary | Unique
RTP_PRIMARYKEY |  |
RTP_TEST_ID_IDX |  |

See Also

Quality Center Database


%%LocalItemTitle%%

RUNTIME_PARAM Table | Quality Center Database

RTP_PRIMARYKEY Index

Description

Index Properties

Primary Key | Yes
Unique Values | Yes

Columns

 | Column | Sort Order
Primary Key | RTP_ID | Ascending

Description

See Also

RUNTIME_PARAM Table | Quality Center Database


%%LocalItemTitle%%

RUNTIME_PARAM Table | Quality Center Database

RTP_TEST_ID_IDX Index

Description

Index Properties

Primary Key | No
Unique Values | No

Columns

Column | Sort Order
RTP_TEST_ID | Ascending

Description

See Also

RUNTIME_PARAM Table | Quality Center Database


%%LocalItemTitle%%

Quality Center Database

SEQUENCES Table

Description

A system table to manage IDs and other system numerators. Do not change values in this table.

Columns

 | Column Name | Description | Datatype | Length | Allow Nulls
Primary Key | SQ_SEQ_NAME | The name of the table or other entity whose numeration is being tracked. | VarChar | 30 |
 | SQ_SEQ_VALUE | The highest current value. | Integer | 4 |

Indexes

Index | Primary | Unique
SQ_PRIMARYKEY |  |

See Also

Quality Center Database


%%LocalItemTitle%%

SEQUENCES Table | Quality Center Database

SQ_PRIMARYKEY Index

Description

Index Properties

Primary Key | Yes
Unique Values | Yes

Columns

 | Column | Sort Order
Primary Key | SQ_SEQ_NAME | Ascending

Description

See Also

SEQUENCES Table | Quality Center Database


%%LocalItemTitle%%

Quality Center Database

STEP Table

Description

Test steps performed during a test instance runs.

Columns

 | Column Name | Description | Datatype | Length | Allow Nulls
Primary Key | ST_ID | The record ID. | Integer | 4 |
 | ST_RUN_ID | The RUN.RN_RUN_ID of the test instance run to which this step belongs. | Integer | 4 |
 | ST_STEP_NAME | The name of the test step. | VarChar | 255 |
 | ST_STATUS | The status of the test step. The values are from the Status custom list. Typical values are: Not Completed, No Run, Passed, N/A, Failed. | VarChar | 70 |
 | ST_EXECUTION_DATE | The date on which the test step was executed. | DBTimeStamp | 4 |
 | ST_EXECUTION_TIME | The time at which the test step was executed. | VarChar | 10 |
 | ST_DESCRIPTION | The step description. | LongVarChar | 16 |
 | ST_EXPECTED | The expected result of the test step. | LongVarChar | 16 |
 | ST_ACTUAL | The actual result of the test step. | LongVarChar | 16 |
 | ST_PATH | The folder of the test script containing the test step. | VarChar | 255 |
 | ST_LINE_NO | The line number on which the step appears in the test script. | Integer | 4 |
 | ST_USER_01 | User-defined field. | VarChar | 40 |
 | ST_USER_02 | User-defined field. | VarChar | 40 |
 | ST_USER_03 | User-defined field. | VarChar | 40 |
 | ST_USER_04 | User-defined field. | VarChar | 40 |
 | ST_USER_05 | User-defined field. | VarChar | 40 |
 | ST_USER_06 | User-defined field. | VarChar | 40 |
 | ST_STEP_ORDER | The order in which the step appears within the test. | Integer | 4 |
 | ST_DESSTEP_ID | The DESSTEPS.DS_ID of the design step on which the test step is based. | Integer | 4 |
 | ST_ATTACHMENT | A value of Y indicates that the step has at least one attachment. | VarChar | 1 |
 | ST_TEST_ID | The TEST.TS_TEST_ID of the test to which the step belongs. | Integer | 4 |
 | ST_OBJ_ID | The type of manual step when running test manually. The values are: 0 - Test, 1 - Test iteration, 2 - Group, 3 - Group iteration, 4- Inner Component, 5 - Leaf Component, 6 - Component iteration, 7 - Component Step, 8 - Test instance iteration. | Integer | 4 |
 | ST_LEVEL | The depth in the manual runner tree. Tests in the root are level 0. | Integer | 4 |
 | ST_EXTENDED_REFERENCE | For backward compatibility. Field may be removed in future version. | VarChar | 50 |
 | ST_COMPONENT_DATA | For backward compatibility. Field may be removed in future version. | LongVarChar | 16 |
 | ST_PARENT_ID | The record ID of the parent node in the tree. For a component step, for example, the ID of the component that includes the step, which is also the parent node of the step in the manual runner tree. | Integer | 4 |

Indexes

Index | Primary | Unique
ST_PRIMARYKEY |  |
ST_RUN_IDX |  |
ST_TEST_ID_IDX |  |
STEP_IDX3 |  |

See Also

Quality Center Database


%%LocalItemTitle%%

Quality Center Database

STEP_PARAMS Table

Description

Parameters for executing manual tests.

Remarks

Actual run parameter values are linked to design tests with the TEST, RUN, and CYCLE tables where To_number(STEP_PARAMS.SP_KEY) = RUN.RN_RUN_ID AND TEST.TS_TEST_ID = RUN.RN_TEST_ID AND RUN.RN_CYCLE_ID = CYCLE.CY_CYLE_ID.

Design step parameters are associated with the design test where To_number(SP_KEY) = TEST.TS_TEST_ID.

Columns

 | Column Name | Description | Datatype | Length | Allow Nulls
Primary Key | SP_ENTITY | The name of the table containing the entity for which the parameter was created. | VarChar | 40 |
Primary Key | SP_KEY | The string representation of the record ID of the instance to which the parameter belongs in the table specified by SP_ENTITY . | VarChar | 40 |
Primary Key | SP_PARAM_NAME | The parameter name. | VarChar | 255 |
 | SP_PARAM_VALUE | The parameter value. | VarChar | 255 |
 | SP_ORIGIN_TEST | The TEST.TS_TEST_ID of the design test from which the step is derived. | Integer | 4 |
 | SP_VALUE_FROM_ENTITY | For backward compatibility. Field may be removed in future version. | VarChar | 40 |
 | SP_VALUE_FROM_KEY | For backward compatibility. Field may be removed in future version. | VarChar | 50 |
 | SP_REF_COUNT | The number of steps in which this parameter is used. Applies only to Test entities. | Integer | 4 |
 | SP_ASSIGNED_BY | For backward compatibility. Field may be removed in future version. | VarChar | 40 |
 | SP_ASSIGN_DATE | For backward compatibility. Field may be removed in future version. | DBTimeStamp | 4 |
 | SP_ASSIGN_TIME | For backward compatibility. Field may be removed in future version. | VarChar | 12 |

Indexes

Index | Primary | Unique
SP_PRIMARYKEY |  |

See Also

Quality Center Database


%%LocalItemTitle%%

STEP_PARAMS Table | Quality Center Database

SP_PRIMARYKEY Index

Description

Index Properties

Primary Key | Yes
Unique Values | Yes

Columns

 | Column | Sort Order
Primary Key | SP_ENTITY | Ascending
Primary Key | SP_KEY | Ascending
Primary Key | SP_PARAM_NAME | Ascending

Description

See Also

STEP_PARAMS Table | Quality Center Database


%%LocalItemTitle%%

Quality Center Database

SYSTEM_FIELD Table

Description

Meta-data about data fields in other tables. Stores settings from project entity customizations and system defaults.

Columns

 | Column Name | Description | Datatype | Length | Allow Nulls
Primary Key | SF_TABLE_NAME | The name of the table containing the field being described. | VarChar | 40 |
Primary Key | SF_COLUMN_NAME | The field being described. | VarChar | 40 |
 | SF_COLUMN_TYPE | The data type, such as DATE, char, memo, number, or time. | VarChar | 20 |
 | SF_USER_LABEL | The display label text. | VarChar | 100 |
 | SF_EDIT_STYLE | The type of control used to edit the value if the specific application window supports controls. If edit style is an empty string or controls are not supported, a text edit box is used. | VarChar | 50 |
 | SF_EDIT_MASK | A mask for controlling input format for strings such as phone numbers, dates, ID numbers, and the like. | VarChar | 50 |
 | SF_IS_SYSTEM | A value of Y indicates a system field. N indicates a user defined field. | VarChar | 1 |
 | SF_IS_CANFILTER | A value of Y indicates that the users can add the field to a view filter. N indicates that the field cannot be used in a filter. | VarChar | 1 |
 | SF_IS_KEY | A value of Y indicates that the field is a member of an index. | VarChar | 1 |
 | SF_KEY_ORDER | For backward compatibility. Field may be removed in future version. | Integer | 4 |
 | SF_IS_EDIT | A value of Y indicates that the field value can be changed by users. N indicates a calculated or fixed value. | VarChar | 1 |
 | SF_IS_ACTIVE | A value of Y indicates that the field can be displayed in the User Interface. | VarChar | 1 |
 | SF_IS_HISTORY | A value of Y indicates that change records are kept on this field. | VarChar | 1 |
 | SF_IS_MAIL | A value of Y indicates that users are notified when the value of this field is changed. | VarChar | 1 |
 | SF_IS_VERIFY | A value of Y indicates that the field value must be an item in a list. Most verification is done against named lists in the ALL_LISTS Table. User name fields are checked against the USERS Table. Subject fields are from the subject tree in the ALL_LISTS Table. | VarChar | 1 |
 | SF_ROOT_ID | The ALL_LISTS.AL_ITEM_ID of the root of the list from which the values are taken. | Integer | 4 |
 | SF_IS_BY_CODE | A value of Y indicates that the contents of the field are the ID of a folder. | VarChar | 1 |
 | SF_IS_REQUIRED | A value of Y indicates that a value for the field is required before a user can create the entity. | VarChar | 1 |
 | SF_GRANT_MODIFY | A bit mask that specifies the groups whose members may modify the field. If bit X is set, the modify action is enabled for the group identified with GROUPS.GR_GROUP_ID = X. | VarChar | 512 |
 | SF_IS_TRANSITION_LOGIC | For backward compatibility. Field may be removed in future version. | VarChar | 1 |
 | SF_USER_COLUMN_TYPE | The type of data a user enters in a field. This is not always the same as the SF_COLUMN_TYPE. For example, a user may enter date or numerical information in a char database field. | VarChar | 20 |
 | SF_IS_KEEP_VALUE | For backward compatibility. Field may be removed in future version. | VarChar | 1 |
 | SF_IS_CUSTOMIZABLE | If Y, the field is displayed in the customization user interface. | VarChar | 1 |
 | SF_CAN_CHANGE_PERMISSIONS | For backward compatibility. Field may be removed in future version. | VarChar | 1 |
 | SF_FIELD_SIZE | The size of the field in bytes. For large object fields, such as memos, the size is -1. | Integer | 4 |
 | SF_IS_VISIBLE_IN_NEW_BUG | A bit mask that specifies the groups for whose members the field is visible in the new defect dialog. If bit X is set, the field is visible for the group identified with GROUPS.GR_GROUP_ID = X. | VarChar | 512 |
 | SF_IS_VISIBLE_FOR_GROUPS | A bit mask that specifies the groups for whose members the field is visible in the User Interface. If bit X is set, the field is visible for the group identified with GROUPS.GR_GROUP_ID = X. | VarChar | 512 |
 | SF_IS_TO_SUM | For backward compatibility. Field may be removed in future version. | VarChar | 1 |
 | SF_IS_UNDER_VCS | If Y, the field is under configuration control. Applicable only to test fields. | VarChar | 1 |
 | SF_OWNER_SENSIBLE | A bit mask that specifies groups. The modify action is enabled for the owner of the entity if the owner belongs to a group whose bit is set. The group's bit is the bit corresponding to the GROUPS.GR_GROUP_ID value. | VarChar | 512 |
 | SF_CAN_GROUP | If Y, the field can be grouped in the UI. | VarChar | 1 |
 | SF_IS_SEARCHABLE | If Y, searching in the values of the field is enabled. | VarChar | 1 |
 | SF_IS_VIRTUAL | If Y, the field does not have a physical representation in the database. | VarChar | 1 |
 | SF_IS_MULTIVALUE | Indicates whether the field can contain multiple values from a look-up list. If true (Y), the UI control linked to the field supports multiple selection and the field contains a semicolon-separated list of values. Note: The values are denormalized for performance reasons. Any program that alters the values in the specified field must also handle the [entity]_MULTIVALUE entries. | VarChar | 1 |
 | SF_REFERENCE_TABLE | The name of the table containing the displayed value. If this field is in use, set SF_IS_BY_CODE to Y. | VarChar | 40 |
 | SF_REFERENCE_ID_COLUMN | The name of the table containing the key. If this field is in use, set SF_IS_BY_CODE to Y. | VarChar | 40 |
 | SF_REFERENCE_NAME_COLUMN | The name of the column containing the displayed value. If this field is in use, set SF_IS_BY_CODE to Y. | VarChar | 40 |

Indexes

Index | Primary | Unique
SF_PRIMARYKEY |  |

See Also

Quality Center Database


%%LocalItemTitle%%

SYSTEM_FIELD Table | Quality Center Database

SF_PRIMARYKEY Index

Index Properties

Primary Key | Yes
Unique Values | Yes

Columns

 | Column | Sort Order
Primary Key | SF_TABLE_NAME | Ascending
Primary Key | SF_COLUMN_NAME | Ascending

See Also

SYSTEM_FIELD Table | Quality Center Database


%%LocalItemTitle%%

Quality Center Database

SYSTRANSLATE Table

Description

For backward compatablity. This table may be removed in future versions.

Indexes

Index | Primary | Unique
SYSTRAN_PRIMARYKEY |  |

See Also

Quality Center Database


%%LocalItemTitle%%

SYSTRANSLATE Table | Quality Center Database

SYSTRAN_PRIMARYKEY Index

Index Properties

Primary Key | Yes
Unique Values | Yes

Columns

 | Column | Sort Order
Primary Key | ENGLISHVALUE | Ascending

See Also

SYSTRANSLATE Table | Quality Center Database


%%LocalItemTitle%%

Quality Center Database

TABLES Table

Description

Permissions by user group to change data.

Remarks

Fields that control permissions are bit masks that specify the groups whose members can perform the action. If bit X is set, the action is enabled for the group identified with GROUPS.GR_GROUP_ID = X.

For owner-sensible fields, the owner, as defined in TB_OWNER_FIELD_NAME, can perform the action if the owner is a member of a group whose corresponding bit in the owner-sensible field is set. For example, if bit one is set in TB_OWNER_SENSIBLE_DELETE and the owner belongs to group one, the owner can delete the record.

If the entire group has the privilege, the owner-sensible bit is not checked by Quality Center. For example, if bit one is set in TB_GRANT_DELETE and the owner belongs to group one, the owner can delete the record regardless of the value of TB_OWNER_SENSIBLE_DELETE.

Columns

 | Column Name | Description | Datatype | Length | Allow Nulls
Primary Key | TB_TABLE_NAME | The name of the table. | VarChar | 40 |
 | TB_GRANT_DELETE | Permissions to delete records. | VarChar | 512 |
 | TB_OWNER_SENSIBLE_DELETE | The owner can delete the record if a member of the group. | VarChar | 512 |
 | TB_GRANT_MODIFY | Permissions to modify records. | VarChar | 512 |
 | TB_OWNER_SENSIBLE_MODIFY | The owner can modify the record if a member of the group. | VarChar | 512 |
 | TB_GRANT_ADD | Permissions to add records. | VarChar | 512 |
 | TB_OWNER_FIELD_NAME | The column in the table that specifies the owner. | VarChar | 40 |
 | TB_AUDIT_ADD | For future use. | VarChar | 1 |
 | TB_AUDIT_DELETE | For future use. | VarChar | 1 |
 | TB_USER_LABEL | Label used when an entity type is presented in the User Interface. For example, the label is used when linking entities. | VarChar | 120 |
 | TB_IS_CUSTOMIZABLE | A value of Y indicates that the entity can be customized in the user interface. | VarChar | 1 |

Indexes

Index | Primary | Unique
TB_PRIMARYKEY |  |

See Also

Quality Center Database


%%LocalItemTitle%%

TABLES Table | Quality Center Database

TB_PRIMARYKEY Index

Index Properties

Primary Key | Yes
Unique Values | Yes

Columns

 | Column | Sort Order
Primary Key | TB_TABLE_NAME | Ascending

See Also

TABLES Table | Quality Center Database


%%LocalItemTitle%%

Quality Center Database

TEST Table

Description

Details of the design test from the test plan module.

Remarks

A test plan subject is a conceptual unit of testing. A subject acts as a folder for other subjects and for tests. The folder structure for test plan subjects is in the ALL_LISTS Table where test folders are descended from the record where ALL_LISTS.AL_DESCRIPTION = 'Subject'. The link from the TEST record to the test folder is the TS_SUBJECT field.

To see test coverage of requirements, use the REQ_COVER Table.

Design tests are linked to design steps with DESSTEPS.DS_TEST_ID.

Tests are linked to test sets in the TESTCYCL Table.

Tests are linked to test runs with RUN.RN_TEST_ID.

Tests are linked to actual run parameter values with the STEP_PARAMS, RUN, and CYCLE tables where To_number(STEP_PARAMS.SP_KEY) = RUN.RN_RUN_ID AND TEST.TS_TEST_ID = RUN.RN_TEST_ID AND RUN.RN_CYCLE_ID = CYCLE.CY_CYLE_ID.

Multiple values for fields are maintained in the TEST_MULTIVALUE Table.

For table relationships, , see the Test Plan Module Overview.

Columns

 | Column Name | Description | Datatype | Length | Allow Nulls
Primary Key | TS_TEST_ID | The record ID. | Integer | 4 |
 | TS_NAME | The name of the test. | VarChar | 255 |
 | TS_STEPS | The number of design steps in the test. | Integer | 4 |
 | TS_PATH | The path of this test relative to the Tests directory in the server repository, whether on the file system or in a database. This is the location for automatic scripts linked to the test. To get the script files, use the Open Test Architecture API. | VarChar | 255 |
 | TS_SUBJECT | The ALL_LISTS.AL_ITEM_ID of the test plan subject folder in which the test resides. | Integer | 4 |
 | TS_STATUS | The test’s current status. The values are from the Plan Status custom list. Typical values are: Ready, Design, Imported, Repair. | VarChar | 70 |
 | TS_RESPONSIBLE | The user responsible for implementing the test. | VarChar | 60 |
 | TS_CREATION_DATE | The date on which the test was created. | DBTimeStamp | 4 |
 | TS_DESCRIPTION | A description of the test. | LongVarChar | 16 |
 | TS_TYPE | The type of test. For a description of possible test types, see The Quality Center Open Test Architecture API Reference . | VarChar | 70 |
 | TS_TIMEOUT | For backward compatibility. Field may be removed in future version. | Integer | 4 |
 | TS_ATTACHMENT | A value of Y indicates that the test has at least one attachment. | VarChar | 1 |
 | TS_RUNTIME_DATA | For backward compatibility. Field may be removed in future version. | VarChar | 255 |
 | TS_USER_01 | User-defined field. | VarChar | 40 |
 | TS_USER_02 | User-defined field. | VarChar | 40 |
 | TS_USER_03 | User-defined field. | VarChar | 40 |
 | TS_USER_04 | User-defined field. | VarChar | 40 |
 | TS_USER_05 | User-defined field. | VarChar | 40 |
 | TS_USER_06 | User-defined field. | VarChar | 40 |
 | TS_USER_07 | User-defined field. | VarChar | 40 |
 | TS_USER_08 | User-defined field. | VarChar | 40 |
 | TS_USER_09 | User-defined field. | VarChar | 40 |
 | TS_USER_10 | User-defined field. | VarChar | 40 |
 | TS_USER_11 | User-defined field. | VarChar | 40 |
 | TS_USER_12 | User-defined field. | VarChar | 40 |
 | TS_USER_HR_01 | TS_USER_HR_01 to TS_USER_HR_08 are for backward compatibility. Fields may be removed in future version. | Integer | 4 |
 | TS_ESTIMATE_DEVTIME | The time estimated to develop the test. | Integer | 4 |
 | TS_TEST_VER_STAMP | The revision number of this record. Increments each time the record is updated. | Integer | 4 |
 | TS_EXEC_STATUS | The execution status of the test. The values are from the Status custom list. Typical values are: Not Completed, No Run, Passed, N/A, Failed. | VarChar | 70 |
 | TS_TEMPLATE | A value of Y indicates that this test is a template test. | VarChar | 1 |
 | TS_STEP_PARAM | For backward compatibility. Field may be removed in future version. | Integer | 4 |
 | TS_VTS | The version time stamp of the last record update according to the database server clock. | VarChar | 20 |
 | TS_VC_CUR_VER | The last checked-in version of the test. Used by the Version Control engine. | VarChar | 50 |
 | TS_USER_13 | User-defined field. | VarChar | 40 |
 | TS_USER_14 | User-defined field. | VarChar | 40 |
 | TS_USER_15 | User-defined field. | VarChar | 40 |
 | TS_USER_16 | User-defined field. | VarChar | 40 |
 | TS_USER_17 | User-defined field. | VarChar | 40 |
 | TS_USER_18 | User-defined field. | VarChar | 40 |
 | TS_USER_19 | User-defined field. | VarChar | 40 |
 | TS_USER_20 | User-defined field. | VarChar | 40 |
 | TS_USER_21 | User-defined field. | VarChar | 40 |
 | TS_USER_22 | User-defined field. | VarChar | 40 |
 | TS_USER_23 | User-defined field. | VarChar | 40 |
 | TS_USER_24 | User-defined field. | VarChar | 40 |
 | TS_TEXT_SYNC | For internal use. Do not change data. | VarChar | 1 |
 | TS_DEV_COMMENTS | Comments about the test design, usually by the developer. | LongVarChar | 16 |

Indexes

Index | Primary | Unique
TS_PRIMARYKEY |  |
TS_SUBJECT_IDX |  |
TS_SUBJECT_NAME_IDX |  |
TS_EXEC_STATUS_LWR_IDX |  |
TS_PATH_LWR_INDEX |  |
TS_RESPONSIBLE_LWR_IDX |  |
TS_STATUS_LWR_IDX |  |

Triggers

Trigger | Description
AUTR2571410_TEST |

See Also

Quality Center Database


%%LocalItemTitle%%

Quality Center Database

TEST_MULTIVALUE Table

Description

Multiple values of test records.

Columns

Column Name | Description | Datatype | Length | Allow Nulls
TSMV_TEST_ID | The TEST.TS_TEST_ID of the test containing the multiple values. | Integer | 4 |
TSMV_COLUMN_NAME | The multi-value column. | VarChar | 40 |
TSMV_VALUE | A single value. Note: The values are denormalized for performance reasons. Any program that alters the values in this value field must also handle the semicolon-separated value in the main entity table. | VarChar | 255 |

Indexes

Index | Primary | Unique
INX_TSMV |  |
INX_TSMV_TEST_ID |  |

See Also

Quality Center Database


%%LocalItemTitle%%

TEST_MULTIVALUE Table | Quality Center Database

INX_TSMV Index

Description

Index Properties

Primary Key | Yes
Unique Values | Yes

Columns

Column | Sort Order
TSMV_COLUMN_NAME | Ascending
TSMV_VALUE | Ascending
TSMV_TEST_ID | Ascending

Description

See Also

TEST_MULTIVALUE Table | Quality Center Database


%%LocalItemTitle%%

TEST_MULTIVALUE Table | Quality Center Database

INX_TSMV_TEST_ID Index

Description

Index Properties

Primary Key | Yes
Unique Values | No

Columns

Column | Sort Order
TSMV_TEST_ID | Ascending

Description

See Also

TEST_MULTIVALUE Table | Quality Center Database


%%LocalItemTitle%%

Quality Center Database

TEST_VC_INFO Table

Description

Used internally by version control plug-in. Do not change values in this table.

Indexes

Index | Primary | Unique
TVCI_PRIMARYKEY |  |

See Also

Quality Center Database


%%LocalItemTitle%%

TEST_VC_INFO Table | Quality Center Database

TVCI_PRIMARYKEY Index

Description

Index Properties

Primary Key | Yes
Unique Values | Yes

Columns

 | Column | Sort Order
Primary Key | TVCI_ID | Ascending

Description

See Also

TEST_VC_INFO Table | Quality Center Database


%%LocalItemTitle%%

Quality Center Database

TESTCYCL Table

Description

Instances of design tests in test sets.

Remarks

A test can be used more than once in a test set. Each use is an instance. This table stores the position (order) of each instance and some data about the instance.

Multiple values for fields are maintained in the TESTCYCL_MULTIVALUE Table.

Columns

 | Column Name | Description | Datatype | Length | Allow Nulls
Primary Key | TC_TESTCYCL_ID | The record ID. | Integer | 4 |
 | TC_CYCLE_ID | The CYCLE.CY_CYCLE_ID of the test set containing this test. | Integer | 4 |
 | TC_TEST_ID | The TEST.TS_TEST_ID of the design test of which this is an instance. | Integer | 4 |
 | TC_CYCLE | For backward compatibility. Field may be removed in future version. | VarChar | 255 |
 | TC_TEST_ORDER | The order in which the test instance appears within the test set in the user interface. | Integer | 4 |
 | TC_STATUS | The status of the last run of the test instance. The values are from the Status custom list. Typical values are: Not Completed, No Run, Passed, N/A, Failed. | VarChar | 70 |
 | TC_TESTER_NAME | The user name of the person responsible for running the test. | VarChar | 60 |
 | TC_EXEC_DATE | The date on which the test was last executed. | DBTimeStamp | 4 |
 | TC_EXEC_TIME | The time at which the test was last executed. | VarChar | 10 |
 | TC_PLAN_SCHEDULING_DATE | The date on which the tester plans to next run the test. | DBTimeStamp | 4 |
 | TC_PLAN_SCHEDULING_TIME | The time at which the tester plans to next run the test. | VarChar | 10 |
 | TC_HOST_NAME | The name or IP address of the host server on which the test is planned to be executed. | VarChar | 50 |
 | TC_EPARAMS | The application-dependant configuration string created by the testing tool. | LongVarChar | 16 |
 | TC_ATTACHMENT | A value of Y indicates thethe test instance has at least one attachment. | VarChar | 1 |
 | TC_USER_01 | User-defined field. | VarChar | 40 |
 | TC_USER_02 | User-defined field. | VarChar | 40 |
 | TC_USER_03 | User-defined field. | VarChar | 40 |
 | TC_USER_04 | User-defined field. | VarChar | 40 |
 | TC_USER_05 | User-defined field. | VarChar | 40 |
 | TC_USER_06 | User-defined field. | VarChar | 40 |
 | TC_USER_07 | User-defined field. | VarChar | 40 |
 | TC_USER_08 | User-defined field. | VarChar | 40 |
 | TC_USER_09 | User-defined field. | VarChar | 40 |
 | TC_USER_10 | User-defined field. | VarChar | 40 |
 | TC_USER_11 | User-defined field. | VarChar | 40 |
 | TC_USER_12 | User-defined field. | VarChar | 40 |
 | TC_TEST_VERSION | For backward compatibility. This field may be removed in future version | Integer | 4 |
 | TC_TESTCYCLE_VER_STAMP | The revision number of this record. Increments each time the record is updated. | Integer | 4 |
 | TC_EXEC_EVENT_HANDLE | The actions to be executed in response to various test set execution events. This field is in a proprietary format. | LongVarChar | 16 |
 | TC_VTS | The time this record was last updated according to the database server clock. | VarChar | 20 |
 | TC_TEST_INSTANCE | The number of this test instance inside the cycle. This field enables several test instances with the same TC_TEST_ID to reside within the same test set. | Integer | 4 |
 | TC_USER_13 | User-defined field. | VarChar | 40 |
 | TC_USER_14 | User-defined field. User-defined field. | VarChar | 40 |
 | TC_USER_15 | User-defined field. | VarChar | 40 |
 | TC_USER_16 | User-defined field. | VarChar | 40 |
 | TC_USER_17 | User-defined field. | VarChar | 40 |
 | TC_USER_18 | User-defined field. | VarChar | 40 |
 | TC_USER_19 | User-defined field. | VarChar | 40 |
 | TC_USER_20 | User-defined field. | VarChar | 40 |
 | TC_USER_21 | User-defined field. | VarChar | 40 |
 | TC_USER_22 | User-defined field. | VarChar | 40 |
 | TC_USER_23 | User-defined field. | VarChar | 40 |
 | TC_USER_24 | User-defined field. | VarChar | 40 |
 | TC_OS_CONFIG | For future use. | VarChar | 40 |
 | TC_ACTUAL_TESTER | The user who last executed this test instance. | VarChar | 60 |
 | TC_DATA_OBJ | An XML string containing parameter values for Business Process Test iterations. | LongVarChar | 16 |
 | TC_ITERATIONS | Contains information about the BPT test iterations that will be performed when executing this test. Theformat is: <total defined iterations>;<first iteration>;<last iteration>. If all defined iterations are to be run, the field may be empty. | VarChar | 255 |
 | TC_ASSIGN_RCYC | The RELEASE_CYCLES.RCYC_ID of the release cycle with which the test instance is associated. | Integer | 4 |

Indexes

Index | Primary | Unique
TC_PRIMARYKEY |  |
TC_TESTCYCLE_IDX |  |
TC_ACTUAL_TESTER_LWR_IDX |  |
TC_ASSIGN_RCYC_IDX |  |
TC_STATUS_LWR_IDX |  |
TC_TEST_ID_IDX |  |
TC_TESTER_NAME_LWR_IDX |  |

Triggers

Trigger | Description
AUTR_363696399_TESTCYCL |

See Also

Quality Center Database


%%LocalItemTitle%%

Quality Center Database

TESTCYCL_MULTIVALUE Table

Description

Multiple values of test cycle - test instance records.

Columns

Column Name | Description | Datatype | Length | Allow Nulls
TCMV_TESTCYCL_ID | The TESTCYCL.TC_TESTCYCL_ID of the design test instance. | Integer | 4 |
TCMV_COLUMN_NAME | The multi-value column. | VarChar | 40 |
TCMV_VALUE | A single value. Note: The values are denormalized for performance reasons. Any program that alters the values in this value field must also handle the semicolon-separated value in the main entity table. | VarChar | 255 |

Indexes

Index | Primary | Unique
INX_TCMV |  |
INX_TCMV_TESTCYCL_ID |  |

See Also

Quality Center Database


%%LocalItemTitle%%

TESTCYCL_MULTIVALUE Table | Quality Center Database

INX_TCMV Index

Description

Index Properties

Primary Key | Yes
Unique Values | Yes

Columns

Column | Sort Order
TCMV_COLUMN_NAME | Ascending
TCMV_VALUE | Ascending
TCMV_TESTCYCL_ID | Ascending

Description

See Also

TESTCYCL_MULTIVALUE Table | Quality Center Database


%%LocalItemTitle%%

TESTCYCL_MULTIVALUE Table | Quality Center Database

INX_TCMV_TESTCYCL_ID Index

Index Properties

Primary Key | Yes
Unique Values | No

Columns

Column | Sort Order
TCMV_TESTCYCL_ID | Ascending

See Also

TESTCYCL_MULTIVALUE Table | Quality Center Database


%%LocalItemTitle%%

Quality Center Database

TO_ALERT Table

Description

For internal use. Do not change data in this table.

See Also

Quality Center Database


%%LocalItemTitle%%

Quality Center Database

TOKENS Table

Description

Assists in searching for similar defects.

Remarks

Tokens are linked to defects by the BUG_TOKENS Table.

Columns

 | Column Name | Description | Datatype | Length | Allow Nulls
Primary Key | TK_ID | The record ID. | Integer | 4 |
 | TK_TOKEN | The token. | VarChar | 255 |

Indexes

Index | Primary | Unique
TK_PRIMARYKEY |  |
TK_TOKEN_IDX |  |

See Also

Quality Center Database


%%LocalItemTitle%%

TOKENS Table | Quality Center Database

TK_PRIMARYKEY Index

Description

Index Properties

Primary Key | Yes
Unique Values | Yes

Columns

 | Column | Sort Order
Primary Key | TK_ID | Ascending

Description

See Also

TOKENS Table | Quality Center Database


%%LocalItemTitle%%

TOKENS Table | Quality Center Database

TK_TOKEN_IDX Index

Index Properties

Primary Key | No
Unique Values | Yes

Columns

Column | Sort Order
TK_TOKEN | Ascending

See Also

TOKENS Table | Quality Center Database


%%LocalItemTitle%%

Quality Center Database

TRAN_RULES Table

Description

Permitted status changes per group.

Remarks

This table defines permitted changes from one status to another by group. For example, TR_TABLE_NAME is BUG, TR_FIELD_NAME is BG_STATUS, TR_GROUP_ID is 1, and TR_RULES is Open,FixedReopen,FixedOpen,RejectedReopen,Rejected. This means that members of group 1 can change a defect status from Open to Fixed, from Reopen to Fixed, from Open to Rejected, and from Reopen to Rejected. All other status changes are denied.

Columns

 | Column Name | Description | Datatype | Length | Allow Nulls
Primary Key | TR_TABLE_NAME | The table containing the field to which the rule applies. | VarChar | 40 |
Primary Key | TR_FIELD_NAME | The field to which the rule applies. | VarChar | 40 |
Primary Key | TR_GROUP_ID | The GROUPS.GR_GROUP_ID of the group to which the rule applies. | Integer | 4 |
 | TR_RULES | One or more allowed transitions. The initial value (or $ANY) is separated by a comma from the permitted target value. There is no separation between a target value and the initial value of the next permitted transition. | LongVarChar | 16 |

Indexes

Index | Primary | Unique
TR_PRIMARYKEY |  |

See Also

Quality Center Database


%%LocalItemTitle%%

TRAN_RULES Table | Quality Center Database

TR_PRIMARYKEY Index

Description

Index Properties

Primary Key | Yes
Unique Values | Yes

Columns

 | Column | Sort Order
Primary Key | TR_TABLE_NAME | Ascending
Primary Key | TR_FIELD_NAME | Ascending
Primary Key | TR_GROUP_ID | Ascending

Description

See Also

TRAN_RULES Table | Quality Center Database


%%LocalItemTitle%%

Quality Center Database

USERS Table

Description

System users who can access this project.

Columns

 | Column Name | Description | Datatype | Length | Allow Nulls
Primary Key | US_USERNAME | The user name. | VarChar | 60 |
 | US_MAIL_ADDRESS | The user's email address. | VarChar | 255 |
 | US_PASSWORD | For backward compatibility. Field may be removed in future version. | VarChar | 100 |
 | US_GROUP | A bit mask that specifies the groups to which the user belongs. If bit X is set, the user belongs to the group identified with GROUPS.GR_GROUP_ID = X. | VarChar | 512 |
 | US_ADDRESS | The user's address. | LongVarChar | 16 |
 | US_PHONE | The user's telephone number. | VarChar | 20 |
 | US_FULLNAME | The user's name. | VarChar | 255 |

Indexes

Index | Primary | Unique
US_PRIMARYKEY |  |

See Also

Quality Center Database


%%LocalItemTitle%%

USERS Table | Quality Center Database

US_PRIMARYKEY Index

Description

Index Properties

Primary Key | Yes
Unique Values | Yes

Columns

 | Column | Sort Order
Primary Key | US_USERNAME | Ascending

Description

See Also

USERS Table | Quality Center Database


%%LocalItemTitle%%

Quality Center Database

VC_CROS_REF Table

Description

Version control table for attachments.

Columns

 | Column Name | Description | Datatype | Length | Allow Nulls
 | CR_ENTITY | The name of the table containing the item to which the file or URL is attached. | VarChar | 30 |
 | CR_KEY_1 | The string representation of the key in the table specified in CR_ENTITY. The key can be the ID field or a compound key. If a compound key, the values of the key fields are separated by a tilde (~). | VarChar | 40 |
Primary Key | CR_REF_ID | The CROS_REF.CR_REF_ID of the item under version control. | Integer | 4 |
 | CR_REFERENCE | The file name or URL. If a file, CR_REFERENCE is CR_ENTITY + CR_KEY_1 + the name of the original uploaded file. | VarChar | 255 |
 | CR_REF_TYPE | The type of attachment: either File or Internet Web Address. | VarChar | 20 |
 | CR_REF_SUBTYPE | This property is used only in Quality Center 9.2. It's use will be discontinued in later versions. A value of enum TDAPI_ATTACH_SUBTYPE. | Integer | 4 |
 | CR_DESCRIPTION | A description of the attachment. | LongVarChar | 16 |
 | CR_VC_CUR_VER | For backward compatibility. Field may be removed in future version. | VarChar | 50 |
Primary Key | CR_VC_USER_NAME | The user who locked the entity. | VarChar | 60 |

Indexes

Index | Primary | Unique
VCCR_PRIMARYKEY |  |
VCCR_ENTITY_KEY_IDX |  |
VCCR_VC_USER_NAME_IDX |  |

See Also

Quality Center Database


%%LocalItemTitle%%

VC_CROS_REF Table | Quality Center Database

VCCR_ENTITY_KEY_IDX Index

Description

Index Properties

Primary Key | No
Unique Values | No

Columns

Column | Sort Order
CR_ENTITY | Ascending
CR_KEY_1 | Ascending

Description

See Also

VC_CROS_REF Table | Quality Center Database


%%LocalItemTitle%%

VC_CROS_REF Table | Quality Center Database

VCCR_PRIMARYKEY Index

Description

Index Properties

Primary Key | Yes
Unique Values | Yes

Columns

 | Column | Sort Order
Primary Key | CR_REF_ID | Ascending
Primary Key | CR_VC_USER_NAME | Ascending

Description

See Also

VC_CROS_REF Table | Quality Center Database


%%LocalItemTitle%%

VC_CROS_REF Table | Quality Center Database

VCCR_VC_USER_NAME_IDX Index

Index Properties

Primary Key | No
Unique Values | No

Columns

 | Column | Sort Order
Primary Key | CR_VC_USER_NAME | Ascending

See Also

VC_CROS_REF Table | Quality Center Database


%%LocalItemTitle%%

Quality Center Database

VC_DESSTEPS Table

Description

Version control table for design steps.

Columns

 | Column Name | Description | Datatype | Length | Allow Nulls
Primary Key | DS_ID | The DESSTEPS.DS_ID of the item under version control. | Integer | 4 |
 | DS_TEST_ID | The TEST.TS_TEST_ID of the test to which the step belongs. | Integer | 4 |
 | DS_STEP_ORDER | The order in which the step appears within the test in the user interface. | Integer | 4 |
 | DS_STEP_NAME | The name assigned to the step by the test developer. | VarChar | 255 |
 | DS_DESCRIPTION | The design step description. | LongVarChar | 16 |
 | DS_EXPECTED | The expected result string. | LongVarChar | 16 |
 | DS_USER_01 | User-defined field. | VarChar | 40 |
 | DS_USER_02 | User-defined field. | VarChar | 40 |
 | DS_USER_03 | User-defined field. | VarChar | 40 |
 | DS_USER_04 | User-defined field. | VarChar | 40 |
 | DS_USER_05 | User-defined field. | VarChar | 40 |
 | DS_USER_06 | User-defined field. | VarChar | 40 |
 | DS_ATTACHMENT | Indicates whether the design step has any attachments: Y or N. | VarChar | 1 |
 | DS_LINK_TEST | If the design step is an instruction to run another test, the ID of the test to be run. | Integer | 4 |
 | DS_HAS_PARAMS | Indicates whether this design step has STEP_PARAMSassociated with it: Y or N. | VarChar | 1 |
 | DS_TEXT_SYNC | For internal use. Do not change data. | VarChar | 1 |
Primary Key | DS_VC_USER_NAME | The user who locked the entity. | VarChar | 60 |

Indexes

Index | Primary | Unique
VCDS_PRIMARYKEY |  |
VCDS_LINK_TEST |  |
VCDS_TEST |  |
VCDS_VC_USER_NAME_IDX |  |

See Also

Quality Center Database


%%LocalItemTitle%%

VC_DESSTEPS Table | Quality Center Database

VCDS_LINK_TEST Index

Description

Index Properties

Primary Key | No
Unique Values | No

Columns

Column | Sort Order
DS_LINK_TEST | Ascending

Description

See Also

VC_DESSTEPS Table | Quality Center Database


%%LocalItemTitle%%

VC_DESSTEPS Table | Quality Center Database

VCDS_PRIMARYKEY Index

Description

Index Properties

Primary Key | Yes
Unique Values | Yes

Columns

 | Column | Sort Order
Primary Key | DS_ID | Ascending
Primary Key | DS_VC_USER_NAME | Ascending

Description

See Also

VC_DESSTEPS Table | Quality Center Database


%%LocalItemTitle%%

VC_DESSTEPS Table | Quality Center Database

VCDS_TEST Index

Description

Index Properties

Primary Key | No
Unique Values | No

Columns

Column | Sort Order
DS_TEST_ID | Ascending

Description

See Also

VC_DESSTEPS Table | Quality Center Database


%%LocalItemTitle%%

VC_DESSTEPS Table | Quality Center Database

VCDS_VC_USER_NAME_IDX Index

Index Properties

Primary Key | No
Unique Values | No

Columns

 | Column | Sort Order
Primary Key | DS_VC_USER_NAME | Ascending

See Also

VC_DESSTEPS Table | Quality Center Database


%%LocalItemTitle%%

Quality Center Database

VC_STEP_PARAMS Table

Description

Version Control table for step parameters.

Remarks

This table controls records from the STEP_PARAMS Table.

Columns

 | Column Name | Description | Datatype | Length | Allow Nulls
Primary Key | SP_ENTITY | The name of the table containing the entity for which the parameter was created. | VarChar | 40 |
Primary Key | SP_KEY | The string representation of the record ID of the instance to which the parameter belongs in the table specified by SP_ENTITY . | VarChar | 40 |
Primary Key | SP_PARAM_NAME | The parameter name. | VarChar | 255 |
 | SP_PARAM_VALUE | The parameter value. | VarChar | 255 |
 | SP_ORIGIN_TEST | The TEST.TS_TEST_ID of the design test from which the step is derived. | Integer | 4 |
 | SP_VALUE_FROM_ENTITY | For backward compatibility. Field may be removed in future version. | VarChar | 40 |
 | SP_VALUE_FROM_KEY | For backward compatibility. Field may be removed in future version. | VarChar | 50 |
 | SP_REF_COUNT | The number of steps in which this parameter is used. Applies only to Test entities. | Integer | 4 |
 | SP_ASSIGNED_BY | For backward compatibility. Field may be removed in future version. | VarChar | 40 |
 | SP_ASSIGN_DATE | For backward compatibility. Field may be removed in future version. | DBTimeStamp | 4 |
 | SP_ASSIGN_TIME | For backward compatibility. Field may be removed in future version. | VarChar | 12 |
Primary Key | SP_VC_USER_NAME | The user who locked the entity. | VarChar | 60 |

Indexes

Index | Primary | Unique
VCSP_PRIMARYKEY |  |
VCSP_VC_USER_NAME_IDX |  |

See Also

Quality Center Database


%%LocalItemTitle%%

VC_STEP_PARAMS Table | Quality Center Database

VCSP_PRIMARYKEY Index

Description

Index Properties

Primary Key | Yes
Unique Values | Yes

Columns

 | Column | Sort Order
Primary Key | SP_ENTITY | Ascending
Primary Key | SP_KEY | Ascending
Primary Key | SP_PARAM_NAME | Ascending
Primary Key | SP_VC_USER_NAME | Ascending

Description

See Also

VC_STEP_PARAMS Table | Quality Center Database


%%LocalItemTitle%%

VC_STEP_PARAMS Table | Quality Center Database

VCSP_VC_USER_NAME_IDX Index

Index Properties

Primary Key | No
Unique Values | No

Columns

 | Column | Sort Order
Primary Key | SP_VC_USER_NAME | Ascending

See Also

VC_STEP_PARAMS Table | Quality Center Database


%%LocalItemTitle%%

Quality Center Database

VC_TEST Table

Description

Version control table for tests.

Details of the design test from the test plan module.

Remarks

A test plan subject is a conceptual unit of testing. A subject acts as a folder for other subjects and for tests. The folder structure for test plan subjects is in the ALL_LISTS Table where test folders are descended from the record where ALL_LISTS.AL_DESCRIPTION = 'Subject'. The link from the TEST record to the test folder is the TS_SUBJECT field.

To see test coverage of requirements, use the REQ_COVER Table.

Design tests are linked to design steps with DESSTEPS.DS_TEST_ID.

Tests are linked to test sets in the TESTCYCL Table.

Tests are linked to test runs with RUN.RN_TEST_ID.

Tests are linked to actual run parameter values with the STEP_PARAMS, RUN, and CYCLE tables where To_number(STEP_PARAMS.SP_KEY) = RUN.RN_RUN_ID AND TEST.TS_TEST_ID = RUN.RN_TEST_ID AND RUN.RN_CYCLE_ID = CYCLE.CY_CYLE_ID.

Multiple values for fields are maintained in the TEST_MULTIVALUE Table.

For table relationships, , see the Test Plan Module Overview.

Columns

 | Column Name | Description | Datatype | Length | Allow Nulls
Primary Key | TS_TEST_ID | The TEST.TS_TEST_ID of the item under version control. | Integer | 4 |
 | TS_NAME | The name of the test. | VarChar | 255 |
 | TS_STEPS | The number of design steps in the test. | Integer | 4 |
 | TS_PATH | The path of this test relative to the Tests directory in the server repository, whether on the file system or in a database. This is the location for automatic scripts linked to the test. To get the script files, use the Open Test Architecture API. | VarChar | 255 |
 | TS_SUBJECT | The ALL_LISTS.AL_ITEM_ID of the test plan subject folder in which the test resides. | Integer | 4 |
 | TS_STATUS | The test’s current status. The values are from the Plan Status custom list. Typical values are: Ready, Design, Imported, Repair. | VarChar | 70 |
 | TS_RESPONSIBLE | The user responsible for implementing the test. | VarChar | 60 |
 | TS_CREATION_DATE | The date on which the test was created. | DBTimeStamp | 4 |
 | TS_DESCRIPTION | A description of the test. | LongVarChar | 16 |
 | TS_TYPE | The type of test. For a description of possible test types, see The Quality Center Open Test Architecture API Reference . | VarChar | 70 |
 | TS_TIMEOUT | For backward compatibility. Field may be removed in future version. For backward compatibility. Field may be removed in future version. | Integer | 4 |
 | TS_ATTACHMENT | A value of Y indicates that the test has at least one attachment. | VarChar | 1 |
 | TS_RUNTIME_DATA | For backward compatibility. Field may be removed in future version. | VarChar | 255 |
 | TS_USER_01 | User-defined field. | VarChar | 40 |
 | TS_USER_02 | User-defined field. | VarChar | 40 |
 | TS_USER_03 | User-defined field. | VarChar | 40 |
 | TS_USER_04 | User-defined field. | VarChar | 40 |
 | TS_USER_05 | User-defined field. | VarChar | 40 |
 | TS_USER_06 | User-defined field. | VarChar | 40 |
 | TS_USER_07 | User-defined field. | VarChar | 40 |
 | TS_USER_08 | User-defined field. | VarChar | 40 |
 | TS_USER_09 | User-defined field. | VarChar | 40 |
 | TS_USER_10 | User-defined field. | VarChar | 40 |
 | TS_USER_11 | User-defined field. | VarChar | 40 |
 | TS_USER_12 | User-defined field. | VarChar | 40 |
 | TS_USER_HR_01 | TS_USER_HR_01 to TS_USER_HR_06 are for backward compatibility. Fields may be removed in future version. | Integer | 4 |
 | TS_ESTIMATE_DEVTIME | The time estimated to develop the test. | Integer | 4 |
 | TS_TEST_VER_STAMP | The revision number of this record. Increments each time the record is updated. | Integer | 4 |
 | TS_EXEC_STATUS | The execution status of the test. The values are from the Status custom list. Typical values are: Not Completed, No Run, Passed, N/A, Failed. | VarChar | 70 |
 | TS_TEMPLATE | A value of Y indicates that this test is a template test. | VarChar | 1 |
 | TS_STEP_PARAM | For backward compatibility. Field may be removed in future version. | Integer | 4 |
 | TS_VTS | The version time stamp of the last record update according to the database server clock. | VarChar | 20 |
 | TS_VC_CUR_VER | The last checked-in version of the test. Used by the Version Control engine. | VarChar | 50 |
 | TS_USER_13 | User-defined field. | VarChar | 40 |
 | TS_USER_14 | User-defined field. | VarChar | 40 |
 | TS_USER_15 | User-defined field. | VarChar | 40 |
 | TS_USER_16 | User-defined field. | VarChar | 40 |
 | TS_USER_17 | User-defined field. | VarChar | 40 |
 | TS_USER_18 | User-defined field. | VarChar | 40 |
 | TS_USER_19 | User-defined field. | VarChar | 40 |
 | TS_USER_20 | User-defined field. | VarChar | 40 |
 | TS_USER_21 | User-defined field. | VarChar | 40 |
 | TS_USER_22 | User-defined field. | VarChar | 40 |
 | TS_USER_23 | User-defined field. | VarChar | 40 |
 | TS_USER_24 | User-defined field. | VarChar | 40 |
 | TS_TEXT_SYNC | For internal use. Do not change data. | VarChar | 1 |
 | TS_DEV_COMMENTS | Developer's comment. | LongVarChar | 16 |
Primary Key | TS_VC_USER_NAME | The user who locked the entity. | VarChar | 60 |

Indexes

Index | Primary | Unique
VCTS_PRIMARYKEY |  |
TS_VC_USER_NAME_IDX |  |
VCTS_EXEC_STATUS_LWR_IDX |  |
VCTS_NAME_LWR_IDX |  |
VCTS_PATH_INDEX |  |
VCTS_RESPONSIBLE_LWR_IDX |  |
VCTS_STATUS_LWR_IDX |  |
VCTS_SUBJECT_IDX |  |

See Also

Quality Center Database


%%LocalItemTitle%%

Quality Center Database

VC_TEST_MULTIVALUE Table

Description

Multiple values for records of tests under version control.

Columns

Column Name | Description | Datatype | Length | Allow Nulls
TSMV_TEST_ID | The TEST.TS_TEST_ID. | Integer | 4 |
TSMV_COLUMN_NAME | The field containing the multi-value. | VarChar | 40 |
TSMV_VALUE | A single value. Note: The values are denormalized for performance reasons. Any program that alters the values in this value field must also handle the semicolon-separated value in the main entity table. | VarChar | 255 |
TSMV_USER_NAME | The user who locked the test. | VarChar | 60 |

Indexes

Index | Primary | Unique
INX_TSVCMV |  |
INX_TSVCMV_TEST_ID |  |

See Also

Quality Center Database


%%LocalItemTitle%%

VC_TEST_MULTIVALUE Table | Quality Center Database

INX_TSVCMV Index

Description

Index Properties

Primary Key | Yes
Unique Values | Yes

Columns

Column | Sort Order
TSMV_COLUMN_NAME | Ascending
TSMV_VALUE | Ascending
TSMV_USER_NAME | Ascending
TSMV_TEST_ID | Ascending

Description

See Also

VC_TEST_MULTIVALUE Table | Quality Center Database


%%LocalItemTitle%%

VC_TEST_MULTIVALUE Table | Quality Center Database

INX_TSVCMV_TEST_ID Index

Description

Index Properties

Primary Key | Yes
Unique Values | No

Columns

Column | Sort Order
TSMV_TEST_ID | Ascending

Description

See Also

VC_TEST_MULTIVALUE Table | Quality Center Database


%%LocalItemTitle%%

Quality Center Database

VER_CTRL Table

Description

Version control locking.

Columns

 | Column Name | Description | Datatype | Length | Allow Nulls
Primary Key | VC_OBJECT_KEY | The string representation of the key of the locked object of the entity identified by VC_OBJECT_TYPE. | VarChar | 50 |
Primary Key | VC_USER_NAME | The username of the user locking the object. | VarChar | 255 |
 | VC_STATUS | The locked object status. This is a value from the VC Status custom list. | VarChar | 20 |
 | VC_DATE | The date the object was locked. | DBTimeStamp | 4 |
 | VC_TIME | The time the object was locked. | VarChar | 10 |
 | VC_VERSION | The locked object’s version. | VarChar | 50 |
 | VC_COMMENTS | User comment. | LongVarChar | 16 |
Primary Key | VC_OBJECT_TYPE | The entity type of the locked object. | Integer | 4 |
 | VC_OBJECT_REFERENCE | The TS_TEST_ID of the locked TEST object. The field is not used for other entity types. | Integer | 4 |
 | VC_USER_03 | User-defined field. | VarChar | 40 |
 | VC_USER_04 | User-defined field. | VarChar | 40 |
 | VC_USER_05 | User-defined field. | VarChar | 40 |
 | VC_USER_06 | User-defined field. | VarChar | 40 |
 | VC_USER_07 | User-defined field. | VarChar | 40 |
 | VC_USER_08 | User-defined field. | VarChar | 40 |
 | VC_USER_09 | User-defined field. | VarChar | 40 |
 | VC_USER_10 | User-defined field. | VarChar | 40 |
 | VC_USER_11 | User-defined field. | VarChar | 40 |
 | VC_USER_12 | User-defined field. | VarChar | 40 |

Indexes

Index | Primary | Unique
VRCT_PRIMARYKEY |  |
VC_OBJECT_TYPE_IDX |  |
VC_USER_NAME_IDX |  |

See Also

Quality Center Database


%%LocalItemTitle%%

VER_CTRL Table | Quality Center Database

VC_OBJECT_TYPE_IDX Index

Description

Index Properties

Primary Key | No
Unique Values | No

Columns

 | Column | Sort Order
Primary Key | VC_OBJECT_TYPE | Ascending

Description

See Also

VER_CTRL Table | Quality Center Database


%%LocalItemTitle%%

VER_CTRL Table | Quality Center Database

VC_USER_NAME_IDX Index

Index Properties

Primary Key | No
Unique Values | No

Columns

 | Column | Sort Order
Primary Key | VC_USER_NAME | Ascending

See Also

VER_CTRL Table | Quality Center Database


%%LocalItemTitle%%

VER_CTRL Table | Quality Center Database

VRCT_PRIMARYKEY Index

Description

Index Properties

Primary Key | Yes
Unique Values | Yes

Columns

 | Column | Sort Order
Primary Key | VC_OBJECT_KEY | Ascending
Primary Key | VC_USER_NAME | Ascending
Primary Key | VC_OBJECT_TYPE | Ascending

Description

See Also

VER_CTRL Table | Quality Center Database


Copyright Page

Legal Notices

HP Quality Center Database Reference Version 9.2

Warranty

The only warranties for HP products and services are set forth in the express warranty statements accompanying such products and services. Nothing herein should be construed as constituting an additional warranty. HP shall not be liable for technical or editorial errors or omissions contained herein.

The information contained herein is subject to change without notice.

Restricted Rights Legend

Confidential computer software. Valid license from HP required for possession, use or copying. Consistent with FAR 12.211 and 12.212, Commercial Computer Software, Computer Software Documentation, and Technical Data for Commercial Items are licensed to the U.S. Government under vendor's standard commercial license.

Third-Party Web Sites

HP provides links to external third-party Web sites to help you find supplemental information. Site content and availability may change without notice. HP makes no representations or warranties whatsoever as to site content or availability.

Copyright Notices

© 2005 - 2007 Mercury Interactive Corporation, All rights reserved

Trademark Notices

Intel®is a trademark or registered trademarks of Intel Corporation or its subsidiaries in the United States and other countries.
Java™ is a US trademark of Sun Microsystems, Inc.
Microsoft® and Windows® are U.S. registered trademarks of Microsoft Corporation.
Oracle® is a registered US trademark of Oracle Corporation, Redwood City, California.
UNIX® is a registered trademark of The Open Group.

If you have any comments or suggestions regarding this document, please send them by e-mail to SW-Doc@hp.com.


%%LocalItemTitle%%

BUG Table | Quality Center Database

AUTR66132_BUG Trigger

See Also

BUG Table | Quality Center Database


%%LocalItemTitle%%

BUG Table | Quality Center Database

BG_COMPOUND_IDX Index

Description

Index Properties

Primary Key | Yes
Unique Values | No

Columns

 | Column | Sort Order
 | BG_DETECTED_BY | Ascending
 | BG_RESPONSIBLE | Ascending
 | BG_STATUS | Ascending
 | BG_PRIORITY | Ascending
Primary Key | BG_BUG_ID | Ascending

Description

See Also

BUG Table | Quality Center Database


%%LocalItemTitle%%

BUG Table | Quality Center Database

BG_PRIMARYKEY Index

Description

Index Properties

Primary Key | Yes
Unique Values | Yes

Columns

 | Column | Sort Order
Primary Key | BG_BUG_ID | Ascending

Description

See Also

BUG Table | Quality Center Database


%%LocalItemTitle%%

BUG Table | Quality Center Database

BG_TO_MAIL_IDX Index

Index Properties

Primary Key | No
Unique Values | No

Columns

Column | Sort Order
BG_TO_MAIL | Ascending

See Also

BUG Table | Quality Center Database


%%LocalItemTitle%%

COMPONENT_STEP Table | Quality Center Database

COMPSTEP_PK Index

Description

Index Properties

Primary Key | Yes
Unique Values | Yes

Columns

 | Column | Sort Order
Primary Key | CS_STEP_ID | Ascending

Description

See Also

COMPONENT_STEP Table | Quality Center Database


%%LocalItemTitle%%

COMPONENT_STEP Table | Quality Center Database

CS_COMPONENT_IDX Index

Index Properties

Primary Key | No
Unique Values | No

Columns

Column | Sort Order
CS_COMPONENT_ID | Ascending

See Also

COMPONENT_STEP Table | Quality Center Database


%%LocalItemTitle%%

COMPONENT Table | Quality Center Database

CO_FOLDER_ID_IDX Index

Description

Index Properties

Primary Key | No
Unique Values | No

Columns

Column | Sort Order
CO_FOLDER_ID | Ascending

Description

See Also

COMPONENT Table | Quality Center Database


%%LocalItemTitle%%

COMPONENT Table | Quality Center Database

FW_CO_PRIMARYKEY Index

Description

Index Properties

Primary Key | Yes
Unique Values | Yes

Columns

 | Column | Sort Order
Primary Key | CO_ID | Ascending

Description

See Also

COMPONENT Table | Quality Center Database


%%LocalItemTitle%%

CYCLE Table | Quality Center Database

AUTR64594118_CYCLE Trigger

Description

See Also

CYCLE Table | Quality Center Database


%%LocalItemTitle%%

CYCLE Table | Quality Center Database

CY_FOLDER_IDX Index

Description

Index Properties

Primary Key | Yes
Unique Values | Yes

Columns

 | Column | Sort Order
 | CY_FOLDER_ID | Ascending
Primary Key | CY_CYCLE_ID | Ascending

Description

See Also

CYCLE Table | Quality Center Database


%%LocalItemTitle%%

CYCLE Table | Quality Center Database

CY_FOLDER_NAME_IDX Index

Description

Index Properties

Primary Key | No
Unique Values | Yes

Columns

Column | Sort Order
CY_FOLDER_ID | Ascending
CY_CYCLE | Ascending

Description

See Also

CYCLE Table | Quality Center Database


%%LocalItemTitle%%

CYCLE Table | Quality Center Database

CY_PRIMARYKEY Index

Description

Index Properties

Primary Key | Yes
Unique Values | Yes

Columns

 | Column | Sort Order
Primary Key | CY_CYCLE_ID | Ascending

Description

See Also

CYCLE Table | Quality Center Database


%%LocalItemTitle%%

RBT_CUSTOMIZATION Table | Quality Center Database

INX_RBT_CUSTOM_KEY Index

Index Properties

Primary Key | No
Unique Values | Yes

Columns

Column | Sort Order
RBT_CUSTOM_KEY | Ascending

See Also

RBT_CUSTOMIZATION Table | Quality Center Database


%%LocalItemTitle%%

RBT_CUSTOMIZATION Table | Quality Center Database

RBT_CUSTOM_PRIMARYKEY Index

Index Properties

Primary Key | Yes
Unique Values | Yes

Columns

 | Column | Sort Order
Primary Key | RBT_CUSTOM_ID | Ascending

See Also

RBT_CUSTOMIZATION Table | Quality Center Database


%%LocalItemTitle%%

REQ_TYPE Table | Quality Center Database

TPR_NAME_LWR_IDX Index

Description

Index Properties

Primary Key | No
Unique Values | Yes

Columns

Column | Sort Order
TPR_NAME | Ascending

Description

See Also

REQ_TYPE Table | Quality Center Database


%%LocalItemTitle%%

REQ_TYPE Table | Quality Center Database

TPR_PRIMARYKEY Index

Index Properties

Primary Key | Yes
Unique Values | Yes

Columns

 | Column | Sort Order
Primary Key | TPR_TYPE_ID | Ascending

See Also

REQ_TYPE Table | Quality Center Database


%%LocalItemTitle%%

REQ Table | Quality Center Database

AUTR81022_REQ Trigger

See Also

REQ Table | Quality Center Database


%%LocalItemTitle%%

REQ Table | Quality Center Database

RQ_FATHER_NAME_LWR_IDX Index

Description

Index Properties

Primary Key | No
Unique Values | Yes

Columns

Column | Sort Order
RQ_FATHER_ID | Ascending
RQ_REQ_NAME | Ascending

Description

See Also

REQ Table | Quality Center Database


%%LocalItemTitle%%

REQ Table | Quality Center Database

RQ_PRIMARYKEY Index

Description

Index Properties

Primary Key | Yes
Unique Values | Yes

Columns

 | Column | Sort Order
Primary Key | RQ_REQ_ID | Ascending

Description

See Also

REQ Table | Quality Center Database


%%LocalItemTitle%%

REQ Table | Quality Center Database

RQ_REQ_PATH_IDX Index

Description

Index Properties

Primary Key | No
Unique Values | Yes

Columns

Column | Sort Order
RQ_REQ_PATH | Ascending

Description

See Also

REQ Table | Quality Center Database


%%LocalItemTitle%%

REQ Table | Quality Center Database

RQ_REQ_STATUS_IDX Index

Index Properties

Primary Key | No
Unique Values | Yes

Columns

Column | Sort Order
RQ_REQ_PATH | Ascending
RQ_REQ_STATUS | Ascending
RQ_NO_OF_SONS | Ascending

See Also

REQ Table | Quality Center Database


%%LocalItemTitle%%

REQ Table | Quality Center Database

RQ_TYPE_ID_IDX Index

Index Properties

Primary Key | Yes
Unique Values | Yes

Columns

 | Column | Sort Order
 | RQ_TYPE_ID | Ascending
Primary Key | RQ_REQ_ID | Ascending

See Also

REQ Table | Quality Center Database


%%LocalItemTitle%%

RUN Table | Quality Center Database

AUTR81515_RUN Trigger

Description

See Also

RUN Table | Quality Center Database


%%LocalItemTitle%%

RUN Table | Quality Center Database

RN_ASSIGN_RCYC_IDX Index

Description

Index Properties

Primary Key | No
Unique Values | No

Columns

Column | Sort Order
RN_ASSIGN_RCYC | Ascending
RN_TEST_ID | Ascending

Description

See Also

RUN Table | Quality Center Database


%%LocalItemTitle%%

RUN Table | Quality Center Database

RN_CYCLE_IDX Index

Description

Index Properties

Primary Key | Yes
Unique Values | Yes

Columns

 | Column | Sort Order
 | RN_CYCLE_ID | Ascending
Primary Key | RN_RUN_ID | Ascending

Description

See Also

RUN Table | Quality Center Database


%%LocalItemTitle%%

RUN Table | Quality Center Database

RN_PRIMARYKEY Index

Description

Index Properties

Primary Key | Yes
Unique Values | Yes

Columns

 | Column | Sort Order
Primary Key | RN_RUN_ID | Ascending

Description

See Also

RUN Table | Quality Center Database


%%LocalItemTitle%%

RUN Table | Quality Center Database

RN_TEST_ID_IDX Index

Description

Index Properties

Primary Key | Yes
Unique Values | Yes

Columns

 | Column | Sort Order
 | RN_TEST_ID | Ascending
Primary Key | RN_RUN_ID | Ascending

Description

See Also

RUN Table | Quality Center Database


%%LocalItemTitle%%

RUN Table | Quality Center Database

RN_TESTCYCLE_IDX Index

Description

Index Properties

Primary Key | Yes
Unique Values | Yes

Columns

 | Column | Sort Order
 | RN_TESTCYCL_ID | Ascending
Primary Key | RN_RUN_ID | Ascending

Description

See Also

RUN Table | Quality Center Database


%%LocalItemTitle%%

RUN Table | Quality Center Database

RN_TESTCYCLE_OLD_IDX Index

Description

Index Properties

Primary Key | No
Unique Values | No

Columns

Column | Sort Order
RN_CYCLE_ID | Ascending
RN_TEST_ID | Ascending
RN_TEST_INSTANCE | Ascending

Description

See Also

RUN Table | Quality Center Database


%%LocalItemTitle%%

STEP Table | Quality Center Database

ST_PRIMARYKEY Index

Description

Index Properties

Primary Key | Yes
Unique Values | Yes

Columns

 | Column | Sort Order
Primary Key | ST_ID | Ascending

Description

See Also

STEP Table | Quality Center Database


%%LocalItemTitle%%

STEP Table | Quality Center Database

ST_RUN_IDX Index

Description

Index Properties

Primary Key | Yes
Unique Values | Yes

Columns

 | Column | Sort Order
 | ST_RUN_ID | Ascending
Primary Key | ST_ID | Ascending

Description

See Also

STEP Table | Quality Center Database


%%LocalItemTitle%%

STEP Table | Quality Center Database

ST_TEST_ID_IDX Index

Description

Index Properties

Primary Key | No
Unique Values | No

Columns

Column | Sort Order
ST_TEST_ID | Ascending

Description

See Also

STEP Table | Quality Center Database


%%LocalItemTitle%%

STEP Table | Quality Center Database

STEP_IDX3 Index

Description

Index Properties

Primary Key | Yes
Unique Values | No

Columns

 | Column | Sort Order
 | ST_PARENT_ID | Ascending
Primary Key | ST_ID | Ascending

Description

See Also

STEP Table | Quality Center Database


%%LocalItemTitle%%

TESTCYCL Table | Quality Center Database

AUTR_363696399_TESTCYCL Trigger

See Also

TESTCYCL Table | Quality Center Database


%%LocalItemTitle%%

TESTCYCL Table | Quality Center Database

TC_ACTUAL_TESTER_LWR_IDX Index

Description

Index Properties

Primary Key | No
Unique Values | No

Columns

Column | Sort Order
TC_ACTUAL_TESTER | Ascending

Description

See Also

TESTCYCL Table | Quality Center Database


%%LocalItemTitle%%

TESTCYCL Table | Quality Center Database

TC_ASSIGN_RCYC_IDX Index

Description

Index Properties

Primary Key | No
Unique Values | No

Columns

Column | Sort Order
TC_ASSIGN_RCYC | Ascending
TC_TEST_ID | Ascending

Description

See Also

TESTCYCL Table | Quality Center Database


%%LocalItemTitle%%

TESTCYCL Table | Quality Center Database

TC_PRIMARYKEY Index

Description

Index Properties

Primary Key | Yes
Unique Values | Yes

Columns

 | Column | Sort Order
Primary Key | TC_TESTCYCL_ID | Ascending

Description

See Also

TESTCYCL Table | Quality Center Database


%%LocalItemTitle%%

TESTCYCL Table | Quality Center Database

TC_STATUS_LWR_IDX Index

Description

Index Properties

Primary Key | No
Unique Values | No

Columns

Column | Sort Order
TC_STATUS | Ascending

Description

See Also

TESTCYCL Table | Quality Center Database


%%LocalItemTitle%%

TESTCYCL Table | Quality Center Database

TC_TEST_ID_IDX Index

Description

Index Properties

Primary Key | No
Unique Values | No

Columns

Column | Sort Order
TC_TEST_ID | Ascending

Description

See Also

TESTCYCL Table | Quality Center Database


%%LocalItemTitle%%

TESTCYCL Table | Quality Center Database

TC_TESTCYCLE_IDX Index

Description

Index Properties

Primary Key | No
Unique Values | Yes

Columns

Column | Sort Order
TC_CYCLE_ID | Ascending
TC_TEST_ID | Ascending
TC_TEST_INSTANCE | Ascending

Description

See Also

TESTCYCL Table | Quality Center Database


%%LocalItemTitle%%

TESTCYCL Table | Quality Center Database

TC_TESTER_NAME_LWR_IDX Index

Description

Index Properties

Primary Key | No
Unique Values | No

Columns

Column | Sort Order
TC_TESTER_NAME | Ascending

Description

See Also

TESTCYCL Table | Quality Center Database


%%LocalItemTitle%%

TEST Table | Quality Center Database

AUTR2571410_TEST Trigger

See Also

TEST Table | Quality Center Database


%%LocalItemTitle%%

TEST Table | Quality Center Database

TS_EXEC_STATUS_LWR_IDX Index

Description

Index Properties

Primary Key | No
Unique Values | No

Columns

Column | Sort Order
TS_EXEC_STATUS | Ascending

Description

See Also

TEST Table | Quality Center Database


%%LocalItemTitle%%

TEST Table | Quality Center Database

TS_PATH_LWR_INDEX Index

Description

Index Properties

Primary Key | No
Unique Values | No

Columns

Column | Sort Order
TS_PATH | Ascending

Description

See Also

TEST Table | Quality Center Database


%%LocalItemTitle%%

TEST Table | Quality Center Database

TS_PRIMARYKEY Index

Description

Index Properties

Primary Key | Yes
Unique Values | Yes

Columns

 | Column | Sort Order
Primary Key | TS_TEST_ID | Ascending

Description

See Also

TEST Table | Quality Center Database


%%LocalItemTitle%%

TEST Table | Quality Center Database

TS_RESPONSIBLE_LWR_IDX Index

Description

Index Properties

Primary Key | No
Unique Values | No

Columns

Column | Sort Order
TS_RESPONSIBLE | Ascending

Description

See Also

TEST Table | Quality Center Database


%%LocalItemTitle%%

TEST Table | Quality Center Database

TS_STATUS_LWR_IDX Index

Index Properties

Primary Key | No
Unique Values | No

Columns

Column | Sort Order
TS_STATUS | Ascending

See Also

TEST Table | Quality Center Database


%%LocalItemTitle%%

TEST Table | Quality Center Database

TS_SUBJECT_IDX Index

Description

Index Properties

Primary Key | Yes
Unique Values | Yes

Columns

 | Column | Sort Order
 | TS_SUBJECT | Ascending
Primary Key | TS_TEST_ID | Ascending

Description

See Also

TEST Table | Quality Center Database


%%LocalItemTitle%%

TEST Table | Quality Center Database

TS_SUBJECT_NAME_IDX Index

Description

Index Properties

Primary Key | No
Unique Values | Yes

Columns

Column | Sort Order
TS_SUBJECT | Ascending
TS_NAME | Ascending

Description

See Also

TEST Table | Quality Center Database


%%LocalItemTitle%%

VC_TEST Table | Quality Center Database

TS_VC_USER_NAME_IDX Index

Description

Index Properties

Primary Key | No
Unique Values | No

Columns

 | Column | Sort Order
Primary Key | TS_VC_USER_NAME | Ascending

Description

See Also

VC_TEST Table | Quality Center Database


%%LocalItemTitle%%

VC_TEST Table | Quality Center Database

VCTS_EXEC_STATUS_LWR_IDX Index

Description

Index Properties

Primary Key | No
Unique Values | No

Columns

Column | Sort Order
TS_EXEC_STATUS | Ascending

Description

See Also

VC_TEST Table | Quality Center Database


%%LocalItemTitle%%

VC_TEST Table | Quality Center Database

VCTS_NAME_LWR_IDX Index

Description

Index Properties

Primary Key | No
Unique Values | No

Columns

Column | Sort Order
TS_NAME | Ascending

Description

See Also

VC_TEST Table | Quality Center Database


%%LocalItemTitle%%

VC_TEST Table | Quality Center Database

VCTS_PATH_INDEX Index

Description

Index Properties

Primary Key | No
Unique Values | No

Columns

Column | Sort Order
TS_PATH | Ascending

Description

See Also

VC_TEST Table | Quality Center Database


%%LocalItemTitle%%

VC_TEST Table | Quality Center Database

VCTS_PRIMARYKEY Index

Description

Index Properties

Primary Key | Yes
Unique Values | Yes

Columns

 | Column | Sort Order
Primary Key | TS_TEST_ID | Ascending
Primary Key | TS_VC_USER_NAME | Ascending

Description

See Also

VC_TEST Table | Quality Center Database


%%LocalItemTitle%%

VC_TEST Table | Quality Center Database

VCTS_RESPONSIBLE_LWR_IDX Index

Description

Index Properties

Primary Key | No
Unique Values | No

Columns

Column | Sort Order
TS_RESPONSIBLE | Ascending

Description

See Also

VC_TEST Table | Quality Center Database


%%LocalItemTitle%%

VC_TEST Table | Quality Center Database

VCTS_STATUS_LWR_IDX Index

Description

Index Properties

Primary Key | No
Unique Values | No

Columns

Column | Sort Order
TS_STATUS | Ascending

Description

See Also

VC_TEST Table | Quality Center Database


%%LocalItemTitle%%

VC_TEST Table | Quality Center Database

VCTS_SUBJECT_IDX Index

Index Properties

Primary Key | No
Unique Values | No

Columns

Column | Sort Order
TS_SUBJECT | Ascending

See Also

VC_TEST Table | Quality Center Database